PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
A/C Not Cold

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Sep 2012, 11:24 am
Fresh Cruiser
 
Join Date: Oct 2008
Posts: 8
Default A/C Not Cold

Hey Everyone.

First off, I must say I'm more a lurker. I frequent the site without logging in just see whats going on here and there. I've used this site for many fixes/maintenance items (plugs, motor mounts, radiator fan, etc) so I wanted to say THANKS first!

With that out of the way, here we go:

Vehicle: 2004 PT Cruiser non-turbo (Touring Edition)

I went to visit my mom. After I left her house I went to the ATM machine. It was there that the engine temp light came on due to overheating. Found out it was a faulty fan.

I replaced the fan and the car no longer overheats, but I no longer have cold A/C. I turn the A/C on and the fan only kicks on to bring engine temp down, not when I turn A/C on.

I tested both fan speeds by hooking power directly to it and both speeds came on. All fuses seem ok (under dash and under hood by relays). Low speed relay works fine. Haven't gotten around to testing high speed but from what I read, it's hardly ever the case.

LPS has been replaced.

Any other ideas?
Reply With Quote
  #2 (permalink)  
Old 18 Sep 2012, 12:04 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: A/C Not Cold

Other than having the fan tested at a shop. There are 3 main things that cause AC to not be hot.


Needs recharge. Check if the box gets cold when you have the AC on.

Condenser is not Condensing, refer to above.

ummmm cant remember the name of the part, known as the Flappy panel door :-D

Which is located in the dash, basically a well......flappy panel that opens and closes when the AC is on/off to let the cold air into the cabin.

Try disconnecting the battery for 10 min if you believe it is this. This will reset the circuit board and it may work, if not it needs replacement.
Reply With Quote
  #3 (permalink)  
Old 18 Sep 2012, 08:16 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: A/C Not Cold

If you ran your A/C with the fan being busted for a while--and your got a stuttering at idle (before getting the new fan)--you might have ruptured an A/C line, due to too much high pressure in the A/C system--because your A/C condenser wasn't cooling at idle and the pressure got crazy.

In other words, you popped an A/C line and lost your A/C coolant.

Tim
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upon Cold Start in Cold Weather, Loud Noise?? paulrosenthal Tech & Performance Forum 33 01 Oct 2014 09:55 am
COLD AIR WHAT??? Wolfman Tech & Performance Forum 7 13 May 2011 06:46 am
Hot, cold, hot, cold...I'm freezing in here!!!! Ironman Tech & Performance Forum 8 07 Dec 2010 10:51 am
Cold Cold Crazy PianT General PT Cruiser Discussions 13 21 Jan 2004 11:35 pm
cold air vs. hot air ptcruz311 Tech & Performance Forum 3 22 Sep 2003 01:31 pm


All times are GMT -5. The time now is 12:04 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors