PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Overheating when engine turned off !

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Sep 2012, 12:03 pm
Fresh Cruiser
 
Join Date: Sep 2012
Posts: 2
Default Overheating when engine turned off !

My 2003 PT Cruiser is running fine apart from occasionally I notice bubbling inside top radiator hose when I stop and turn engine off at end of journey.
Does not happen immediately but after about 30 seconds to 1 minute.
Car has never overheated or gone above mid level on temp gauge when running.
When this occurs and I turn ignition 'on' and notice that temp gauge settles in mid level !.

Occasionally fan kicks in when running and stuck in traffic, as it should.

Not losing any coolant.

I notice that the cooling system has the most stupid design and is troublesome to try and expel air. I wonder whether a small amount of air is trapped and is causing this my problem ?.

Do not want to cause a head gasket or other issue.

Anyone experienced similar or has the answer...........
Reply With Quote
  #2 (permalink)  
Old 25 Sep 2012, 01:35 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: Overheating when engine turned off !

Open the cap on your reservoir tank and look inside; that's where the bubbling is most likely coming from.

Sounds like coolant isn't circulating properly but it should be an easy fix. Ton of people on here have experienced heating problems (my friend included who's PT I fixed) and you'll be surprised how easy the fix was.

When's the last time you replaced your thermostat? If you replace it, make sure the tiny 'notch' is lined up within the thermostat housing. Also, make sure your radiator cap is good (check the rubber seal/gasket for cracking inside the cap).

One more thing; turn the car on and turn on your A/C. Your fan should come on immediately. Non-turbo PT's have a high-speed and low-speed fan setting, and it isn't uncommon for one of those speeds to stop working.
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Overheating Issue norm123 Tech & Performance Forum 5 06 Jul 2012 10:44 am
Engine doesn't idle up when a/c turned on cmore Canada PT Forum 1 12 Sep 2011 09:12 am
Speedo & Tach jumping when engine is turned off. ShayP Tech & Performance Forum 1 20 Jun 2011 12:46 pm
Electrical issueS... (fog lights always turned on... radio display turned off.. etc) benoit_bertrand Sound and Security Forum 5 09 May 2011 03:09 pm
Engine cuts out when steering wheel turned NH03PtCruiser Tech & Performance Forum 6 13 Aug 2008 08:07 pm


All times are GMT -5. The time now is 10:32 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors