PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine Mounts!?

 
Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01 Oct 2012, 02:31 pm
Fresh Cruiser
 
Join Date: May 2010
Posts: 19
Default Engine Mounts!?

Okay, please don't scold me. I've spent the last couple hours scouring the web in search of answer. And I seem to be getting conflicting information.

Firstly, I've got a 2001 Touring Edition. 2.4. Automatic. All Stock. 140000 Miles.

There's a lot of clunking going on in the front end. I know for sure that one culprit is the engine mounts. They've never been replaced. And I've got 140K. So I'm assuming they're shot.

Here’s the questions I have, and cannot find a definite answer to:

How many engine/trans mounts are there? 4 or 3? I have the service manual, and it states 4. Other people claim 3. I see kits on eBay that contain 2, 3, or 4 mounts. Which should I get?

Secondly, which of these mounts will likely need replacing? I know the upper and lower strut mounts are a MUST, but what about the others?


I’m going to be replacing these myself within the next few weeks, and I only want to have to do it once. Thanks an advance for the help; really appreciate it.

Anything but going to a dealer…
Reply With Quote
  #2 (permalink)  
Old 01 Oct 2012, 02:41 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Engine Mounts!?

there are the two torque struts,
one centered mount in between them that bolts to the timing cover(and hardly ever goes bad/is difficult to get to)
and one mount below the battery tray that attaches to the transmission

most likely you just need the 2 torque struts. if you do spirited driving, you should fill them before installing them
Busted_PT likes this.

Last edited by rob342; 01 Oct 2012 at 02:45 pm.
Reply With Quote
  #3 (permalink)  
Old 01 Oct 2012, 02:46 pm
Badglas's Avatar
Cool Cruiser
 
Join Date: Jul 2012
Location: Central Illinois
Posts: 493
Default Re: Engine Mounts!?

Quote:
Originally Posted by kcpope View Post
Okay, please don't scold me. I've spent the last couple hours scouring the web in search of answer. And I seem to be getting conflicting information.

Firstly, I've got a 2001 Touring Edition. 2.4. Automatic. All Stock. 140000 Miles.

There's a lot of clunking going on in the front end. I know for sure that one culprit is the engine mounts. They've never been replaced. And I've got 140K. So I'm assuming they're shot.

Here’s the questions I have, and cannot find a definite answer to:

How many engine/trans mounts are there? 4 or 3? I have the service manual, and it states 4. Other people claim 3. I see kits on eBay that contain 2, 3, or 4 mounts. Which should I get?

Secondly, which of these mounts will likely need replacing? I know the upper and lower strut mounts are a MUST, but what about the others?


I’m going to be replacing these myself within the next few weeks, and I only want to have to do it once. Thanks an advance for the help; really appreciate it.

Anything but going to a dealer…
Your PT has 4 mounts for the drivetrain. The upper strut, lower strut, main(center) mount, and the transmission mount.

Upper and lower struts will be broken at that mileage, the most likely culprits. The main mount can only be replaced by removing the motor, or when replacing the water pump. It is probably worn, but I doubt it is broken. The transmission mount is located under the battery tray and power center. It is easily replaced from above. I'm sure it is worn, but I doubt it is broken either.

Make sure to follow the FSM when replacing any of the mounts. The upper strut has to be installed with a precise measurement of position.

Good luck!

Ron
Busted_PT likes this.
__________________
2001 PT Cruiser Limited Auto Stock

"Political correctness is a doctrine, fostered by a delusional, illogical Minority, and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a Turd by the clean end". (R.J. Wiedemann Lt.Col. USMC Ret)
Reply With Quote
  #4 (permalink)  
Old 01 Oct 2012, 08:30 pm
Fresh Cruiser
 
Join Date: May 2010
Posts: 19
Default Re: Engine Mounts!?

Okay, thank you all for the info.

Now, I'm probably NOT going to be changing out that mount that requires engine or waterpump removal. That sounds like a bear.

Maybe I'll just do the upper and lower strut mounts, and the tranny mount.

Lastly, is this the tranny mount? And if so, why does it say it only fits the 2003+ model years...?

Transmission Mount 2001 - 2002 Chrysler PT Cruiser 2.4L | eBay
Reply With Quote
  #5 (permalink)  
Old 04 Oct 2012, 06:43 pm
Fresh Cruiser
 
Join Date: May 2010
Posts: 19
Default Re: Engine Mounts!?

Bump. Any thoughts?
Reply With Quote
  #6 (permalink)  
Old 04 Oct 2012, 07:41 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Engine Mounts!?

to answer your question:

no, that is the timing cover engine mount. this is the transmission mount:
ANCHOR 3026 Transmission Mount | eBay

you should probably just skip this one too.

just get the upper and lower torque struts. they are probably all you need.
Badglas likes this.
Reply With Quote
  #7 (permalink)  
Old 06 Oct 2012, 07:56 am
Fresh Cruiser
 
Join Date: Sep 2012
Location: TN
Posts: 24
Default Re: Engine Mounts!?

Quote:
Originally Posted by rob342 View Post
you should fill them before installing them
How is this done to the bog bone/torque strut mounts?
Reply With Quote
  #8 (permalink)  
Old 06 Oct 2012, 09:17 am
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Engine Mounts!?

here's mine i filled:

Butt Head's Photos | Facebook

it's called 3m windo weld. you can find it online or at some parts stores. i used a generic version called titan p2g because i found it cheap on ebay.

keep in mind you have to let it dry completely before installing it. this takes (at least) a full 2 days. you can speed it up by cooking it in the oven at a low temperature, but i didn't.

Last edited by rob342; 06 Oct 2012 at 09:28 am.
Reply With Quote
  #9 (permalink)  
Old 06 Oct 2012, 09:26 am
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Engine Mounts!?

-----
Reply With Quote
  #10 (permalink)  
Old 06 Oct 2012, 09:30 pm
Fresh Cruiser
 
Join Date: Sep 2012
Location: TN
Posts: 24
Default Re: Engine Mounts!?

Quote:
Originally Posted by rob342 View Post
here's mine i filled:

Butt Head's Photos | Facebook

it's called 3m windo weld. you can find it online or at some parts stores. i used a generic version called titan p2g because i found it cheap on ebay.

keep in mind you have to let it dry completely before installing it. this takes (at least) a full 2 days. you can speed it up by cooking it in the oven at a low temperature, but i didn't.
That's awesome to know....now I don't have to buy new ones.
__________________
2001 Purple PT Cruiser (Mine)
2007 Sliver PT Cruiser (Wife's)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Mounts bheffner PT Cruiser Convertible Forum 2 06 Sep 2012 10:37 am
engine mounts lt4supr Turbo Performance 25 05 Oct 2011 01:19 pm
engine mounts lt4supr General PT Cruiser Discussions 11 04 Jun 2008 07:56 am
Engine mounts KingKole02 Tech & Performance Forum 3 13 Jan 2005 04:04 pm


All times are GMT -5. The time now is 03:32 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors