PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
codes p1391, p0340

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Oct 2012, 05:33 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default codes p1391, p0340

gentlemen, 2001 na auto. the wife's car threw a cel the other day. did the key dance and it showed p1391. i figured i'd go with a camshaft position sensor from rockauto. put it in and no cel. nice. well, took it for a spin and the car died 2 miles away. wouldn't start and drained the battery trying.

nice guy pulls up and tows me home. swap the sensor with the old one. finally get it started and idle into the driveway. put it in park and it dies. when starting it sounds like it's flooding, so it takes a while. now code is just p1391.

any ideas?
Reply With Quote
  #2 (permalink)  
Old 25 Oct 2012, 06:49 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: codes p1391, p0340

I found this:

2001 PT has P1391 code
Reply With Quote
  #3 (permalink)  
Old 25 Oct 2012, 06:49 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: codes p1391, p0340

Something to read....

Error code P1391
Reply With Quote
  #4 (permalink)  
Old 26 Oct 2012, 02:34 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: codes p1391, p0340

ok. i've read evrything above. still no luck.
i have deduced one thing and it appears to be somewhat related to the problem. when the engine is cold, ie, after letting it sit overnight, she fires right up. idles fine and revs well. as soon as it warms up, the problem starts.

could the IAT have anything to do with it?
Reply With Quote
  #5 (permalink)  
Old 29 Oct 2012, 04:43 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: codes p1391, p0340

well, crawled underneath and, just like crewzin's, wire loom was rubbing on the outer tie rod. one wire has only 1 strand holding it together. i would imagine the cranskshaft sensor needs most of the strands to work properly.

so, gotta buy some heatshrink tubing then solder the wire back together. funny thing is, there's a metal eyelet that should be bolted to the something to hold it up out of the way. i'll have to locate a bolt nearby. or ziptie it.
Reply With Quote
  #6 (permalink)  
Old 29 Oct 2012, 05:55 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: codes p1391, p0340

Glad you found it. I wasn't the only one to have that problem. You were lucky not to be too far from home. I was in the middle of South Carolina at 11;30pm and had to have it towed to the nearest (50 miles away) Chrysler dealer and they found the wires burnt away. Cost me an overnight stay in a motel, 2 hours labor to find and fix the harness plus the tow truck driver broke one under car LED light, the dealer (getting the car up on the ramp) broke another.

Reply With Quote
  #7 (permalink)  
Old 29 Oct 2012, 08:45 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: codes p1391, p0340

yep, my neighbor works for an automobile electrics company. he came home from work and crawled right under and temporarily fixed it. he's taking it to work tomorrow to make the fix permanent (up on the rack).
i'm so happy and so is the mrs.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0340 & P1391 code // cold start & occassionally stalls apalomo01 Tech & Performance Forum 13 28 Jul 2012 08:00 pm
Multiple Codes (P0340/P0522) higear4 General Turbo Discussions 19 05 Sep 2011 05:30 pm
error codes p0340 and p1299 nithawk2000 Tech & Performance Forum 3 29 Apr 2011 10:02 pm
Codes p1684 and p0340 xodeflepgirlox Tech & Performance Forum 1 08 Oct 2010 07:46 pm
P0340 & P1391 Rippsnorter Tech & Performance Forum 3 10 Jun 2010 11:37 pm


All times are GMT -5. The time now is 10:28 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors