PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
clunking sound

 
Like Tree4Likes
  • 1 Post By pluminator
  • 1 Post By mudking82
  • 1 Post By Busted_PT
  • 1 Post By PhxPT

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Oct 2012, 08:19 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 15
Default clunking sound

Hi All
I have an 04 PT. I have replaced the struts and lower A arm. I still get a clunking sound on the front passanger side of the car when hitting bumps or a ripple in the road at low or high speeds. Could that be caused by bad motor mounts?
Reply With Quote
  #2 (permalink)  
Old 25 Oct 2012, 09:47 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: clunking sound

motor mounts, the springs on the struts, incorrect torquing of the strut bolts, bad swaybar links, . Check all those out.

Grab the front springs and give em a yank, if you feel any play, means they are worn and wobbling. If the strut moves or squeaks when you do this, re-torque the bolts.

Give the swaybars an jiggle and see if theres any play there :-)

You can visually check the motor mounts for cracks/peeling, otherwise just start up the car, have someone rev it 2-3 times from idling to about 3000RPM real quick, if the motor jumps back and forth, it may be time for new mounts :-)

Hope this helps
Derren likes this.
Reply With Quote
  #3 (permalink)  
Old 26 Oct 2012, 04:49 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 15
Default Re: clunking sound

Thank You for the information.
I will check the motor mounts.
I know the sway bar and links are ok and i just put in new complete struts with springs and torqued them to speck.
Even had new tires mounted and ballanced. The PT rides much better so I will check out the motor mounts asap,
Thanks again

Last edited by Derren; 26 Oct 2012 at 04:54 pm.
Reply With Quote
  #4 (permalink)  
Old 27 Oct 2012, 01:01 am
Fresh Cruiser
 
Join Date: Oct 2012
Posts: 15
Default Re: clunking sound

Have you checked the lower control arms yet? If not, check the rearmost bushing on them specifically as it tends to wear out and cause quite a racket going over the smallest of bumps when they get really bad.
Derren likes this.
__________________
2003 GT Turbo, 5-speed
Reply With Quote
  #5 (permalink)  
Old 27 Oct 2012, 06:22 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: clunking sound

The sway bar bushings and links both have been an issue. Also check the bolts that hold the upper mount to the body. These can cause that noise.
Derren likes this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #6 (permalink)  
Old 27 Oct 2012, 12:48 pm
PhxPT's Avatar
Regular Cruiser
 
Join Date: Mar 2012
Location: Phoenix, AZ
Posts: 104
Default Re: clunking sound

I had a clunking that was horribly loud, turned out to be mushy struts & disintegrated sway bar bushings.
Derren likes this.
Reply With Quote
  #7 (permalink)  
Old 28 Oct 2012, 08:34 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 15
Default Re: clunking sound

I do have quite a bit of rocking going on with the motor. it very well may need motor mounts. Also the sway bar bushings look kind of bulging
Reply With Quote
  #8 (permalink)  
Old 28 Oct 2012, 10:51 pm
Teekypt's Avatar
Senior Cruiser
 
Join Date: May 2008
Location: Houston, TX
Posts: 1,428
Send a message via Skype™ to Teekypt
Default Re: clunking sound

Quote:
Originally Posted by Derren View Post
Hi All
I have an 04 PT. I have replaced the struts and lower A arm. I still get a clunking sound on the front passanger side of the car when hitting bumps or a ripple in the road at low or high speeds. Could that be caused by bad motor mounts?
That's where my "clunk" came from...bad motor mounts. And odd you should post this...I had them replaced in '05...and now when I shift from park to reverse, I hear a clunk...i popped the hood and my dad saw my engine moving when I shifted....so my assumption is motor mounts as well. Gotta have it looked at <3 Hope you fix your problem too
__________________
2003, GT, "ShuggaPlum", xenon bumper kit, custom grey/black CoverKing seat covers (front & back).
Sunrise: July 2002
Sunset: June 2018

http://www.math.uh.edu/~tai/Today/Clean3.jpg
Reply With Quote
  #9 (permalink)  
Old 01 Nov 2012, 11:47 am
Fresh Cruiser
 
Join Date: Sep 2012
Location: TN
Posts: 24
Default Re: clunking sound

I changed out the control arms and sway bar link and mounting bushings and still have a slight clunk.

Mine does it on sharp or fast turns. Sounds to me like something shifts out of place.

Has anyone had or seen problems with the front cross member being loose and needing tightened?
__________________
2001 Purple PT Cruiser (Mine)
2007 Sliver PT Cruiser (Wife's)

Last edited by tooter1; 01 Nov 2012 at 03:52 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear Clunking Tobi585 Wheels, Tires, Suspension 19 17 Apr 2016 02:05 am
please help clunking and few other questions wreksta Tech & Performance Forum 0 15 Sep 2009 05:04 pm
clunking sound from front right end when turning any TSB mino General PT Cruiser Discussions 5 18 Oct 2007 03:04 pm
clunking 5 speed ote69 General Turbo Discussions 6 20 Oct 2003 05:04 pm
Clunking sound from rear left side Presario BJ General PT Cruiser Discussions 3 27 Apr 2003 06:50 pm


All times are GMT -5. The time now is 06:05 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors