PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
My 2008 is sick,

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Nov 2012, 07:29 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default My 2008 is sick,

On the way to the university where I work, I remembered why I hate Mondays,
Its Always something.

Today on the way in my 2008 base coughed a couple times, had no acceleration pedal response for a few moments, & engine light began blinking.
Ouch, this cant be good!
Then seconds later the engine light went out, and drove normally the rest of the way to work.

After work,
I got about 10 miles up the road and it hit again.
A little sputter/misfire with absolutely no accelerator pedal response and again the engine light blinked a few times.
After about 5-10 seconds I was able to use the gas pedal as normal, but this time the engine light stayed on constant.

I did the key dance, I get no codes, it just does its thing a few seconds then says "done"

Any Idea's?
The car is otherwise in tip top shape.

Sara
Reply With Quote
  #2 (permalink)  
Old 05 Nov 2012, 07:57 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: My 2008 is sick,

the cam shaft sensor will casue this it diod on my 06
Reply With Quote
  #3 (permalink)  
Old 05 Nov 2012, 08:06 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: My 2008 is sick,

Quote:
Originally Posted by cruserdad1976 View Post
the cam shaft sensor will casue this it diod on my 06

I bet you are correct, I remember on my 01 limited we had to replace one of the sensors, I just forget if it was the cam or crank sensor.
It does seem odd that it shows no code on the key dance though, must be just on the edge of dead maybe?
Reply With Quote
  #4 (permalink)  
Old 06 Nov 2012, 01:26 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: My 2008 is sick,

well i only replaced my can dont even know where the crank sensor is
Reply With Quote
  #5 (permalink)  
Old 06 Nov 2012, 02:16 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: My 2008 is sick,

OK, just talked to the service center,

Error code P0016 ?
This sounds serious huh?

code p0016
Reply With Quote
  #6 (permalink)  
Old 07 Nov 2012, 11:33 am
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: My 2008 is sick, updated

I had the cam & crank sensors both replaced.
No more errors,
now runs perfect again.
Knock on Wood

Both the parts installed were purchased from mopar dealer so it should be good top go.

Reply With Quote
  #7 (permalink)  
Old 23 Jan 2014, 07:08 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: My 2008 is sick, AGAIN

Holy Thread Hole,

I just got the dreaded P0016 again today, only 2+ years since I replaced both the cam & crank sensors!
I got lucky today though,, limped home and into the garage.

Why Oh Why does this always happen during extreme weather periods?
Wind chill is well below ZERO, and of course I had a tutor student tonight I had to cancel.

Symptoms of a P0016 will or may include:

* Malfunction Indicator Lamp (MIL) illumination YES
* The engine may run but with reduced performance YES
* The engine may crank but not start Started Barely
* The engine may exhibit a rattle near the harmonic balancer indicating the tone ring is damaged Unknown heard nothing odd
* The engine may start and run, but poorly YES

I would almost be willing to bet that the mechanic lied and used an aftermarket part, I will know shorty though as we are picking one up at the dealer right now.

Last edited by Sarasmiles; 23 Jan 2014 at 07:22 pm.
Reply With Quote
  #8 (permalink)  
Old 23 Jan 2014, 07:29 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Lightbulb Re: My 2008 is sick, AGAIN

Quote:
Originally Posted by Sarasmiles View Post
I would almost be willing to bet that the mechanic lied and used an aftermarket part, I will know shorty though as we are picking one up at the dealer right now.
Would that surprise you?....They charge MFG price for OEM part,and pocket the rest!.....Hope the new MFG CPS takes care of it,was the target magnet also replaced?...Not they go bad like the CPS,but I personally like doing certain things as a matched set,and for about $14 extra,it just makes sense.
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #9 (permalink)  
Old 23 Jan 2014, 08:32 pm
Regular Cruiser
 
Join Date: Aug 2009
Location: Illinois
Posts: 179
Default Re: My 2008 is sick, AGAIN

Quote:
Originally Posted by randyincctx View Post
Would that surprise you?....They charge MFG price for OEM part,and pocket the rest!.....Hope the new MFG CPS takes care of it,was the target magnet also replaced?...Not they go bad like the CPS,but I personally like doing certain things as a matched set,and for about $14 extra,it just makes sense.
Well,,, I got the camshaft sensor off, it was indeed an OEM part.
Got the new one on,, eh,, maybe 15 minutes work.

Seems to be running fine now.
I did buy the crank sensor as well just in case.
I would change it right now but I have no access to a lift and its a royal PITA from the top. It it acts up again in the next couple days I'll call this guy we know about 20 miles away and have him do it.

The dealer did say if we ended up not needing the crank sensor right now we could return it as long as we did not open the bag.

Update,

Just went for a 25 mile drive-about, interestingly not only does it appear to be working fine now, I actually seem to have a better idle & more power! Hope it lasts!
Temp is -4, wind chill is around -15.

Last edited by Sarasmiles; 23 Jan 2014 at 10:01 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone do a sick exhaust bhunt41 Tech & Performance Forum 2 21 Jan 2011 12:30 am
Oh know Eve is sick!!! WolfmanG Tech & Performance Forum 8 01 Jan 2011 12:12 am
My sick '02 - help? JJ66 Tech & Performance Forum 1 22 Jun 2010 10:33 am
My PT is sick oldunclelar General Turbo Discussions 6 19 May 2010 11:36 am
Sick PT jburress Tech & Performance Forum 7 05 Jul 2003 10:01 pm


All times are GMT -5. The time now is 10:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors