PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2009 pt Cooling fan has me perplexed

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Nov 2012, 10:49 pm
Fresh Cruiser
 
Join Date: Jul 2012
Posts: 11
Default 2009 pt Cooling fan has me perplexed

So I bought a new 2009 pt cruiser from the dealer. I already put 65k on it...

The radiator fan crapped out on me and I ordered the replacement and took a look at the part before ripping the old one out...

Weird thing is the plug for the fan is the three prong connection and not the four prong that came with part. I'm confused because it supposed to four... Ahhh!

Any ideas?
Reply With Quote
  #2 (permalink)  
Old 07 Nov 2012, 11:21 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: 2009 pt Cooling fan has me perplexed

return it for the right part
Reply With Quote
  #3 (permalink)  
Old 08 Nov 2012, 08:23 am
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: 2009 pt Cooling fan has me perplexed

Does you new fan have the relays on the side? If it does then you have the correct part.
Reply With Quote
  #4 (permalink)  
Old 08 Nov 2012, 10:34 am
Fresh Cruiser
 
Join Date: Jul 2012
Posts: 11
Default Re: 2009 pt Cooling fan has me perplexed

yes the relays are on the side but my fan has the three prong plug. 2009's are supposed to have a four prong plug. whats wrong here?
Reply With Quote
  #5 (permalink)  
Old 08 Nov 2012, 10:39 am
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: 2009 pt Cooling fan has me perplexed

The fan on the car actually has two plugs. The fan itself plugs into a harness that runs over to the relays and then runs to another plug down underneath which is the four pin plug. It is down there sitting right beside the transmission pan. My replacement fan which was a Dorman did not have that plug for the fan. It was all one sealed wiring harness with just the four pin plug. You have to remember that in the 06's and up they went to the Canbus system. So a majority of the electrical components have an extra wire which is the bus wire. That wire runs to the TIPM and monitors the electrical circuit. If the TIPM doesn't get the right signal from that component it will shut that circuit down until it is repaired.

Last edited by Ray_Dockrey; 08 Nov 2012 at 10:45 am.
Reply With Quote
  #6 (permalink)  
Old 08 Nov 2012, 12:58 pm
Fresh Cruiser
 
Join Date: Jul 2012
Posts: 11
Default Re: 2009 pt Cooling fan has me perplexed

i got the same fan.
so the three prong plug isnt used? just plug in the four prong plug and im good to go since its all wired together?
Reply With Quote
  #7 (permalink)  
Old 08 Nov 2012, 03:00 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: 2009 pt Cooling fan has me perplexed

Yeah it is very confusing until you take the old fan out and compare the two. If you get it up on ramps and crawl underneath it you will see that square four pin plug. There was enough wire to take the fan out the top and then unplug that four pin plug. Not a whole lot of room to unplug it from underneath.
Reply With Quote
  #8 (permalink)  
Old 08 Nov 2012, 03:15 pm
Fresh Cruiser
 
Join Date: Jul 2012
Posts: 11
Default Re: 2009 pt Cooling fan has me perplexed

sweet! thanks a lot. i had a pretty good idea of how to do the job, but that was a slight curve ball. thanks for clearing it up. huge help!
Reply With Quote
  #9 (permalink)  
Old 04 Jul 2015, 11:55 am
Fresh Cruiser
 
Join Date: Jun 2015
Posts: 1
Default Re: 2009 pt Cooling fan has me perplexed

Can someone post pics of the 2 connectors and a wiring diagram.
Reply With Quote
  #10 (permalink)  
Old 04 Jul 2015, 12:50 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,256
Default Re: 2009 pt Cooling fan has me perplexed

Quote:
Originally Posted by datawanted View Post
Can someone post pics of the 2 connectors and a wiring diagram.
The second generation (2006-2010) has the 4 pin grey plug that plugs into the wire harness coming from the engine.

If you ordered your radiator fan from a automotive parts store sometimes they give us the wrong radiator fan with the 3 prong plug for a 1st generation. This happen to me a few years ago with Rockauto. They immediately replaced it but in the meantime you have a PT Cruiser with no cooling fan. I ordered another one and keep it in the garage.


four prong plug dorman radiator fan - Bing Images
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed and new cooling fan and cooling temp sensor & still the fan doesn't kick in rdvarona Southeast PT Forum 18 31 May 2013 09:14 pm
My 2009 Cruiser Ray_Dockrey Members PT Project 5 24 Aug 2012 12:51 pm
2009 pt oil type? IATA Tech & Performance Forum 10 22 Jun 2011 09:37 pm
230 hp 2006-2009 PT mangopuppy3 Classifieds: For Sale/Trade 0 11 May 2011 08:33 pm


All times are GMT -5. The time now is 10:00 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors