PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Clutch problems!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Nov 2012, 06:56 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Lancaster, Lancashire, UK
Posts: 19
Default Clutch problems!

Hi Guys! It's been a while since I was here, but good to see the forums as full as ever!
I have a 2.2CRD with a decidedly 'mushy' clutch pedal - pretty much no resistance at all, and I can't get the car in gear at all. What might be the first things to check? The ol' girl's done 138k and had a new clutch back at about 25k, and a new master&slave about 3 years ago - fluid level looks fine.

Any ideas??
Reply With Quote
  #2 (permalink)  
Old 09 Nov 2012, 10:38 pm
2step's Avatar
Senior Cruiser
 
Join Date: Oct 2004
Location: New Braunfels, Texas.
Posts: 1,672
Default Re: Clutch problems!

That sounds like (1) a leaking slave cylinder, (2) air in the system, (3) low or worn out hydraulic fluid, (4) a master cylinder gone bad. See if you can pump the clutch pedal rapidly a few times and then are able to change the gear.

(1) Can you see any drips or gunk on the bottom of the trans?
(2) Does the pedal seem softer than usual?
(3) Check the fluid reservoir and add if low or better yet bleed and flush the system with fresh fluid. You can do a wanker flush by drawing the fluid out of the reservoir with what we in the US call a "turkey baster" (looks like a giant eye dropper). Draw all the fluid you can and dump it, add fresh in the reservoir and pump the pedal to mix it in, draw some more, add some more, etc. until it's mostly fresh.
(4) Inspect for leaks, etc.
Reply With Quote
  #3 (permalink)  
Old 10 Nov 2012, 06:31 am
Fresh Cruiser
 
Join Date: Jul 2009
Location: Lancaster, Lancashire, UK
Posts: 19
Default Re: Clutch problems!

Hi 2Step!

Thanks for the advice - I'll check your ideas out next week as I'm off work (thank god!).
The pedal is definitiely soft - pretty much no resistance at all. The master and slave cylinders were replaced about 2-3 years ago, but that's not to say they might be leaking again..however disappointing that may be as the originals lasted some 7-8 years..!!
I've heard that there may be a pedal adjustment screw behind the fascia - is this true, or just on the petrol version?

I like the idea of flushing the system with a turkey baster! Excellent idea! As long as it stops raining here long enough, I may give that a go, as the reservoir level seems pretty full - about 1cm from the top of the reservoir?

Anyway, appreciate your help, pal - updates as I have them...
Reply With Quote
  #4 (permalink)  
Old 16 Nov 2012, 08:22 am
Fresh Cruiser
 
Join Date: Jul 2009
Location: Lancaster, Lancashire, UK
Posts: 19
Default Re: Clutch problems!

Well hello, again!
Thanks again to 2step - flushed the system, topped up fluid levels and there is indeed a bad leak in the slave. Part ordered and mechanic on standby...!

For those members of the Forum in the UK, here's a contact you may find as invaluable as I have:

ACD of Lancashire 01254 301021
Specialists in breaking Chryslers and can post to anywhere in the UK. All parts checked before being sold. My replacement clutch slave cylinder (182.50 + postage new!) was 78 incl postage. What I've saved will pay for my mechanic to fit it! I've had a few things off these guys before, from front wing to crank case cover to injectors - all at a good price. I'm not on commission, by the way!!

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Pt Cruiser -TE Clutch problems, I think. randomzombie Tech & Performance Forum 13 17 May 2012 06:28 pm
Possible clutch problems, or something else? dom92 General PT Cruiser Discussions 4 25 Apr 2012 05:45 pm
Clutch Problems Mikedes Tech & Performance Forum 9 08 Jul 2011 10:08 pm
Is any one having clutch problems? Richsard D. Tech & Performance Forum 4 06 Aug 2005 10:10 pm
Clutch Problems? ptgtcb General Turbo Discussions 2 24 Apr 2004 12:11 am


All times are GMT -5. The time now is 10:18 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors