PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Code 0335

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Nov 2012, 08:57 pm
HarleyTom's Avatar
Fresh Cruiser
 
Join Date: Jun 2012
Location: Port Angeles, Wa.
Posts: 16
Send a message via AIM to HarleyTom
Default Code 0335

First thanks to everyone that responces..
Ok 1st I had oil light staying on, along with check engine light on and blinking, and engine missing at about 2200rpm.
I diconnected the neg. wire on battery about 15min. reconnected and started engine, didn't start right up, I shut off key each time and then started on 3rd try.
Now only check engine light is on but still idles kind of rough smooths out id rev's up untill aprox 2200 rpm.
I did the code check with key and this time code 0335 only shows
Sorry if I write alot but trying to let everyone know the correct info.
Oh 04 PT Touring w/out turbo,
1 more thing cruise controll light doesn't turn on to?
Hope this helps me.. need to go to work monday evening @ Hope Depot,,
I work freight and get off after bus drivers are home in bed.. lol
Harley Tom
Reply With Quote
  #2 (permalink)  
Old 10 Nov 2012, 11:54 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Code 0335

P0355 has to do with the coil. Check to make sure all the connections to the coil are properly seated.

Did the light for the cruise control ever work? Have you checked your fuses?
Reply With Quote
  #3 (permalink)  
Old 11 Nov 2012, 02:06 am
HarleyTom's Avatar
Fresh Cruiser
 
Join Date: Jun 2012
Location: Port Angeles, Wa.
Posts: 16
Send a message via AIM to HarleyTom
Default Re: Code 0335

Quote:
Originally Posted by CREWZIN View Post
P0355 has to do with the coil. Check to make sure all the connections to the coil are properly seated.

Did the light for the cruise control ever work? Have you checked your fuses?
Ok the only reason I checked the cruise control when I was driving home late last night to maintain speed and rpm under 2200rpm,,, and yes the light was always wooking on dash when cruise activated.
I will check coil to see if all wiring are seated and dry tomorrow sunday morning, would this be a problem with rought idle and not letting engine to run above 2200rpm? or could it still be crank sensor or maybe cam sensor going out again?
Man I hope I get this fixed befor monday afternoon,,,, rather be surfing on my days off and I'm 59yrs old young,,, lol Thanks again Crewzin,, one day would like to meet you seem to enjoy being helpful to all of us pt cruisin folks,, thanks to everyone elso to.. Harley Tom
Reply With Quote
  #4 (permalink)  
Old 11 Nov 2012, 09:19 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Code 0335

Although the stock coil on the PT is one of the best things on the car, everything could fail once in awhile. Yes, a failing coil could cause some of the problems your seeing.

Without re-reading everything, if you haven't used OEM sensors, yes, they could fail again and usually do as aftermarket sensors either don't work at all or work for a short time and fail.

The cruiser control goes through so any different things that any one of them could cause a failure. The PCM, clock spring, speed control servo plus others all have to do with the cruise control. Finally, although it isn't listed, fuse #10 in the interior fuse box gives power to the cruise ....check it.
Reply With Quote
  #5 (permalink)  
Old 11 Nov 2012, 03:39 pm
HarleyTom's Avatar
Fresh Cruiser
 
Join Date: Jun 2012
Location: Port Angeles, Wa.
Posts: 16
Send a message via AIM to HarleyTom
Default Re: Code 0335

Quote:
Originally Posted by CREWZIN View Post
Although the stock coil on the PT is one of the best things on the car, everything could fail once in awhile. Yes, a failing coil could cause some of the problems your seeing.

Without re-reading everything, if you haven't used OEM sensors, yes, they could fail again and usually do as aftermarket sensors either don't work at all or work for a short time and fail.

The cruiser control goes through so any different things that any one of them could cause a failure. The PCM, clock spring, speed control servo plus others all have to do with the cruise control. Finally, although it isn't listed, fuse #10 in the interior fuse box gives power to the cruise ....check it.
Getting started late this sunday norning but 1st thing did was recheck the codes using the 3 on off with key,, this time I received 3 errors codes P0340/P0335/P0522. I rpleced the cam sensor about maybe 3 months ago aprox 2000 miles give or take,, with aftermarket part autozone,, when I did check oil level it was below half, I topped it off yesterday/ I did check coil wires (spark plugs wires, & in tight and look good but have no electric tester. I am going to replace the cam sensor again and hope all goes away, if it was the problem can't understand why it went out so soon?... (Note) if new sensor doesn't work well I'll be trying to find a way to fix it before monday evening to get to work @ home depot, anybody going my way? Thanks for all the help.. if fixed I will reply,, H T...
Reply With Quote
  #6 (permalink)  
Old 14 Nov 2012, 01:10 pm
Moutray's Avatar
Fresh Cruiser
 
Join Date: Nov 2012
Location: Jacksonville, FL
Posts: 5
Default Re: Code 0335

I have the same problem my friend. I changed the crk sensor to Mopar and erased one code, but that 0335 still exists with Mopar oil pressure sensor. Its interesting that you mentioned the cruise control because I looked into that and I am experiencing the same prob. All the lights kinda go in and out to. The car was given to me or I would not bother with it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'04 codes read 0522,0335. Stalling at stopsigns and lights? Mawbadical General PT Cruiser Discussions 11 11 Nov 2012 03:54 pm
0522, 0340, 0335 bjagd02 General PT Cruiser Discussions 3 26 Feb 2011 05:35 pm
CEL code help?? 05pt Tech & Performance Forum 11 08 Sep 2010 10:51 am
code 352 coco1476 Tech & Performance Forum 5 18 Jan 2010 05:19 pm
Code Help! 1lowufo Tech & Performance Forum 1 21 Aug 2004 07:03 pm


All times are GMT -5. The time now is 04:23 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors