PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even crank

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Dec 2012, 02:38 am
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 14
Default 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even crank

Hello, I have a 2007 PT cruiser that I recently adquired. The car was running great, but as I was on the freeway, the accelerator stopped working and it wouldn't go at all. So I has someone help me get it into a parking lot and I got the error coses as the check engine light went on. The codes I got errors P0340 and P0016 . The car would crank but Not turn over. I tryed using starter fluid and giving it a jump but to no avail. There is plently of gas in the car. So I replaced the camshaft position sensor and only the P0340 code came on. The car still would crank but would not start. Then I replaced the crankshaft position sensor and the check engine light is still on, but no more codes pop up. Now the car won't even crank. The old o rings were removed and as the camshaft position sensor the was replaced had a broken seal, I cleaned out to place with the camshaft position sensor. I'm now at a dead end and I have run out of ideas on what to do next. The codes are gone and as the car won't even crank now, I am out of ideas on what to do. Any help would be appreciated

Last edited by andrewsmith1984; 23 Dec 2012 at 02:46 am.
Reply With Quote
  #2 (permalink)  
Old 23 Dec 2012, 07:09 am
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

Did you run the battery down trying to get it to start? Your original issue sounds like you might have broken the timing belt. How many miles are on it?
Reply With Quote
  #3 (permalink)  
Old 23 Dec 2012, 09:44 am
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 26
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

try to change your battery and see what happens
and about the codes have no idea check this post
Error Codes
Reply With Quote
  #4 (permalink)  
Old 23 Dec 2012, 10:08 am
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 14
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

I checked the battery, and switching out the battery didn't change it at all. I also opened up the case for the timing belt and I didn't see any broken or missing teeth and it seemed to be pretty smooth. It's strange because the P0016 and the P0340 codes went away and I'm still getting the check engine light. With the old crankshaft position sensor, the car would crank, but not turn over, but with the new one, it won't even crank, but at the same time that P0340 code for the engine is gone. It almost seems counter intuitive.And because there are no more problem codes, I'm not sure on what to look at next. Thanks for the posts, I'm gonna keep my eye open and if you have any more information, i'm willing to try just about anything.
Reply With Quote
  #5 (permalink)  
Old 23 Dec 2012, 10:09 am
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 14
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

Oh and it has 110000 miles on the car.
Reply With Quote
  #6 (permalink)  
Old 23 Dec 2012, 10:47 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

You said you replaced the Crankshaft sensor, but the code is for a CAMsahft sensor and at those miles you sometimes get that code when the timing belt breaks because the Camshaft sensor is no longer seeing a signal because nothing is turning.

First thing, as already said, take the CAMSHAFT sensor off, have someone turn over the engine and watch the Camshaft magnet and see if it turns. It's on the end of one of the camshafts and won't turn if the belt is broken. I know you opened the case but the belt wasn't moving and could have split at the bottom.
Reply With Quote
  #7 (permalink)  
Old 23 Dec 2012, 12:09 pm
Fanatic Cruiser
 
Join Date: Jun 2009
Location: Rochester, Michigan
Posts: 668
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

Unfortunately, two things come to mind:
1. if you are certain that the battery, starter relay, and wiring are good...you may have fried the starter with all the cranking
2. broken timing belt

If, for whatever reason, you can't get the engine to crank with the starter; then (key off) turn the crank pulley with a wrench and do what Crewzin said to verify camshaft movement.

btw... cranking and turning over are the same thing...what you probably mean is that the engine won't fire.

Last edited by Carl48; 23 Dec 2012 at 12:15 pm.
Reply With Quote
  #8 (permalink)  
Old 23 Dec 2012, 01:55 pm
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 14
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

Thanks, for the input. I'm going to go over with my brother later today and I'm bringing a starter and i'm going to check the crankshaft pulley, timing belt, and the camshaft magnet. I'll go ahead and post my results later. And if it doesn't start at least I'll be able to get it towed to my house with my brother's tahoe. Once again, thanks for the input and if you or anyone else has any ideas, let me know, as i'm welcome to any suggestion.
Reply With Quote
  #9 (permalink)  
Old 23 Dec 2012, 04:25 pm
Fresh Cruiser
 
Join Date: Oct 2012
Location: San Diego, CA
Posts: 31
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

As crewzin said check the cam is turning. If I understood your post correctly, the car did crank with the old sensor but not with the new, have you put the old one back in to see if it still cranks even if it throws a code?

If you have done that and it still won't crank then one other thing to consider is a broken ignition switch actuator pin (Dorman part number 924-704). Costs about $40 bucks to replace and takes about 15 minutes. You will need a "security" T10 Torx to remove a couple of the screws holding the unit in place. There are how to's on Youtube from Dorman that show you how to change it.

It's a very common fail point and when it fails there is no crank from the car, all lights in the dash work OK but there is zero attempt to turn the engine. I had this exact problem on my sons car. It was ok one minute and toast the next, once it was replaced the car fired right up.
Reply With Quote
  #10 (permalink)  
Old 30 Dec 2012, 10:44 pm
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 14
Default Re: 2007 PT cruiser died, parts replaced, engine codes are gone, but car wont even cr

Ok, it's been a while, i checked the starter and it was definitely old and looked like it was in bad shape, so I replaced that. Although i was pretty sure this wasn't the only problem, It definitely needed it. I also put back the old crankshaft sensor and it still didn't turn over. I gave it a jump and made sure that the battery is working, and that seems to be fine. Now my next part is to check the timing belt. I had taken a look before, but now it's gonna be fun trying to get a look at all of it. Signs are pointing to this as the problem. Unfortunately to get to it, I looked into it and I need to basically remove a third of the components in the engine compartment and hold the engine up with a jack stand due to the fact that I will have to remove the upper and lower engine mounts on the left side of the car. Unless anyone has any other ideas on how to do this, I looked at it and I cant see another way to get the timing belt cover off. Thanks for the input, it just looks like this will be a job and a half, haha.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
wont crank please help destinbeachbum Tech & Performance Forum 9 01 Dec 2012 04:34 pm
PT Cruiser died no fuel and won't crank! PurpleCruizerConvertible Tech & Performance Forum 11 22 Nov 2012 11:17 am
2007 PT Cruiser Overheated now wont start!! kbryant Tech & Performance Forum 15 25 May 2012 03:55 pm
2001 PT Cruiser Just Died... Got codes.. Took a cab home pasikobri Tech & Performance Forum 7 08 Feb 2010 05:02 pm
02 pt died and won't crank over ronwins3 Tech & Performance Forum 16 23 Dec 2009 06:25 am


All times are GMT -5. The time now is 02:12 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors