PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
error code P0304...it was the coil pack

 
Like Tree1Likes
  • 1 Post By Busted_PT

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 31 Dec 2012, 02:02 pm
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 6
Wink error code P0304..CORRECTION: IT"S NOT THE COIL PACK

CORRECTION: IT"S NOT THE COIL PACK... '03 GT. 105k miles. Went to pass a truck on the hwy and engine sputtered. 10 seconds later engine light came on. code P0304 cylinder #4 misfire. I understand cyl #1 and #4 share a coil however only #4 was not firing. Swapped around plugs and wires but no change. hooked up timing light and #1, 2 and 3 had a rapid pulse but #4 seemed to flash at half speed, I'm guessing somehow it was firing on the exhaust stroke only. If nothing else that narrowed it down to ignition and not fuel or vacuum problem. Figured I'd have to start throwing parts at the car and started with the coil pack...lucked out, might start out the new year on a good note afterall. Only problem seems to be the idle is slightly high, I'll try unhooking the battery to let the computer re-learn. maybe driving with 1 cylinder running so rich changed the programming

Last edited by sportshooz; 03 Jan 2013 at 12:27 am. Reason: bad info
Reply With Quote
  #2 (permalink)  
Old 31 Dec 2012, 02:46 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: error code P0304...it was the coil pack

I would check the vac lines. May hay disturbed one while working. or you may need to clean the AIC valve. May need to lube the pivot points on the throttle body. Check the cables if you had the upper intake off.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 31 Dec 2012, 05:44 pm
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 6
Default Re: error code P0304...it was the coil pack

I did hand check the vacuum lines but maybe i'll try spraying a little starter fluid around see what happens. I was able to work around the intake though they made it as hard to get to as possible and I did hyperextend the throttle to get to bolts so thats a distinct possibility too. Not familiar with the AIC valve but I'll do a little research. Thanks for your thoughts, I'll get on it tomorrow.
Reply With Quote
  #4 (permalink)  
Old 31 Dec 2012, 05:51 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,760
Default Re: error code P0304...it was the coil pack

You may have changed out a working coil by your description of the problem. The PT ignition system is a waste spark system so if you indicated a constant pulse on all 4 terminals then the coil was functioning as it should. Generally if the coil was faulty you would be getting no pulse or intermittent pulse on one or more terminals and not in specifically on the compression stroke or exhaust stroke by itself .
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN

Last edited by NitroPT; 31 Dec 2012 at 05:55 pm.
Reply With Quote
  #5 (permalink)  
Old 31 Dec 2012, 06:38 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: error code P0304...it was the coil pack

Quote:
Originally Posted by sportshooz View Post
'03 GT. 105k miles. Went to pass a truck on the hwy and engine sputtered. 10 seconds later engine light came on. code P0304 cylinder #4 misfire. I understand cyl #1 and #4 share a coil however only #4 was not firing. Swapped around plugs and wires but no change. hooked up timing light and #1, 2 and 3 had a rapid pulse but #4 seemed to flash at half speed, I'm guessing somehow it was firing on the exhaust stroke only. If nothing else that narrowed it down to ignition and not fuel or vacuum problem. Figured I'd have to start throwing parts at the car and started with the coil pack...lucked out, might start out the new year on a good note afterall. Only problem seems to be the idle is slightly high, I'll try unhooking the battery to let the computer re-learn. maybe driving with 1 cylinder running so rich changed the programming
Quote:
Originally Posted by NitroPT View Post
You may have changed out a working coil by your description of the problem. The PT ignition system is a waste spark system so if you indicated a constant pulse on all 4 terminals then the coil was functioning as it should. Generally if the coil was faulty you would be getting no pulse or intermittent pulse on one or more terminals and not in specifically on the compression stroke or exhaust stroke by itself .
Lynn,
I'm thinking you were blinded by the flash of my signature pics and missed this.
UptownSport likes this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com

Last edited by Busted_PT; 31 Dec 2012 at 06:41 pm.
Reply With Quote
  #6 (permalink)  
Old 31 Dec 2012, 08:13 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,760
Default Re: error code P0304...it was the coil pack

Quote:
Originally Posted by Busted_PT View Post
Lynn,
I'm thinking you were blinded by the flash of my signature pics and missed this.
No I did not miss anything, the OP in the first post said a constant pulse on all 4 but seemed only half on one terminal.That does not mean an erratic or absent pulse but constant. Technically that is not possible given the design of the Transformer style coil pack?
You may also read my very short description of a waste spark system and see that what he says can't fundamentally occur?

I would say if he gave that coil to anyone and even re-installed it on his PT it would probably not be bad.


uptownsport gave a like thinking I was caught me off my game...

Go back and re-read the OPs first post and you will understand the confusion he creates by his unusual method of testing a coil.

__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN

Last edited by NitroPT; 31 Dec 2012 at 08:18 pm.
Reply With Quote
  #7 (permalink)  
Old 31 Dec 2012, 09:47 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: error code P0304...it was the coil pack

I thought he liked my humor.

Question Lynn,
Dose the ford 3.0 use that type of coil? Reason I ask, had a leg go on on recently.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com

Last edited by Busted_PT; 31 Dec 2012 at 09:52 pm.
Reply With Quote
  #8 (permalink)  
Old 01 Jan 2013, 12:38 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,760
Default Re: error code P0304...it was the coil pack

Typically most all coils can be used on most any ignition systems but the coil on PT and aftermarket replacements are Chrysler applicated. Ford uses a different coil package.
On a four terminal coil generally there are usually 2 coils and if a problem comes up it will usually be on one coil and the terminals seizing to function
None oil cooled coils seldom have intermiting operation. They either work or don't work. Ther are some exceptions such as damage to the coil.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #9 (permalink)  
Old 01 Jan 2013, 12:48 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: error code P0304...it was the coil pack

Ya this one started to miss under a load and got worse until one leg died all together. Thanks Lynn.
Hey I've known you sense last year !
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #10 (permalink)  
Old 02 Jan 2013, 11:16 pm
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 6
Default Re: error code P0304...it was the coil pack

You're correct..the new coil fix didn't last more than maybe 10 miles. I'm reading posts from 2008 and no one seems to have resolved this. My new codes are P0300 random miss, p2305 ignition coil B secondary circuit, and P0440 evap system Which usually accompanys P0441 evap incorrect purge flow but somehow is omitted in this new list, I have to reset the last 2 pretty regularly but they never seemed to affect performance, I may have to hand this to my dealer, this is gonna hurt.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Code P0304 Cylinder 4 Misfire Detected WV05Cruiser Tech & Performance Forum 16 23 Feb 2016 10:33 am
Question about coil pack muzicmax General Turbo Discussions 7 15 Oct 2012 07:12 pm
Error code P0300 & P0304 Jimpote03 Tech & Performance Forum 1 07 Mar 2011 05:28 pm
Error Code P0304 Max Tech & Performance Forum 2 30 Mar 2009 03:46 pm


All times are GMT -5. The time now is 02:52 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors