PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
HELP

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Jan 2013, 12:01 pm
Fresh Cruiser
 
Join Date: Jan 2013
Posts: 6
Default HELP

i have a 06 pt cruiser had starting problems with the cold weather had to jump start every couple of days bought a new battery still wont start turns over but not starting any ideas
Reply With Quote
  #2 (permalink)  
Old 05 Jan 2013, 12:29 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: HELP

Is it turning over quickly with the new battery? If not, you cables might be at fault. Check all the ends of all the cables for corrosion.
mityqwik likes this.
Reply With Quote
  #3 (permalink)  
Old 05 Jan 2013, 12:41 pm
Fresh Cruiser
 
Join Date: Jan 2013
Posts: 6
Default Re: HELP

its turning over quickly i have cleaned the cable ends i am not good with cars
Reply With Quote
  #4 (permalink)  
Old 05 Jan 2013, 12:51 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: HELP

How's your plugs and wires. If they're worn, it'll take a lot longer to start than usual.
Reply With Quote
  #5 (permalink)  
Old 05 Jan 2013, 12:54 pm
Fresh Cruiser
 
Join Date: Jan 2013
Posts: 6
Default Re: HELP

wouldnt start this past tuesday jump started it worked Wednesday jump start did not work took the battery to auto place dead battery bought a new one and still wont start
Reply With Quote
  #6 (permalink)  
Old 05 Jan 2013, 12:56 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,579
Default Re: HELP

Your post refers to cold weather starts, this would be more then likely a fuel delivery question.
__________________
Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #7 (permalink)  
Old 05 Jan 2013, 01:08 pm
Fresh Cruiser
 
Join Date: Jan 2013
Posts: 6
Default Re: HELP

thanks i am not ruling anything out
Reply With Quote
  #8 (permalink)  
Old 05 Jan 2013, 01:09 pm
Fresh Cruiser
 
Join Date: Jan 2013
Posts: 6
Default Re: HELP

Quote:
Originally Posted by CREWZIN View Post
How's your plugs and wires. If they're worn, it'll take a lot longer to start than usual.
could it be a fuse?
Reply With Quote
  #9 (permalink)  
Old 05 Jan 2013, 01:09 pm
Fresh Cruiser
 
Join Date: Jan 2013
Posts: 6
Default Re: HELP

could it be a fuse?
Reply With Quote
  #10 (permalink)  
Old 05 Jan 2013, 01:21 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,579
Default Re: HELP

Its not a fuse
__________________
Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:47 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors