PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
My $20 fix for very rough idle & stalling.

 
Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Jan 2013, 08:27 pm
mnahmnah's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Wisconsin
Posts: 304
Lightbulb My $20 fix for very rough idle & stalling.

My 2001 has been in the driveway for two weeks while I tried to diagnose on my own.

What didn't work:
new plugs and wires

What made very slight improvement:
carb cleaner in the throttle body
fuel injector cleaner, because I'm convinced I got a tank of bad gas (2 bottles in full tank) $9

What made it purr like a freakin' kitten:
replacement air filter! The one I had in there until today was new, put in 2 months ago, and it was clean.

Here's why----
The one that was thrown in there by the shop that did my oil change was misshapen.... it had a bit of a crimped corner that gave it a concave curvature along one of the long sides. I didn't notice that it wasn't seated until yesterday, and when I poked at it, it would just push down into the box. I couldn't get it to seat by moving it around, so I decided to get a newer one with a beefy gasket. Got a Fram CA8747. Nothing fancy. $10.99.

From what I have read/heard by talking to others, the air bypassing the filter could have been adding too much air to the mix, depending on where the Mass Air Sensor (?) is located, and the sensor wasn't taking the extra airflow into account. (Maybe someone can verify or comment on this part.)

Anyway, my PT is now humming quietly (maybe quieter than a kitten!) and I'm freaking overjoyed. Now I can move on to the oil leak....

Thank you for all your help and suggestions! I'll be around -- much more to do on this poor mistreated PT.
__________________
2001 LE, 168,000 miles.
One of the split seats went into a dumpster in Tulsa. The arm rest unscrewed and fell off. It's on its 2nd timing belt. Surviving the Upper Peninsula winters.

Last edited by mnahmnah; 17 Jan 2013 at 12:00 am.
Reply With Quote
  #2 (permalink)  
Old 16 Jan 2013, 08:34 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: My $20 fix for very rough idle & stalling.

Quote:
Originally Posted by mnahmnah View Post
From what I have read/heard by talking to others, the air bypassing the filter could have been adding too much air to the mix, depending on where the Mass Air Sensor (?) is located, and the sensor wasn't taking the extra airflow into account. (Maybe someone can verify or comment on this part.)
these cars have no mass airflow sensor. also before i bothered buying a cone filter for mine, i just left the airbox off for a few days to make sure i liked it. it sounded cooler and got better mpg. the "power" also seemed to come in at a higher rpm like the engine would wake up at 4800rpm and pull to redline, where it felt wound out and lifeless before

makes no sense why that would fix your problem. glad it did though.

i think it was badglas who said changing his map sensor fixed his idle. maybe your map sensor is on its way out. so it was unable to make good use of the extra air the leaky airbox provided. im no mechanic though, so dont read tooooo much into my explanation.

edit: here i googled this:
site:ptcruiserlinks.com "badglas" "map sensor"

and found this:
Idle Quality
mnahmnah likes this.

Last edited by rob342; 16 Jan 2013 at 08:50 pm.
Reply With Quote
  #3 (permalink)  
Old 16 Jan 2013, 08:42 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,882
Default Re: My $20 fix for very rough idle & stalling.

That should not had any affect on that. Mine purrs like a kitten without an air box or the turbo hose on the car. Glade your getting some resolution. But think you must have, in the process done something else that escapees your realizing that it affected anything. Happy all the same.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 16 Jan 2013, 09:43 pm
mnahmnah's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Wisconsin
Posts: 304
Default Re: My $20 fix for very rough idle & stalling.

What...??

My happy only got to last an hour?

Dang... I'm so confused.

Sorry about the thread title, then, maybe it should be deleted before I mislead hundreds of PT owners into checking their air filter?

But seriously, I don't get it either. Maybe it was the magic of Lucas in the tank, kicking Arco's butt.

Something to do with EGR valve? DTC 401, rough idle and dumb question
__________________
2001 LE, 168,000 miles.
One of the split seats went into a dumpster in Tulsa. The arm rest unscrewed and fell off. It's on its 2nd timing belt. Surviving the Upper Peninsula winters.

Last edited by mnahmnah; 16 Jan 2013 at 09:53 pm.
Reply With Quote
  #5 (permalink)  
Old 16 Jan 2013, 09:57 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,882
Default Re: My $20 fix for very rough idle & stalling.

Quote:
Originally Posted by mnahmnah View Post
What...??

My happy only got to last an hour?

Dang... I'm so confused.

Sorry about the thread title, then, maybe it should be deleted before I mislead hundreds of PT owners into checking their air filter?

But seriously, I don't get it either. Maybe it was the magic of Lucas in the tank, kicking Arco's butt. IDK but now I'm still afraid to drive out of town.
If it's still running well I would drive it around locally to see if it's going to act up. It may yet be that the additives have taken there tole or the TB cleaning loosened things up and got you going.
No I wouldn't try to get it deleted. Not a normal practice. Even a failed idea has it's value. Especially one that is made clear during the course of the thread how things turned out.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com

Last edited by Busted_PT; 16 Jan 2013 at 10:02 pm.
Reply With Quote
  #6 (permalink)  
Old 16 Jan 2013, 10:02 pm
mnahmnah's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Wisconsin
Posts: 304
Default Re: My $20 fix for very rough idle & stalling.

That's a good link. Would a map sensor that's going out decide to fully recover once in a while? Because that's what's been happening. I've had two horrible sessions where I've been threatened (by the severe roughness driving and idle, and stalling out) to be stranded while far from home.

Then it resolves. Apparently then all I've done myself to improve things is put fuel injector cleaner in it and force it through for a half hour.

So today, it resolved. It happens in almost a snap of the fingers. Runs great; snap; car is shaking and stalling out, barely can get it to the nearest mini mart. I add fuel injector cleaner, force it to run (including revving in neutral at stop signs) for half hour to an hour, then; snap; it resolves and runs perfect.

Any more ideas?

Quote:
Originally Posted by rob342 View Post

makes no sense why that would fix your problem. glad it did though.

i think it was badglas who said changing his map sensor fixed his idle. maybe your map sensor is on its way out. so it was unable to make good use of the extra air the leaky airbox provided. im no mechanic though, so dont read tooooo much into my explanation.

edit: here i googled this:
sitetcruiserlinks.com "badglas" "map sensor"

and found this:
Idle Quality
__________________
2001 LE, 168,000 miles.
One of the split seats went into a dumpster in Tulsa. The arm rest unscrewed and fell off. It's on its 2nd timing belt. Surviving the Upper Peninsula winters.
Reply With Quote
  #7 (permalink)  
Old 16 Jan 2013, 10:26 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,882
Default Re: My $20 fix for very rough idle & stalling.

Quote:
Originally Posted by mnahmnah View Post
That's a good link. Would a map sensor that's going out decide to fully recover once in a while? Because that's what's been happening. I've had two horrible sessions where I've been threatened (by the severe roughness driving and idle, and stalling out) to be stranded while far from home.

Then it resolves. Apparently then all I've done myself to improve things is put fuel injector cleaner in it and force it through for a half hour.

So today, it resolved. It happens in almost a snap of the fingers. Runs great; snap; car is shaking and stalling out, barely can get it to the nearest mini mart. I add fuel injector cleaner, force it to run (including revving in neutral at stop signs) for half hour to an hour, then; snap; it resolves and runs perfect.

Any more ideas?
As I said I would drive it for a bit and see if it comes back.
mnahmnah likes this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #8 (permalink)  
Old 16 Jan 2013, 11:59 pm
mnahmnah's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Wisconsin
Posts: 304
Default Re: My $20 fix for very rough idle & stalling.

Quote:
Originally Posted by Busted_PT View Post
As I said I would drive it for a bit and see if it comes back.
You are truly the bearer of wisdom.
(I did that last night, 4 miles around the neighborhood, no improvement really. Must have needed more time.)


Is this whole episode, then, all about bad gas? Does it really cripple the engine that badly?

Let the gas jokes begin!
__________________
2001 LE, 168,000 miles.
One of the split seats went into a dumpster in Tulsa. The arm rest unscrewed and fell off. It's on its 2nd timing belt. Surviving the Upper Peninsula winters.

Last edited by mnahmnah; 17 Jan 2013 at 12:14 am.
Reply With Quote
  #9 (permalink)  
Old 17 Jan 2013, 05:20 am
Vlefaive's Avatar
Senior Cruiser
 
Join Date: Jun 2012
Location: Whitby ON Canada
Posts: 1,630
Default Re: My $20 fix for very rough idle & stalling.

I replaced a cam sensor, because of similar symptoms, but I ran a key dance following a check engine light.
Try a key dance anyway?
mnahmnah likes this.
__________________
'03 GT Blue/ autostick.. 160,000KM ( That's 100,000miles for y'all South of the border ) All the options, the heated leather is a must up here in Canada, Love the solid heavy duty feel and obvious Torque.. The Turbo is strong, fast and reliable.. People that don't understand the love of a PT, probably don't deserve to.
Reply With Quote
  #10 (permalink)  
Old 17 Jan 2013, 06:15 am
mnahmnah's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Wisconsin
Posts: 304
Default Re: My $20 fix for very rough idle & stalling.

Thank you for the suggestion.. I have, many times,, just in case! I get nothing... not even the dashes ------ just "done".

Also I bought an Actron scanner/code reader, and no codes there either, plus all the systems it monitors check out ok. ?? This is why I'm confused. The malfunction light didn't even come on when I didn't tighten the gas cap like it's supposed to. Found that 2 days later...


I have a feeling I'm going to be replacing a lot of sensors...
__________________
2001 LE, 168,000 miles.
One of the split seats went into a dumpster in Tulsa. The arm rest unscrewed and fell off. It's on its 2nd timing belt. Surviving the Upper Peninsula winters.
Reply With Quote
Reply

Tags
air mixture, arco, rough idle, stalling


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle-Replacing the IAC Idle Air Controller engineerrock Tech & Performance Forum 9 07 Jun 2014 07:24 pm
Stalling, rough idle, running "hard", hesitation LiLOrion Tech & Performance Forum 36 21 May 2013 12:43 pm
Rough idle / stalling stek2008 General PT Cruiser Discussions 9 30 Oct 2011 10:22 pm
Car is stalling/RPM's Go up and down/running rough and stuttering/NO ERROR CODES? darkpt06 Tech & Performance Forum 3 28 Sep 2011 06:55 pm
Rough Idle, Rough @60, check engine light NEW Dystroy Tech & Performance Forum 8 12 Jan 2009 09:07 pm


All times are GMT -5. The time now is 05:49 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors