PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine quits while driving

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Jan 2013, 11:18 pm
Fresh Cruiser
 
Join Date: Jan 2009
Posts: 14
Default Engine quits while driving

Hi. I own a 2001 limited edition PT with 97k+. Several times during the last few months my cruiser has experienced what I can only describe as a momentary seizure. Everything quits for a few seconds: lights, radio go out; orange ABS and TRAC lights appear on dash, and sometimes the trip odometer resets to zero. Engine then revs, soon followed by continued forward motion. Bad enough going 40 in town, but rather disconcerting when I'm doing 70 on I-66. Finally took it to my local AAA rated shop. They said it might require three separate diagnostics but went for charging system first and said battery bad and replaced it; they told me bad battery could cause these systems. Car ran fine for a month, but has done the same thing twice in the last week. This is getting aggravating, and I don't feel like a more expensive diagnostic if anyone out there in PT Forum land has heard of this. I did search topics for this and generally Googled it but didn't find anything.I would appreciate any help here! I really like my PT, in spite of all the dough I've had to sink into it.
Reply With Quote
  #2 (permalink)  
Old 17 Jan 2013, 11:22 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: Engine quits while driving

Quote:
Originally Posted by Ornald View Post
Hi. I own a 2001 limited edition PT with 97k+. Several times during the last few months my cruiser has experienced what I can only describe as a momentary seizure. Everything quits for a few seconds: lights, radio go out; orange ABS and TRAC lights appear on dash, and sometimes the trip odometer resets to zero. Engine then revs, soon followed by continued forward motion. Bad enough going 40 in town, but rather disconcerting when I'm doing 70 on I-66. Finally took it to my local AAA rated shop. They said it might require three separate diagnostics but went for charging system first and said battery bad and replaced it; they told me bad battery could cause these systems. Car ran fine for a month, but has done the same thing twice in the last week. This is getting aggravating, and I don't feel like a more expensive diagnostic if anyone out there in PT Forum land has heard of this. I did search topics for this and generally Googled it but didn't find anything.I would appreciate any help here! I really like my PT, in spite of all the dough I've had to sink into it.
Certainly sounds like a power issue, i would check all the connections to and from the battery, replace the battery cables, check the grounds around the battery box to the fuse box. I had a neon do this because of a bad connection and ended up melting my battery terminals to the posts :/

But check all that out first and formost before you pay for any expensive diagnostics, would suck to pay $70 for some to tell you a battery cable was corroded somewhere that you cant see the second you open the hood
Reply With Quote
  #3 (permalink)  
Old 20 Jan 2013, 12:55 pm
Fresh Cruiser
 
Join Date: Jan 2009
Posts: 14
Default Re: Engine quits while driving

Thanks. I will check cables, although I would hope the charging system check done would have included that, but you never know. The original cable connections at the battery rotted right off and needed new ends put on, so who knows what's further into the cables or what the other ends look like. Sounds like a good place to start.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
engine cuts off while driving leesa47 Tech & Performance Forum 2 19 Apr 2012 11:14 am
Engine died while driving, Blown ASD fuse & VERY Hot MyCruiserHatesMe Tech & Performance Forum 11 10 Aug 2011 08:50 am
2007 PT Touiring Edition-Engines quits tmh620 Tech & Performance Forum 0 23 Dec 2010 03:19 pm
pt stalls and quits after putting into drive notme Tech & Performance Forum 5 02 Sep 2010 11:31 am
Rough idle/engine miss while driving smithtls Tech & Performance Forum 5 10 Oct 2002 02:02 pm


All times are GMT -5. The time now is 01:00 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors