PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2004 PT Cruiser TE turning over, but not firing.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Feb 2013, 08:48 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 3
Default 2004 PT Cruiser TE turning over, but not firing.

Hi! I have a 2004 Cruiser Touring Edition, and when I try to start it, it's turning over, but not firing.
Some other key details;
It's still getting a spark.
The check engine light only comes on when turned to the on the on position.
Just put a brand new starter in.
Has a full tank of gas.
Fuel pump/filter is working fine.
Hasn't ran on E.
Just got a new battery, even when the battery is hooked up to my dad's truck, still won't fire.
Has enough oil, tranny fluid, and antifreeze.

Was working just fine yesterday, then when I decided to go to work today, it decided to not work. Any suggestions on what it could possibly be?

I'm taking it to an auto part store tomorrow, to get it hooked up to a computer to see if they can find a fault code, but I want a general idea on what it could be, before taking it in.

Thanks in advance to anyone who can help!
Reply With Quote
  #2 (permalink)  
Old 18 Feb 2013, 09:59 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2004 PT Cruiser TE turning over, but not firing.

You can pull your own fault codes from the computer right now.....

How to retrieve fault codes.

BTW, what kind of mileage do you have? If the codes come back anything like P0340 or P0344, and your anywhere near 100,000 miles, you might have a broken timing belt.

Last edited by CREWZIN; 18 Feb 2013 at 10:14 pm.
Reply With Quote
  #3 (permalink)  
Old 18 Feb 2013, 10:55 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 3
Default Re: 2004 PT Cruiser TE turning over, but not firing.

I can't, my laptop won't stay on unless it's plugged in.
And also, not sure about the millage, it's up there though. It can't be the timing belt, I recently got that fixed with what seems to be a million other problems.

Last edited by Kari; 18 Feb 2013 at 10:57 pm.
Reply With Quote
  #4 (permalink)  
Old 18 Feb 2013, 11:16 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2004 PT Cruiser TE turning over, but not firing.

Quote:
Originally Posted by Kari View Post
I can't, my laptop won't stay on unless it's plugged in.
Not sure what you mean with your laptop. You can get the fault codes from the cars computer just by turning the ignition key the right way. No laptop needed. The codes show up in the middle dial where the odometer is. Follow the instructions in the link I posted.
Reply With Quote
  #5 (permalink)  
Old 18 Feb 2013, 11:24 pm
Fresh Cruiser
 
Join Date: Feb 2013
Posts: 3
Default Re: 2004 PT Cruiser TE turning over, but not firing.

I noticed that, after I went to the link. I did that, and got p0522 as the code.
Reply With Quote
  #6 (permalink)  
Old 19 Feb 2013, 05:00 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,253
Default Re: 2004 PT Cruiser TE turning over, but not firing.

p0522 - engine oil pressure sensor /switch circuit voltage low. broken wire, poor connection, bad oil pressure switch. it's a start! sorry
Reply With Quote
  #7 (permalink)  
Old 19 Feb 2013, 07:33 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2004 PT Cruiser TE turning over, but not firing.

There's another owner with a problem like yours. Here's the thread and the advice I gave.

Cruiser Will Not Start
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 PT cruiser not firing no codes bentonggbn Tech & Performance Forum 13 19 Jul 2014 10:09 am
Please help again - Sputtering and Back firing clickhere4dawn Tech & Performance Forum 10 23 Nov 2012 11:25 am
2002 PT Cruiser not firing fletch65 Tech & Performance Forum 28 20 Apr 2011 09:46 am
Miss firing code cyl 4 devil9 Tech & Performance Forum 3 04 Jun 2010 09:36 am
PT Cruiser Coupe will be at Turning Stone coach Northeast PT Forum 0 15 Apr 2005 08:05 am


All times are GMT -5. The time now is 11:14 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors