PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
erratic idle

 
Like Tree1Likes
  • 1 Post By dextv

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Feb 2013, 07:09 pm
Fresh Cruiser
 
Join Date: Nov 2012
Location: the woodlands, tx
Posts: 6
Unhappy erratic idle

hey, i've been reading the forum for a couple of months, but this is my first post. i am experiencing rough idle. i recently bought a 2001 pt cruiser with 5 speed with 78,000 miles. i took it to a shop before i bought it and knew it needed some things replaced, but nothing urgent. 2 months and everything is fine. 2 weeks ago, when i cranked it, the idle was high and erratic. when i touch the accelerator, the idle jumps from 1500 to over 2500, gradually comes down, but still erratic. i spent days going thru the forum, looking for help. i'm not a seasoned mechanic, but i'm on a budget. i cleaned the iac (a real challenge), checked the map sensor, checked pcv valve, replaced pcv hose (badly cracked), cleaned throttle body. for days, no check engine light, then, yesterday, after i cleaned the throttle body, the check engine light came on. i figured it was because of the throttle body cleaner. but the codes are (not in order) 0171, 1684, 0123, 1193. last year the previous owner replaced the timing belt and water pump.
today, i cleared the codes and restarted the engine (still idling high and rough) and rechecked the engine codes..... only a 1684 now-- which is because i disconnected the battery to clear the old codes....
i tried to upload a video of the idle but get invalid file when i try to post video or link to url....
any help is appreciated...
Reply With Quote
  #2 (permalink)  
Old 26 Feb 2013, 09:08 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: erratic idle

Quote:
Originally Posted by dextv View Post
hey, i've been reading the forum for a couple of months, but this is my first post. i am experiencing rough idle. i recently bought a 2001 pt cruiser with 5 speed with 78,000 miles. i took it to a shop before i bought it and knew it needed some things replaced, but nothing urgent. 2 months and everything is fine. 2 weeks ago, when i cranked it, the idle was high and erratic. when i touch the accelerator, the idle jumps from 1500 to over 2500, gradually comes down, but still erratic. i spent days going thru the forum, looking for help. i'm not a seasoned mechanic, but i'm on a budget. i cleaned the iac (a real challenge), checked the map sensor, checked pcv valve, replaced pcv hose (badly cracked), cleaned throttle body. for days, no check engine light, then, yesterday, after i cleaned the throttle body, the check engine light came on. i figured it was because of the throttle body cleaner. but the codes are (not in order) 0171, 1684, 0123, 1193. last year the previous owner replaced the timing belt and water pump.
today, i cleared the codes and restarted the engine (still idling high and rough) and rechecked the engine codes..... only a 1684 now-- which is because i disconnected the battery to clear the old codes....
i tried to upload a video of the idle but get invalid file when i try to post video or link to url....
any help is appreciated...
Well the 1684 means the battery has been disconnected in the past 60 starts, so ignore that

the 0171 means the engine is running to lean.
0123 is TPS high voltage
1193 is insufficient flow to the EGR valve.

So in short, i would replace the EGR :-D

I would also replace the intake temp sensor on the rubber hose coming from your air box :-D

Also remove the upper intake manifold, and clean out your throttle body, to insure sufficient airflow into the manifold :-D
Replace the air filter too :-D

That should fix ya right up :-)

Last edited by pluminator; 26 Feb 2013 at 09:13 pm. Reason: because i cant type okay! :-p
Reply With Quote
  #3 (permalink)  
Old 26 Feb 2013, 09:31 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,882
Default Re: erratic idle

What is the temp gauge reading?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 27 Feb 2013, 01:33 am
Fresh Cruiser
 
Join Date: Nov 2012
Location: the woodlands, tx
Posts: 6
Default Re: erratic idle

engine code just shows 1684....
idle still erratic and high...
throttle body has been cleaned...
air filter replaced (when i replaced the battery)...
can the egr and intake temp sensor be tested? (i'm on a budget)...
temp gauge never got above normal, but i haven't driven any since the idle went nuts...didn't want to get stranded if i could help it.....just been idling in the garage. (i'm driving a 1990 miata [285,000 miles] while i work on the cruiser)
thx

Last edited by dextv; 27 Feb 2013 at 02:01 am.
Reply With Quote
  #5 (permalink)  
Old 27 Feb 2013, 08:06 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,253
Default Re: erratic idle

Your egr valve could be stuck open. Test by removing hose from egr and apply vacuum. Dab paint on center pin of egr. It should move up and down. Sometimes they can be cleaned by removing the carbon build-up.
Reply With Quote
  #6 (permalink)  
Old 27 Feb 2013, 10:42 am
Fresh Cruiser
 
Join Date: Nov 2012
Location: the woodlands, tx
Posts: 6
Default Re: erratic idle

apply vacuum to the hose?
how much vacuum?
it is ok to spray cleaner into it while it's on the car?
thx
Reply With Quote
  #7 (permalink)  
Old 27 Feb 2013, 11:36 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,253
Default Re: erratic idle

you can steal vacuum from the transducer feed line which is a round plastic thingie next to the egr. When piped direct to the egr hose fitting, the pin should move when connected or disconnected. Use a penetrating oil on the pin [manifold side only].
Reply With Quote
  #8 (permalink)  
Old 27 Feb 2013, 04:14 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: erratic idle

Quote:
Originally Posted by dextv View Post
engine code just shows 1684....
idle still erratic and high...
throttle body has been cleaned...
air filter replaced (when i replaced the battery)...
can the egr and intake temp sensor be tested? (i'm on a budget)...
temp gauge never got above normal, but i haven't driven any since the idle went nuts...didn't want to get stranded if i could help it.....just been idling in the garage. (i'm driving a 1990 miata [285,000 miles] while i work on the cruiser)
thx
Intake temp is easy to test, disconnect it and start the car, if the revs still stay the same, it probably has something to do with it, if they go even higher, its probably okay.
Reply With Quote
  #9 (permalink)  
Old 27 Feb 2013, 07:47 pm
Fresh Cruiser
 
Join Date: Nov 2012
Location: the woodlands, tx
Posts: 6
Smile Re: erratic idle


SUCCESS !!!
while i was trying to figure out the egr, i checked all the hoses in the area and found another hose that had to be replaced (in addition to the pcv hose i replaced)...
cruiser is runnin' great again....
thanks for the help


next is the upper engine mount, rear brakes, and driver axle seal (but not today)
Busted_PT likes this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic idling with a burst of steam nacarre Tech & Performance Forum 22 21 Sep 2012 02:12 pm
Erratic gauge and dash lights activity Destroyer4 Tech & Performance Forum 8 26 Jun 2012 03:31 pm
erratic iddle when car stars almonte General PT Cruiser Discussions 3 14 Jul 2011 10:39 pm
Erratic starting and power locks chatter cruisinglite Tech & Performance Forum 27 21 Oct 2009 06:43 am
Erratic Door Locks/Airbag/Rear Hatch trikosuave General PT Cruiser Discussions 1 15 Apr 2007 11:23 am


All times are GMT -5. The time now is 03:17 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors