PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Please Help!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Mar 2013, 09:13 pm
Fresh Cruiser
 
Join Date: Mar 2013
Location: toronto
Posts: 2
Default Please Help!

I have been having problems with my car. I am a single mother on an extremely limited budget and can't afford to run to a mechanic every time I have a problem. It started about 2 months ago, it was the battery, I replaced it and didn't have any issues till last week. It started no problem, brought my son to the sitters, started again no problems, stopped to run an errand and again started no problems. About an hour after coming home I went to start it again to go to work and nothing, there was enough juice to unlock the car with my key and the radio was on, but the car wouldn't turn, no clicking nothing. Couldn't even lock the car with my key, had to go around and lock the doors manually. I automatically though it was the aternator as the battery is brand new, but I didn't have any of the normal tell tale signs that this could be the issue.
I didn't try to start it all week, on Saturday I thought I would test it and it started no issues. I haven't drove it anywhere. Tonight I went to start it to be sure it will start as I have to bring it tomorrow to get emissions testing done and an oil change, started no problem, turned over right away, but now it's idling roughly and there is a bit of a knocking sound. When I rev the engine the knocking gets worse. Does anyone have any idea of what it could be? I know bit about cars, and anytime I have gone to a mechanic they talk to me like I know nothing and try to rip me off.
Reply With Quote
  #2 (permalink)  
Old 07 Mar 2013, 09:15 pm
Fresh Cruiser
 
Join Date: Mar 2013
Location: toronto
Posts: 2
Default Re: Please Help!

I should of added it's a 2006, Dream edition, had 99k on it. Spark plugs have been replaced recently as well as the thermostat. Codes don't come up either
Reply With Quote
  #3 (permalink)  
Old 07 Mar 2013, 10:26 pm
Vlefaive's Avatar
Senior Cruiser
 
Join Date: Jun 2012
Location: Whitby ON Canada
Posts: 1,630
Default Re: Please Help!

Hi from Whitby ... I would take it back to where you got the battery ? Might have got a bad one ? I even considered one from Costco today.... second guessed that .
__________________
'03 GT Blue/ autostick.. 160,000KM ( That's 100,000miles for y'all South of the border ) All the options, the heated leather is a must up here in Canada, Love the solid heavy duty feel and obvious Torque.. The Turbo is strong, fast and reliable.. People that don't understand the love of a PT, probably don't deserve to.
Reply With Quote
  #4 (permalink)  
Old 07 Mar 2013, 10:53 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Please Help!

Hate to start off with the bad news But, your due for a timing belt change and is it's cheap. Somewhere in the neighborhood of $1000, due at 100,000 miles.

The car not starting and the knocking with rough idle don't seem to be related that I can think of. As was said, the battery, even when new, could have a bad/dead cell. Most auto stores will do a battery and charging test for free and that would eliminate if it is the battery. Hopefully they looked at the battery cables for any corrosion before putting in the new one.

The rough idle and knocking doesn't sound good. Could be that the timing belt is slipping which would give you both symptoms but there's other possibilities. Do you happen to have an engine light on? That will give you fault codes to help us help you. Here's how to get the fault codes from the computer...

How to retrieve fault codes.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:57 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors