PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Coolant problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Mar 2013, 11:15 am
Fresh Cruiser
 
Join Date: May 2012
Posts: 13
Default Coolant problem

Hi all,

I have noticed over the past few weeks that I have been losing coolant, its got to the point now that I can see its coming out from the radiator cap, i've ordered a new cap.
However today I have been having trouble with the coolant being expelled from the expansion tank all over the floor, this then drops the level of coolant to very low in the thermostat housing, it doesn't do it when the car idles as I've had it running for 3 hours on the drive with no problems, however if i drive it for a mile or so the expansion tank gurgles like mad and expels the coolant ....

My question is , is the whole problem being caused by the radiator cap not sealing properly ? or is it something more serious ?

I've checked the oil and its nice and clear, the car runs fine other than this ....

I would appreciate your help on this guys


Thanks
Reply With Quote
  #2 (permalink)  
Old 11 Mar 2013, 12:26 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: Coolant problem

i'm gonna guess that when the coolant started coming out the radiator cap, air was being sucked in. my 2002 was doing the same thing. when you get the new cap make sure you burp the system of all the air.

i let mine sit in my garage for 2 weeks before i had it towed to the dealer. pressure check showed it was leaking from either the thermostat housing or gasket. had them replace both along with thermostat and flushed the system and filled with the red hoat coolant.

$503 later and all is good. may seem like a lot of money but for piece of mind, well worth it.
__________________
2005 Toyota Camry LE Salsa Red (Wife's)
2002 Automatic N/A (Mine) Inferno Red
2016 Kia Soul Plus Black
Reply With Quote
  #3 (permalink)  
Old 11 Mar 2013, 12:54 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 13
Default Re: Coolant problem

I've just had a thought, I put some radweld in the system yesterday, I wonder if this has caused a blockage somewhere ?? totally forgot about putting it in !!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshoot coolant leak: Photo of Coolant on top of engine radiator cap MarcusO Tech & Performance Forum 7 27 Apr 2013 09:16 am
Coolant System Problem. PLEASE HELP!!!! cgrayflorida General PT Cruiser Discussions 2 24 Jul 2010 05:10 pm
02 pt cruiser coolant problem vanhalen7174 Tech & Performance Forum 0 15 Apr 2010 01:57 pm
Temperature & Coolant Problem SRMarsh General PT Cruiser Discussions 7 13 May 2009 01:42 pm
Coolant Problem DIYPTGUY Tech & Performance Forum 12 04 May 2009 03:25 pm


All times are GMT -5. The time now is 01:43 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors