PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
misfire,code po300 po304

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Apr 2013, 09:13 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 4
Default misfire,code po300 po304

ok I am new to this forum. I have a 2005 2.4l turbo,started to misfire at idle and hiway speeds. Changed plugs wires, coil,cam position sensor. Still has misfire,checked coil output with tester and all cylinders are receiving spark. all injectors appear to be working,with the screw driver method, all clicking. I have sprayed starting fluid around intake manifold with no change in miss. Have not done a compression test yet,but why would this all of a sudden start with no previous indications. Getting very frustrated,starting to dream about matches and gas cans..lol:
Reply With Quote
  #2 (permalink)  
Old 09 Apr 2013, 05:17 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: misfire,code po300 po304

Did you use a Mopar cam sensor? Lots of aftermarket sensors don't work.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 09 Apr 2013, 02:02 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 4
Default Re: misfire,code po300 po304

Yes I used a mopar sensor.Today it seems to run better but am getting a flashing check engine light at idle,does not seem to be missing now under load. when I say missing at idle it doesn't do it every time. I used bosch platinum plugs , could the plugs be giving me issues? This is getting to be very frustrating. I am going to change intake manifold gaskets and valve cover gaskets on the week-end,I notice a small amount of oil in spark plug tubes so it is starting to leak a bit.Thanks for any help
Reply With Quote
  #4 (permalink)  
Old 09 Apr 2013, 08:25 pm
Cool Cruiser
 
Join Date: May 2011
Posts: 228
Default Re: misfire,code po300 po304

Mine is doing the exact same thing. I am thinking intermittent injector failure.
Reply With Quote
  #5 (permalink)  
Old 10 Apr 2013, 05:05 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: misfire,code po300 po304

Flashing check engine light is serious - what code(s)?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #6 (permalink)  
Old 10 Apr 2013, 10:10 am
Fresh Cruiser
 
Join Date: Jul 2012
Posts: 28
Default Re: misfire,code po300 po304

I have similar issues, I just deal with it. I don't think theres much left to try/replace/etc for mine, but you can try and make sure you have a good ground and positive cable. i replaced my positive cable, and so far no engine light, it idles better and doesn't seem to miss (much)

-Nick
Reply With Quote
  #7 (permalink)  
Old 10 Apr 2013, 01:58 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 4
Default Re: misfire,code po300 po304

codes are po300,po304. multiple misfires and misfire cylinder four
Reply With Quote
  #8 (permalink)  
Old 10 Apr 2013, 07:27 pm
Regular Cruiser
 
Join Date: Feb 2013
Location: Texas
Posts: 150
Default Re: misfire,code po300 po304

My advice is to take it to the dealer and ask for a diagnosis only. That way you're not wasting your money replacing parts that don't need to be replaced.
__________________
2008 PT Cruiser Touring 135,000 miles
Reply With Quote
  #9 (permalink)  
Old 12 Apr 2013, 08:52 pm
Cool Cruiser
 
Join Date: May 2011
Posts: 228
Default Re: misfire,code po300 po304

Mine is PO302. Flashing at idle then on off idle when driving
Reply With Quote
  #10 (permalink)  
Old 12 Apr 2013, 08:54 pm
Cool Cruiser
 
Join Date: May 2011
Posts: 228
Default Re: misfire,code po300 po304

Im gonna clean the MAP sensor. Or, park it over tall grass after driving it for couple hours
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
#1 misfire code rocnroller Tech & Performance Forum 1 12 Feb 2013 02:37 pm
code reads po300 echillie1 Tech & Performance Forum 6 03 Mar 2012 07:46 pm
p0304 misfire code sporttraveler Tech & Performance Forum 9 17 Feb 2012 08:26 pm
misfire code at idle specialkay Tech & Performance Forum 4 08 Dec 2011 08:28 pm
ERROR CODE PO335 & PO300 - HELP! PTZIGGY Tech & Performance Forum 7 09 Dec 2009 05:53 pm


All times are GMT -5. The time now is 11:27 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors