PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
ac problem still a problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Apr 2013, 03:36 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 11
Default ac problem still a problem

hi everyone. I've been checking this site out for the past year, but this is the first time I've posted anything. (Great site btw) so I have a 2008 non turbo pt cruiser. I got it about a year and a half ago and love it. Had to replace the cam shaft sensor but no big deal. I got the car in september and had no problems (except sensor) until summer came. Whenever I turned the ac on the car would randomly shake. Took back to my dealer (not chrysler and no warrenty) and they said it had to much pressure. Seemed to work for a week but then it returned. Took back to dealership and they said compressor was going bad. That it tears itself up from the inside out? But then I checked out these forums and read about the fan. So just to double check I went to chrysler paid 100 bucks and they told me it was the fan modulator. That the fan wasn't working at all. Was told the fan and modulator all comes together and it would be 800 to fix. So I went out and bought the fan and had my boyfriend and his dad replace it. Tested it out and it worked! Now a week later and 90 degree weather I turn on my ac and while sitting at a light the car starts shaking! What am I missing? I've already spent a good amount of money getting it diagnosed. And I live in va where the humidity becomes unbearable in the summer. I'm still paying on this car and l love it but this is driving me crazy. Btw my boyfriend is not a mechanic but knows his way around cars and his dad was a mechanic for 12 years. Does anyone have an idea what's wrong? Could it be the compressor? My car just hit 60000 miles. Any help would be greatly appreciated
Reply With Quote
  #2 (permalink)  
Old 09 Apr 2013, 08:03 pm
Fresh Cruiser
 
Join Date: Oct 2010
Posts: 4
Default Re: ac problem still a problem

I fixed same issue with IAC controller. (Idle Air Controller) on my 2006
non turbo
Reply With Quote
  #3 (permalink)  
Old 10 Apr 2013, 01:03 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,253
Default Re: ac problem still a problem

There is a pressure switch in the AC circuit which turns on the radiator fan.[indirectly] -- When the engine is cold and idling; turn on the AC. Turn interior fan on medium. The car should blow cold cold air within 30 sec? Some time between turning on the AC and 3 minutes later the radiator fan should start. You should be able to hear it running or see it turning with a light and a mirror. Does the engine shake as soon as you turn on the AC? or later?

Also, what is the rpm before and after turning on the AC? [see johnware above]

Sometimes things take time.

Last edited by pt06; 10 Apr 2013 at 01:08 am.
Reply With Quote
  #4 (permalink)  
Old 13 Apr 2013, 08:13 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 11
Default Re: ac problem still a problem

Ok so update to my situation. After I posted this my pt overheated on me (first time) boyfriend checked car out and said the fan was not running.....again. futher investigation showed the plug that plugs the radiator fan to the car was messed up and not staying plugged. So what did we do? We taped it lol. Now car is not over heating, ac is working, and I'm at peace. Thing is though the car still runs a lil rough. No stumble or anything like that. Just not smooth. Is this normal? Do u think I need to change spark plugs? I'm not getting any codes and everything is seemingly fine just wanna make my ride a lil smoother
Reply With Quote
  #5 (permalink)  
Old 14 Apr 2013, 04:36 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,253
Default Re: ac problem still a problem

Day 311; Pull out easiest plug to get to. Check gap. if over .045 gap, change all plugs. Champion re16mc gapped to .040.

If the plug wires have'nt been changed yet, now is the time. If they are the original wires, they might be dated 07 or 08 mopar. I have had good luck with the mopar [Chrysler] wires.
Reply With Quote
  #6 (permalink)  
Old 14 Apr 2013, 07:24 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 11
Default Re: ac problem still a problem

Ok I will def try that. Thanks
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd fob/key problem CoolVanillla General PT Cruiser Discussions 5 25 Dec 2012 06:22 pm
AC problem? not sure.. demon666 Tech & Performance Forum 2 29 Aug 2011 04:57 pm
is it a balljoint problem or a wheel bearing problem? phtech Tech & Performance Forum 2 05 Mar 2011 04:33 pm
Will this cause a problem? crazie.eddie General PT Cruiser Discussions 9 24 Oct 2004 05:29 am
still having problem mo-cash General Turbo Discussions 6 10 Feb 2004 09:16 pm


All times are GMT -5. The time now is 12:03 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors