PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
overheating weird problem...

 
Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Apr 2013, 07:07 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 17
Default overheating weird problem...

Ok guys im new to the forum but not new to cars...I have an srt4 and so we are in the same family lol...ok my dad bought a pt cruiser cheap and the lady told him she was told it might be the water pump but I don't think it is...it had straight coolant in it, not 50/50 mix just straight...the car was overheating so I drained that coolant and put straight distilled water in it and a new thermostat just to test it...the car ran for about half an hour no problem I drove it around and then let it sit for another 20 mins or so and it started overheating...let it cool down and kept pressing on the hoses trying to rid the system of air while adding water and bubbles were still coming out...I let the car sit this time for about 45 min or so and the gauge was at mid point no problem and the fan would come on and it would drop...everything was fine then it overheated again...now I did read that these cars have problems with the fans and I did notice that some times the fan would turn on and it wouldn't sound as loud as other times...when it would start overheat I noticed it the most...don't know if its in my head...now I also read that when you turn the ac on the fan should turn on no matter the temp and the fan doesn't turn on with the ac on...the ac doesn't cool which I don't know why because I haven't been able to get to that yet...I need your help guys my dad really needs the car and I want to help him...im leaning towards the fans or fan relays...I also noticed that the bleeder valve by the thermostat never lets air or water out when you open it to try to bleed the system...idk why...I took it off and the actual valve is not clogged...I know when I drained the system in my srt4 I used that bleeder valve to rid the system of air and I would open it until a stream of water comes out...what do you guys recommend? please help...thank you...
Reply With Quote
  #2 (permalink)  
Old 15 Apr 2013, 09:13 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: overheating weird problem...

Not sure why the bleeder valve wouldn't work but the fan is a weak point. The inner brushes mostly for the low speed tend to burn out and yes, the fan should run no matter what the temp is if the A/C is on.

Easy to replace the fan and housing for under $100 with a Dorman unit which has a lifetime warranty. That could possibly fix your A/C and overheating problem in one go.
Teekypt likes this.
Reply With Quote
  #3 (permalink)  
Old 15 Apr 2013, 10:14 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 17
Default Re: overheating weird problem...

thanx for the reply...so at idle with the ac off it should be at high speed? My question is if it doesn't work when you turn the ac on does it automatically mean the fan is not doing it's job when not using the ac and car idling? I want to know if the fan is the problem...could the relays have something do do with it? If so how do I check them? I read somewhere they're under the battery, is it true? I'm not very good with electricity...also, do I have to remove the intake manifold to get the fan off? It certainly looks that way...lastly, what coolant do these cars use? I know the srt4 uses the red Mopar coolant that you can only get at the dealer if so I still have almost a whole jug left over from my srt so I can use that...I know water boils faster than coolant so can running straight distilled water be causing it to overheat? Sorry for all the questions but I really need to know...
Reply With Quote
  #4 (permalink)  
Old 16 Apr 2013, 12:39 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,253
Default Re: overheating weird problem...

It is likely that your bleeder is plugged. Or the aluminum housing is corroded. After bleeding properly, run engine till it gets hot. Note level of coolant in the coolant reservoir. Let engine cool down. Level of coolant should drop. If not, check reservoir hose for cracks and radiator cap seals for cracks. --- In addition, you could also have a fan issue.
Reply With Quote
  #5 (permalink)  
Old 16 Apr 2013, 07:29 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 17
Default Re: overheating weird problem...

yes I suspect the aluminum housing is corroded because I pulled the bleeder and it is not plugged...I will check the fan and see but im not very good with electricity so when it comes to relays and all that stuff im screwed lol...if the car ran for 45 min straight without overheating does that rule out the water pump? how can I make sure its not the water pump before I go any further?
Reply With Quote
  #6 (permalink)  
Old 16 Apr 2013, 08:06 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: overheating weird problem...

The most common sign of a failed water pump is a small leak from the hole at the bottom of the pump itself.

Something to read:

How to Test a Water Pump | eHow.com
Reply With Quote
  #7 (permalink)  
Old 16 Apr 2013, 08:15 am
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: overheating weird problem...

Just something to consider... The fan won't kick on with the AC if the compressor doesn't kick on. Make sure the ac compressor engages before throwing money at the fan
Reply With Quote
  #8 (permalink)  
Old 16 Apr 2013, 05:21 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 17
Default Re: overheating weird problem...

ah crap...ok so how do I make sure the compressor kicks on? by listening to it? I know the one in the srt4 makes a loud noise when it turns on...crwezin I red that article and when I poured coolant into it at first it wouldn't drop at all...after a while the engine started taking it but slowly...uh oh...could it mean water pump? does anyone sell timing belt/water pump kits for the pt cruiser? for example I know modern performance sells the kist for srt4 and that's where I bought mines and it came with belt, pump, tensioner, idler, etc...I called modern and they said one of the components wouldn't work on the pt cruiser...I think it was the tensioner or pump...don't remember...is there somewhere I can buy a kit like this for it?

Last edited by nor11384; 16 Apr 2013 at 05:29 pm.
Reply With Quote
  #9 (permalink)  
Old 17 Apr 2013, 12:52 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,253
Default Re: overheating weird problem...

nor; like Crewzin said, if the water pump isn't leaking, it is probably ok. --- Just stick a wire in the thermostat housing to clear the corrosion; but be careful not to damage the sealing surface.

Crewzin has a good article on how to test the fan.

From a cold start; hood up, AC button off, selector switch fully ccw, temp fully ccw, fan on medium. Start car and let it run about 1 minute. Idle should be down to 700-800 rpm. Listen to engine. Push AC button. Button should light up within 15 seconds. Radiator fan should start within 1 minute or sooner. If cold air comes out of the duct, you're golden. You should feel the engine 'strain' as the compressor kicks in. The radiator fan may cycle. The compressor may cycle depending on load.

Let us know.
Reply With Quote
  #10 (permalink)  
Old 17 Apr 2013, 07:52 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 17
Default Re: overheating weird problem...

thanx for replying...what do you mean by ccw? the 2001 pt cruiser doesn't have an ac button...it is just like the srt4 you turn the selector to one side and it's ac and other side it's fan...I found the dorman fan on rockautos website for $75 which the same exact as the autozone one they're selling for $130...so at least it's about 50 bucks I save there...I suspect the compressor isn't working because I don't hear it turn on...what should I check on it? The electrical connections? Bare with me gentlemen just need this thing going...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
weird stalling problem stevenmh Tech & Performance Forum 12 04 Nov 2016 09:31 pm
02 PT Cruiser Overheating (Very Weird issue) HDuece2 General PT Cruiser Discussions 19 12 Feb 2011 10:22 pm
Weird engine drivetrain problem I need help with... The13bats General Turbo Discussions 4 11 Jan 2011 07:16 pm
Weird Electrical Problem da12ask General PT Cruiser Discussions 6 21 May 2009 12:09 pm
Weird Problem JoeyC33 General PT Cruiser Discussions 5 06 Aug 2008 05:21 pm


All times are GMT -5. The time now is 04:28 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors