PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
No power when starting the car

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Apr 2013, 12:24 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 9
Default No power when starting the car

I have a 05 manual, when I put the key in the ignition and turn the key I lose power (everything turns off) its like it has no battery. The radio does not work, lights etc the battery is 4 months old, I thought it was the electrical ignitions switch so I changed it but still have the same problem. Any suggestions?
Reply With Quote
  #2 (permalink)  
Old 16 Apr 2013, 02:22 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: No power when starting the car

Is the battery charged? Something could have been left on or if you have fog lights they may be stuck on and ran the battery down. Also could be that the battery went bad. They do that sometimes. Check the cables too. They are a known source of issues too.
Reply With Quote
  #3 (permalink)  
Old 16 Apr 2013, 02:50 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 9
Default Re: No power when starting the car

I tested the battery battery is good I use this to commute everyday.it has no fog lights I checked everything if I left anything on everything is off, before the problem, when I got in the car everything was working but as soon as I turn the key everything shut down.
Reply With Quote
  #4 (permalink)  
Old 16 Apr 2013, 02:58 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: No power when starting the car

How did you test the battery? There may be enough juice to run some things but not enough amperage to turn it over.
Reply With Quote
  #5 (permalink)  
Old 16 Apr 2013, 03:44 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 9
Default Re: No power when starting the car

I tested with a battery tester. The car does not crank nore the head lights are deam, the dase light don't even turn on! I tried turning on the hazard lights on and I just heard a buzzing noise. Is there a main fuse that control the electrics that I can test?
Reply With Quote
  #6 (permalink)  
Old 16 Apr 2013, 04:24 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: No power when starting the car

did you try to jump it??? I knwo the battey says its fully charghed but try a jump its free and if it works it has to have something to do with the battery
Reply With Quote
  #7 (permalink)  
Old 16 Apr 2013, 04:43 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 9
Default Re: No power when starting the car

Quote:
Originally Posted by cruserdad1976 View Post
did you try to jump it??? I knwo the battey says its fully charghed but try a jump its free and if it works it has to have something to do with the battery
Yes I did nothing happen!
Reply With Quote
  #8 (permalink)  
Old 16 Apr 2013, 05:37 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: No power when starting the car

check the start wires OR does the car have a netural saftey switch
Reply With Quote
  #9 (permalink)  
Old 16 Apr 2013, 06:22 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 9
Default Re: No power when starting the car

Quote:
Originally Posted by cruserdad1976 View Post
check the start wires OR does the car have a netural saftey switch
I don't think it has a netural safty switch its manuel
Reply With Quote
  #10 (permalink)  
Old 16 Apr 2013, 08:27 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: No power when starting the car

even maual transmissions have a safety switch, probably behind the clutch pedal.
__________________
2005 Toyota Camry LE Salsa Red (Wife's)
2002 Automatic N/A (Mine) Inferno Red
2016 Kia Soul Plus Black
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 PT Cruiser no power to power seat paradyne64 General PT Cruiser Discussions 5 29 Dec 2016 02:54 am
Power Steering-it takes power just to steer it 05PTGT General Turbo Discussions 8 29 Jan 2013 08:37 pm
How to: Get power to radio and add circuits for power xwing777 Sound and Security Forum 19 10 Jun 2012 04:49 pm
FIXED: No power to power sockets, front or rear InTheBlack Tech & Performance Forum 2 11 Jan 2011 11:12 pm
Erratic starting and power locks chatter cruisinglite Tech & Performance Forum 27 21 Oct 2009 06:43 am


All times are GMT -5. The time now is 11:33 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors