PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
I'm close to selling it!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Apr 2013, 03:06 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 3
Default I'm close to selling it!

Hi guys,
I'm new here but I've used a lot of your forum info in these past few weeks. I have a 2002 PT Cruiser Touring edition that has 85k miles on it. My first problem was with the timing belt, it broke and took a lot of stuff with it because the tensioner locked up. At least that's what the mechanic said. All damages included, it cost about 1.2k to clean up.

Few weeks later I notice the foglight would come on and off at random.

Just about a week ago I was sitting in the drive-through lane at CookOut when my friend and I heard a loud pop-hiss similar to that of a trucks air brakes. At first I thought it was a semi very close, but then I noticed a white steam/fog coming out from under the car, 80% from the back, 10% on each side.

Identified and changed the multi-function switch.

Air conditioner no longer works. Fan will NOT kick on when AC is on and engine idle.

Radiator fan relays change. The old relay = no function.
New relay = ceaseless function even after ignition is off and engine is cold.

Change temperature sensor. HAVE YET TO TRY NEW RELAY WITH NEW SENSOR.

The radiator fan refuses to kick on. The fan itself works, if the boot is removed from the temperature sensor on the radiator, the fan kicks on and stays on as long as ignition is on. However, when replacing the boot to the sensor, the fan does not kick on. I will try the new relay as soon as I can afford another one.

Code reader at Advanced said to change the relay first, we did and the problem persisted.

Also, after this 'vent' of whatever gas or fluid that came from underneath the car, the alternator is putting out power but weakly.

In the morning, the car will slowly turn until ignition is achieved and then cut completely off. The second attempt to turn ignition requires fuel fed into the system much like a weedeater or chainsaw else ignition ceases.

battery test at advanced claims GOOD BATTERY but with weak alternator flux.

I'm at my end here, if it's not this relay sensor, I'm tempted to scrap the car.

I'm pretty upset that this car is dying at 85k miles!

Thanks for your help!
Reply With Quote
  #2 (permalink)  
Old 17 Apr 2013, 03:29 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: I'm close to selling it!

wow lots of issues FIrst off I would ahve changed the complete fan its about the same price and every thing si new
the fan quit the ac overheated and blew off the freon that was your white steam id almost bet the temp guage went to red line

I guess freon could ahev gotten in the altonator but it seems odd
its also odd to ahev a fully charged battery and a weak altenator???
lots of questions
Reply With Quote
  #3 (permalink)  
Old 17 Apr 2013, 03:34 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,910
Default Re: I'm close to selling it!

There's LOTS of threads on the radiator fan- It might even be stickied.
Do some reading because it comes up everyday.

Alternator; There's:

*Wiring
- Fusible link to starter (where actual charging juice goes)
- Regulator wiring, from alternator to PCM

*alternator itself

* Belt, and it's adjustment

* Regulator (in PCM)

The first three DO go bad, IDK if I've ever heard of regulator (hence entire PCM) of legitimately failing, dealerships have replaced them- Not bashful about throwing parts at it and handing you the bill.
If this were to fail, you can just wire in an old school chrysler regulator; EZ & Cheap

In Minnesota, we wouldn't scrap a car for no AC, easy enough on the few really hot days to just roll window down and suck it up.
Now the heater, on the other hand ...

Good luck!!
Reply With Quote
  #4 (permalink)  
Old 17 Apr 2013, 03:45 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 3
Default Re: I'm close to selling it!

The radiator fan works for sure. I'm not worried about the heat. I used to drive a '94 firebird formula with no heater or AC. I'm more worried about something going wrong in the system and causing another failure whether it be electrical or mechanical. We read a lot into this forum during the repairing process, I just decided to take a shot on here in case anyone had ever heard of a freon or radiator purge like that.

I took it over to my friends to replace the temp sensor, he's a mechanic. He said he had never heard of any of that happening and there was nothing in the puke tank, but he also said he doesn't have much experience with this particular vehicle.
Reply With Quote
  #5 (permalink)  
Old 17 Apr 2013, 05:08 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,910
Default Re: I'm close to selling it!

From what I've read (not much) and working around my AC, it seems to be pretty conventional- Same, generally, as other cars.

I'd guess, and my guesses are always wrong, that AC overheated with no fan on and a hose blew- At first I didn't get the 'release' was for sure from the AC
Reply With Quote
  #6 (permalink)  
Old 18 Apr 2013, 11:16 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 3
Default Re: I'm close to selling it!

Just replaced the relay. no fan activation.

put the old one back in and then fan comes right on, continuous.

got them to run the code reader with all the new stuff on it and it brought back the code P0118. the high speed fan relay and temperature sensor are freshly replaced.

any ideas? also, the boot is loose on the connector end of the temperature sensor, but the wires appear in tact and attached.
Reply With Quote
  #7 (permalink)  
Old 20 Apr 2013, 05:28 am
Fanatic Cruiser
 
Join Date: Jan 2013
Posts: 905
Default Re: I'm close to selling it!

The 'puke tank' must be up to the cold line when the engine is cold. See owner's manual.
Reply With Quote
  #8 (permalink)  
Old 20 Apr 2013, 10:23 am
Cool Cruiser
 
Join Date: May 2011
Posts: 222
Default Re: I'm close to selling it!

I feel your pain! I absolutely had to have one of these when they first came out. I bought a 2008 when my commute was longer. I have not gone 1 year without having some sort of problem with mine. There may be some exceptional lucky people out there with little to no issues, but judging by this forum you wouldnt know it
Reply With Quote
  #9 (permalink)  
Old 21 Apr 2013, 04:29 am
Fanatic Cruiser
 
Join Date: Jan 2013
Posts: 905
Default Re: I'm close to selling it!

L2; people with good running cars and people who have found good mechanics are not the ones that write into this site. Maybe 1% of PT owners write into here. Over 1,000,000 PT's were made.

The radiator fan seems to cause much confusion to both the car owner and the auto shops. With a wiring diagram, a test light, Crewzin's fan motor test, and some studying, most people can figure out the problem and replace only the bad part. $$$$ saved.
Reply With Quote
  #10 (permalink)  
Old 21 Apr 2013, 09:36 am
Cool Cruiser
 
Join Date: May 2011
Posts: 222
Default Re: I'm close to selling it!

I know. cant go two miles without seeing one. With that track record they all cant be bad. It my black cloud hanging over my head.
Reply With Quote
Reply

Tags
electrical, emergency purge?, radiator fan


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
rag top sunroof won't close Itsjilz General PT Cruiser Discussions 2 05 Apr 2013 02:35 pm
Getting close-RTTB in Oct. xwing777 General PT Cruiser Discussions 1 31 Jul 2012 12:34 am
So close to getting my PT (questions) LawChick General PT Cruiser Discussions 13 31 Jul 2009 12:54 pm
Getting close turbomangt The Detail Shop 0 17 Feb 2005 09:55 am
Soo close.... AlphaMoose General PT Cruiser Discussions 11 16 Dec 2003 06:25 pm


All times are GMT -5. The time now is 01:30 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors