PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
HELP ME! NO POWER TO ANYTHING!!

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Apr 2013, 03:39 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 10
Default HELP ME! NO POWER TO ANYTHING!!

i have a limited edition 2002 pt cruiser. my battery moved when i was stopping and the positive terminal touched the frame of the car and everything went dead. all fuses (engine bay and under dash) are fine visually. inspected all of them pulled them all out. disconnected all battery terminals (positive/negative) cleaned terminals and where the wires were grounded. nothing is working at all. no lights, i mean really no power to anything, doesn't crank no power. tried jumping it still nothing. took battery to auto zone and they say its 100%. I NEED ALL YOUR HELP PLEASE!! THANK YOU!!
Reply With Quote
  #2 (permalink)  
Old 21 Apr 2013, 07:38 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: HELP ME! NO POWER TO ANYTHING!!

Do the lights turn on? Dome light come on when you open the door? If not, trace/replace the battery cables because if your battery is good, all fuses are good, the battery power isn't getting to where it needs to go. You need to get/buy a voltage tester to see where the battery power is getting to. You only visually tested all the fuses, now find out if power is getting to the box itself. Double check fuse #13 in the PDC (Power Distribution Center) which is another name for the fuse box in the engine compartment. You did check all the fuses in the PDC as well as the interior fuse box, right?
Reply With Quote
  #3 (permalink)  
Old 21 Apr 2013, 05:01 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 10
Default Re: HELP ME! NO POWER TO ANYTHING!!

no lights come on at all. no power to anything. i tested the battery cables with a fluke. and they are still fine. i also tested the pdc with the fluke and its fine there too. but i tried it in the cigarette lighter in the car and dont get anything. im really stumped on this electrical issue cause there are so many possibilities. i just hope that my ecu isnt fried! even if it was shouldnt i still have power to atleast the light in the car?
Reply With Quote
  #4 (permalink)  
Old 21 Apr 2013, 05:05 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: HELP ME! NO POWER TO ANYTHING!!

Yes, you'd think there would still be power to the accessories even if the computer was bad.
Reply With Quote
  #5 (permalink)  
Old 21 Apr 2013, 05:19 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 10
Default Re: HELP ME! NO POWER TO ANYTHING!!

so where do i go from here? do you think the pdc could have been fried without all the fuses blowing? all suggestions would be looked into.
Reply With Quote
  #6 (permalink)  
Old 21 Apr 2013, 05:44 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: HELP ME! NO POWER TO ANYTHING!!

According to the chart for the 2001, there's two grounding wires from the battery. Make sure they aren't fried and that the battery has a good ground.

Carl48 likes this.
Reply With Quote
  #7 (permalink)  
Old 21 Apr 2013, 06:30 pm
Fanatic Cruiser
 
Join Date: Jun 2009
Location: Rochester, Michigan
Posts: 669
Default Re: HELP ME! NO POWER TO ANYTHING!!

When the positive terminal touched the frame, the return path was through the grounds...check the ground conductors and connections per Crewzins advice.
Reply With Quote
  #8 (permalink)  
Old 21 Apr 2013, 06:51 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 10
Default Re: HELP ME! NO POWER TO ANYTHING!!

Quote:
Originally Posted by CREWZIN View Post
According to the chart for the 2001, there's two grounding wires from the battery. Make sure they aren't fried and that the battery has a good ground.

would this be for the 2002 model also limited edition? looks different
Reply With Quote
  #9 (permalink)  
Old 21 Apr 2013, 07:00 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: HELP ME! NO POWER TO ANYTHING!!

Quote:
Originally Posted by souchiem View Post
would this be for the 2002 model also limited edition? looks different

The chart was taken from the Haynes/Chilton manual which covered the 2001 thru 2003 models. Doesn't matter what EDITION. They are all the same. A couple small changes like the EGR system in the 2003 but that doesn't matter in your situation.
Reply With Quote
  #10 (permalink)  
Old 22 Apr 2013, 02:03 pm
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 10
Default Re: HELP ME! NO POWER TO ANYTHING!!

Should there be a complete current when with a fluke connect positive and ground battery cable without battery in it?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 PT Cruiser no power to power seat paradyne64 General PT Cruiser Discussions 5 29 Dec 2016 02:54 am
Power Steering-it takes power just to steer it 05PTGT General Turbo Discussions 8 29 Jan 2013 08:37 pm
How to: Get power to radio and add circuits for power xwing777 Sound and Security Forum 19 10 Jun 2012 04:49 pm
Power?? jakeiniowa Stage Turbo Kits 15 08 Nov 2011 09:59 am
FIXED: No power to power sockets, front or rear InTheBlack Tech & Performance Forum 2 11 Jan 2011 11:12 pm


All times are GMT -5. The time now is 12:46 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors