PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine Check Light

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Mar 2004, 02:01 pm
Dedicated Cruiser
 
Join Date: Oct 2003
Location: Jacksonville, NC, USA.
Posts: 2,612
Default Engine Check Light

Last night my engine check light came on about 5 minutes from my house. When I got home I checked for any codes and received the following:

P0456 & P1684

I was able to find the following info only

P0456 Evaporative Emission Control System Leak Detected (very small leak)

P16XX Computer and Auxiliary Outputs

I made sure the fuel cap was on properly, then I disconnected the negative battery cable to see if anything would reset. The P0456 code went away but the P1684 remained.

Anyone have more info on the P1684 than just Computer and Auxiliary Outputs?

Anything else I should check or do?
Reply With Quote
  #2 (permalink)  
Old 13 Mar 2004, 02:29 pm
Ant Ant is offline
Young Cruiser
 
Join Date: Jun 2003
Location: Peoria, AZ.
Posts: 91
Default

It simply means your battery has been disconnected in last 50 starts.
The light should go out but it will stayed stored for a while. If you run your diagnostic check it will come up because you just disconnected the battery again; normal.
__________________
PT powered PT with:
Fully built HRC Turboed 2.4: Wiseco pistons, T2 rods, Port & Polished head (Bob Special) with oversize Stainless Steel valves, #14 Crane Cams, AF/X UDP, No balance shafts, Custom 3\" downpipe, 3\" hi flow exhaust, Ported GT intake manifold, Bored Throttle Body, 30 lb injectors, Water/Alc. injection
Reply With Quote
  #3 (permalink)  
Old 13 Mar 2004, 02:33 pm
Dedicated Cruiser
 
Join Date: Oct 2003
Location: Jacksonville, NC, USA.
Posts: 2,612
Default

Quote:
quote:Originally posted by Ant

It simply means your battery has been disconnected in last 50 starts.
The light should go out but it will stayed stored for a while. If you run your diagnostic check it will come up because you just disconnected the battery again; normal.
Thanks Ant. That's strange though, I have not disconnected my battery for several months. Could a low battery cause the same thing?
__________________

2002 Inferno Red PT Limited
Photos and more at: http://www.randgraphics.org/PT_Cruiser/demos/index.htm
Mercedes Wiki
Reply With Quote
  #4 (permalink)  
Old 13 Mar 2004, 09:16 pm
Cool Cruiser
 
Join Date: May 2003
Location: South Bend, IN.
Posts: 473
Default

Ant is correct for pre-2001 cars.
The P1684 is simply a PCM readiness code.
It means that communication between the PCM and BCM is working.
Ignore it.

Reply With Quote
  #5 (permalink)  
Old 13 Mar 2004, 10:04 pm
Dedicated Cruiser
 
Join Date: Oct 2003
Location: Jacksonville, NC, USA.
Posts: 2,612
Default

Quote:
quote:Originally posted by MX-5

Ant is correct for pre-2001 cars.
The P1684 is simply a PCM readiness code.
It means that communication between the PCM and BCM is working.
Ignore it.

Thanks MX-5!
__________________

2002 Inferno Red PT Limited
Photos and more at: http://www.randgraphics.org/PT_Cruiser/demos/index.htm
Mercedes Wiki
Reply With Quote
  #6 (permalink)  
Old 13 Mar 2004, 10:16 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

So it was the old "loose gas cap" problem???[:I]
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 14 Mar 2004, 05:15 am
Dedicated Cruiser
 
Join Date: Oct 2003
Location: Jacksonville, NC, USA.
Posts: 2,612
Default

Quote:
quote:Originally posted by quicksilverdon

So it was the old "loose gas cap" problem???[:I]
Not sure. I undid the gas cap and re-installed it, then I disconnected the battery negative cable for about 40 min. When battery cable was re-installed the 0456 code was gone but still had the 1684. When out and checked it a couple of hours later and received no codes.
__________________

2002 Inferno Red PT Limited
Photos and more at: http://www.randgraphics.org/PT_Cruiser/demos/index.htm
Mercedes Wiki
Reply With Quote
  #8 (permalink)  
Old 06 Jun 2004, 04:40 pm
Fresh Cruiser
 
Join Date: Jun 2004
Location: Shawnee Mission, KS, USA.
Posts: 1
Default

I am getting error code P0601 and P1684 on my 2001 PT Cruser....does anyone know what those codes mean....or can anyone refer me to a listing of codes? My engine light is on; taking car to dealer tomorrow. Thanks, Kay
Reply With Quote
  #9 (permalink)  
Old 16 Jun 2004, 11:28 pm
Fresh Cruiser
 
Join Date: Jun 2004
Location: Caribou, ME, USA.
Posts: 1
Send a message via AIM to cavynmaicl
Default

[:I] Ok, I have the engine light on, but no codes... I've run the diagnostic a few times, and gotten no codes, everything seems to be fine, but the engine light stays on... any thoughts? I'm at a loss...
Reply With Quote
  #10 (permalink)  
Old 26 Jun 2004, 10:42 pm
Fresh Cruiser
 
Join Date: Jun 2004
Location: .
Posts: 1
Default

Hi, Have a 2001 with engine light on and no codes. Transmission stays in 2nd gear. Any ideas....


Regards, Rich
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Check Engine" idiot light on AGAIN tezz General Turbo Discussions 17 17 Sep 2015 11:54 am
Check Engine Light CHROMEDCRUISER General PT Cruiser Discussions 13 30 Apr 2012 04:49 pm
Faulty Check engine light? Mel K General Turbo Discussions 5 23 Mar 2007 10:06 am
Check engine oil light question AaronR General PT Cruiser Discussions 5 28 Aug 2004 03:18 am
Clearing check engine light Blade Tech & Performance Forum 10 27 Mar 2004 01:48 am


All times are GMT -5. The time now is 05:00 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors