PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
P0340 error

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Jun 2013, 09:46 pm
Fresh Cruiser
 
Join Date: Jun 2013
Posts: 2
Default P0340 error

I just joined this site tonight, though I have been here many times for help. Let me say that this is a GREAT site! And has been very helpful.

I know that this code has been beat to death and I have read and recieved a lot of good info on this subject. How to change, what to look for etc.

My question is though, can something else cause this code other than a bad sensor, magnet, wiring, etc.
I mean something like an injector, coil, spark plug, etc.?

My car is idling rough, though it normally will accelerate OK. It sometimes bucks and acts like it is misfiring when accererating. I let off the gas and then it will seem to accelerate OK again.

I just completed a timing belt, water pump, new radiator, crank sensor. (What a production!)
I took it out for a test ride and all seemed well. Started the car this am, check engine light came on and that's where I am.
Hopefully, just a bad cam sensor.

Thanks for the help.
Reply With Quote
  #2 (permalink)  
Old 28 Jun 2013, 10:15 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,880
Default Re: P0340 error

Did you have this problem before the belt?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 29 Jun 2013, 01:57 am
Fresh Cruiser
 
Join Date: Jun 2013
Posts: 2
Default Re: P0340 error

No, I just did the belt for maintainance.
It had thrown a crankshaft sensor code but was running OK.
Reply With Quote
  #4 (permalink)  
Old 29 Jun 2013, 06:44 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: P0340 error

Idling rough after the timing belt change usually always means that the timing is off. It's one of the hardest parts of the belt change and many have come to the forum both after a home maintenance job or even after professional have changed it and said the idle is rough and wasn't that way before the change.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0340 error code and wont start. jdwalk04 Tech & Performance Forum 0 27 Apr 2012 11:23 am
Error Code p0340 fallynangel Tech & Performance Forum 7 10 Dec 2011 09:03 pm
error codes p0340 and p1299 nithawk2000 Tech & Performance Forum 3 29 Apr 2011 10:02 pm
2005 PT Cruiser GT is getting a P0340 error. silverwolf22 General PT Cruiser Discussions 1 20 Jun 2010 05:03 pm
Error code P0340 ADVICE??? mjb457 Tech & Performance Forum 10 20 Aug 2009 09:24 pm


All times are GMT -5. The time now is 06:05 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors