PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Need help with engine

 
Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Jun 2013, 06:24 pm
Fresh Cruiser
 
Join Date: Jun 2013
Location: SW FLA
Posts: 12
Default Need help with engine

My daughters car had a blown head gasket. I replaced the upper end gaskets, i also replaced the timing belt, waterpump, while it was apart. I tripled checked camshaft, crank timing marks, and reassembled it. Everything reinstalled this is what is taking place now.
When cold engine starts up, idles great. When temp gets to say 180-190 degrees starts to run rough and will not idle. Then it becomes hard to start. After it cools down it will start up. OBD2 reader showes no codes at all. The radiator fan motor was bad i also replaced it. At what temp should the fan kick on without the AC on?? I have new gas, good rail pressure i was able to test for that.The only other item im not sure about is a sensor that located on the firewall side of the engine, lower passanger side. The engine is acting like i have an intermitting sensor issue. But if that was the case shouldnt i get a dt code? Last question i have is it the crank or cam sensor that tells the pcm top dead center for #1 cylinder?
Reply With Quote
  #2 (permalink)  
Old 29 Jun 2013, 06:36 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Lightbulb Re: Need help with engine

Did you check/or replace the Engine Coolant Temperature Sensor ???LINK: Replacing the coolant temp sensor
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #3 (permalink)  
Old 29 Jun 2013, 06:46 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Need help with engine

Welcome to the forum.

Cam sensor usually senses the position of the timing belt or timing chain gear and tells the computer when #1 cylinder is at top dead center. In other words, when #1 cylinder comes up. Crank sensor tells the computer when to fire the spark plugs in the rest of the cylinders. In other words, as the crank shaft goes around it tells the computer when each piston comes up so it can fire it's spark plug.

Without the A/C on or the knob in the defrost position, the low speed fan should come on about the time the temperature gauge gets to half way. Sorry, can't find the exact temperature but I'm sure someone has it written down.

Just as it starts to run rough, can you turn the A/C on and tell if the fan comes on?

The sensor I THINK your talking about that you don't know what it is, might be the Crankshaft sensor. Should be just above the oil filter IF you have a 2001-2003 cruiser. That sensor was moved to behind the starter in 2004.
mityqwik and Repairdad like this.
Reply With Quote
  #4 (permalink)  
Old 29 Jun 2013, 07:05 pm
Fresh Cruiser
 
Join Date: Jun 2013
Location: SW FLA
Posts: 12
Default Re: Need help with engine

The OBD2 showes the temp increasing as the engine runs, so by that i would assume the sensor is functioning. So no i did not replace the water temp sensor yet. Thanks for the info on the camshaft sensor. Also i havent reconnected the AC as of yet so no its not being used for this round of troubleshooting.
Reply With Quote
  #5 (permalink)  
Old 29 Jun 2013, 07:06 pm
Fresh Cruiser
 
Join Date: Jun 2013
Location: SW FLA
Posts: 12
Default Re: Need help with engine

I will pick up a new cam sensor and install it.. Then i will let you know if it worked..
Reply With Quote
  #6 (permalink)  
Old 29 Jun 2013, 09:34 pm
mityqwik's Avatar
Senior Cruiser
 
Join Date: Sep 2010
Location: Hampton roads Va.
Posts: 1,966
Thumbs up Re: Need help with engine

welcome to the forum and from virginia
__________________
It takes 8,460 bolts to assemble an automobile,
and one nut to scatter it all over the road
Reply With Quote
  #7 (permalink)  
Old 30 Jun 2013, 09:39 am
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: Need help with engine

Welcome,

If it was idling before head gasket change, it's something that occurred during that procedure-

I know you don't want to hear this, but I'd guess timing is off- EVERYBODY messes it up- Really hard to get a 'line' of sight on timing marks in the chassis
Reply With Quote
  #8 (permalink)  
Old 30 Jun 2013, 01:14 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,880
Default Re: Need help with engine





Picture of the marks when they are right. You can check the marks with only the top cover off. Run the piston to top dead center. A clean screw driver with some hash marks on it will show you exactly when it is at the top. And the marks should look just like the cams on here.
Repairdad likes this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #9 (permalink)  
Old 30 Jun 2013, 03:31 pm
Fresh Cruiser
 
Join Date: Jun 2013
Location: SW FLA
Posts: 12
Default Re: Need help with engine

At first couple of attemps to set the timing using the shop service manuals. I went by sight which didnt work out. Trying to set the exhaust cam gear notch 1/2 notch above the intake cam gear notch was tough. The way i finally got it correct was to cut a peace of wood to span across both cam gears. Using it as the streight edge i centered it on both cam gear mounting bolts to create what i thought was the center line to use to determine the 1/2 notch offset between the 2 cam gear marks.. Also my cam gears have the wording stamped into them "front" and "up" . On both of the cam gears, there are 2 cam marks on each gear at 180 degrees apart. Did i use the wrong centerline method, or is there marks on the block, rear timimg cover to use for the correct why to determine centerline? Pleas any in put would be greatful. Daughter is leaving to go to school out of town need to get this runing. Thanks for your input.
Reply With Quote
  #10 (permalink)  
Old 30 Jun 2013, 03:48 pm
Fresh Cruiser
 
Join Date: Jun 2013
Location: SW FLA
Posts: 12
Default Re: Need help with engine

Thank you for the picture i did the same thing except i set the exhaust cam 1/2 notch above the intake cam. Thats what the manuel said to do. And it dosent work. I have nothing to loose to set both cam mark inline with each other. I will try that and see if it works better.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Engine misfire and flashing check engine light fg1911a1 General Turbo Discussions 15 26 Jul 2014 06:20 pm
Converting 2002 engine to a 2003 engine - ECU RomanSouthAfrica Tech & Performance Forum 2 08 Apr 2013 04:33 pm
Can I swap a 2001 w/egr engine for a 2002 engine w/o egr? cas0918 General PT Cruiser Discussions 5 15 Feb 2013 11:58 pm
Pt Crusier engine change with a neon engine? reepos1 Tech & Performance Forum 2 09 Nov 2010 11:21 pm
Can 2001 Engine be replaced with Newer Engine harleysforfun General PT Cruiser Discussions 1 07 Aug 2009 01:38 pm


All times are GMT -5. The time now is 04:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors