PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
PO344 HELP!!!!!!

 
Like Tree9Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Jul 2013, 06:33 pm
Koch's Avatar
Cool Cruiser
 
Join Date: Feb 2012
Location: Salyersville, ky
Posts: 213
Question PO344 HELP!!!!!!

I have a 2004 non turbo and about 2 weeks ago i started getting the PO344 code and the car would go in2 limp mode, The first thing I done was go to NAPA and changed the Cam sensor.. the car was okay for a few hours then the problem hit again, so i tried 3 other aftermarket sensors and still the same problem. So after doing some research on here I decided to order both a new cam and crank sensor Mopar brand, got them in today and the car was doing great I knew the problem was fixed but its not I'm still getting the same code! what do I need to do???? I talked to a local shop and the master tech there told me to check the wiring harness splices and he printed me a diagram of the cam harness, Also talked to someone and they mentioned it could be the computer. so my question is what years of computers will interchange with my car, does it have to be reprogrammed by dodge? And also does anyone else have any ideas of what i need to check, replace ect.


P.S. I drove the car about 20 miles today and let the car idle for an hour before the code was set again and once it did it came on back to back 4 times as soon as i started the engine then the last time i cleared the code i drove 10 miles home and the CEL was still off.... I hate problems like this!!!! :S
__________________
PO344 O' how I hate you!
-2004 Chrysler PT Cruiser Limited- Inferno Red
Reply With Quote
  #2 (permalink)  
Old 06 Jul 2013, 06:42 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: PO344 HELP!!!!!!

OK, first, did you check the wiring harness from the Camshaft sensor all the way round the back of the engine for any ripped/worn parts that would interfere with the wiring. You didn't say you did. A couple of us (including me) had problems around back of the engine with the harness worn through to the bare wires.

Second. Get yourself a new Camshaft magnet that's located inside the hole where the sensor goes. Many owners found that even though it looked good, replacing the magnet cured their problems.


Last edited by CREWZIN; 06 Jul 2013 at 06:44 pm.
Reply With Quote
  #3 (permalink)  
Old 06 Jul 2013, 06:56 pm
Koch's Avatar
Cool Cruiser
 
Join Date: Feb 2012
Location: Salyersville, ky
Posts: 213
Default Re: PO344 HELP!!!!!!

Quote:
Originally Posted by CREWZIN View Post
OK, first, did you check the wiring harness from the Camshaft sensor all the way round the back of the engine for any ripped/worn parts that would interfere with the wiring. You didn't say you did. A couple of us (including me) had problems around back of the engine with the harness worn through to the bare wires.

Second. Get yourself a new Camshaft magnet that's located inside the hole where the sensor goes. Many owners found that even though it looked good, replacing the magnet cured their problems
I checked the wires the best i could, tomorrow I'm going to spend some time and check the harness better, I also already changed the plug itself, Do you happen to know the OEM number for the Magnet? Also the car has 147k miles and I've never changed the timing belt could that have anything to do with this type of problem?
__________________
PO344 O' how I hate you!
-2004 Chrysler PT Cruiser Limited- Inferno Red
Reply With Quote
  #4 (permalink)  
Old 06 Jul 2013, 07:06 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: PO344 HELP!!!!!!

Wow, 147K and the same timing belt! Your living on borrowed time and YES, the belt is probably stretched and the timing is off causing the cam and crank sensor to send a signal that's it's off timed. Why on earth would you wait this long to change the belt? It is expensive (around $1000) if the dealer or private mechanic does the change but if you plan on keep the car, have it changed. Also change the water pump and belt tensioner while doing the belt.
Reply With Quote
  #5 (permalink)  
Old 06 Jul 2013, 07:15 pm
Koch's Avatar
Cool Cruiser
 
Join Date: Feb 2012
Location: Salyersville, ky
Posts: 213
Default Re: PO344 HELP!!!!!!

Quote:
Originally Posted by CREWZIN View Post
Wow, 147K and the same timing belt! Your living on borrowed time and YES, the belt is probably stretched and the timing is off causing the cam and crank sensor to send a signal that's it's off timed. Why on earth would you wait this long to change the belt? It is expensive (around $1000) if the dealer or private mechanic does the change but if you plan on keep the car, have it changed. Also change the water pump and belt tensioner while doing the belt.
To be honest bought the car for temporary use with plans on getting a bigger car by now but financial problems has kept me from moving on, the car had a water pump changed at 60k according to Chysler.com owners service and since I only paid $2,500 for the car it would be hard for be to put $1k more in it, the car also had 124k when i bought it so not 100% sure of the total history of the car.
__________________
PO344 O' how I hate you!
-2004 Chrysler PT Cruiser Limited- Inferno Red
Reply With Quote
  #6 (permalink)  
Old 06 Jul 2013, 07:29 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: PO344 HELP!!!!!!

Whoever changed the pump should have did the belt at the same time, might as well since the belt has to come off to get to the pump.

Maybe they did change it so that would put you at about 87K so go ahead and check out the harness really well and change the magnet. Not sure of the number but you probably have to get it at the dealer so they can look it up.
Reply With Quote
  #7 (permalink)  
Old 06 Jul 2013, 07:42 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,880
Default Re: PO344 HELP!!!!!!

Quote:
Originally Posted by Koch View Post
To be honest bought the car for temporary use with plans on getting a bigger car by now but financial problems has kept me from moving on, the car had a water pump changed at 60k according to Chysler.com owners service and since I only paid $2,500 for the car it would be hard for be to put $1k more in it, the car also had 124k when i bought it so not 100% sure of the total history of the car.
Pop the top cover off,three screws. Look for signs of lettering. A belt that old will look well worn on the back side. I you get lucky and see writing its differently been changed. May need to turn it over to see the whole belt. Yes the computer has to be programmed to your vin. Ebay is the best deal on those. Did on on a 03 5sp. n/a for $169. exchange free ship both ways. Auto parts $300 +.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #8 (permalink)  
Old 06 Jul 2013, 07:44 pm
Koch's Avatar
Cool Cruiser
 
Join Date: Feb 2012
Location: Salyersville, ky
Posts: 213
Default Re: PO344 HELP!!!!!!

Quote:
Originally Posted by Busted_PT View Post
Pop the top cover off,three screws. Look for signs of lettering. A belt that old will look well worn on the back side. I you get lucky and see writing its differently been changed. May need to turn it over to see the whole belt. Yes the computer has to be programmed to your vin. Ebay is the best deal on those. Did on on a 03 5sp. n/a for $169. exchange free ship both ways. Auto parts $300 +.
I think I can get a PCM for free, just have to have it programmed can a dealer do it without it installed on the car?
__________________
PO344 O' how I hate you!
-2004 Chrysler PT Cruiser Limited- Inferno Red
Reply With Quote
  #9 (permalink)  
Old 06 Jul 2013, 07:46 pm
Koch's Avatar
Cool Cruiser
 
Join Date: Feb 2012
Location: Salyersville, ky
Posts: 213
Default Re: PO344 HELP!!!!!!

Quote:
Originally Posted by CREWZIN View Post
Whoever changed the pump should have did the belt at the same time, might as well since the belt has to come off to get to the pump.

Maybe they did change it so that would put you at about 87K so go ahead and check out the harness really well and change the magnet. Not sure of the number but you probably have to get it at the dealer so they can look it up.
Found the OEM number its 05293199AA, also it was a dodge dealer in northern KY that changed the pump but when i called them to ask if they had changed the belt at the time they told me that was private information... so I'm going to follow busted's lead and take the inspection cover off in the morning and check the belt for writing...
__________________
PO344 O' how I hate you!
-2004 Chrysler PT Cruiser Limited- Inferno Red
Reply With Quote
  #10 (permalink)  
Old 06 Jul 2013, 07:48 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,880
Default Re: PO344 HELP!!!!!!

Quote:
Originally Posted by Koch View Post
I think I can get a PCM for free, just have to have it programmed can a dealer do it without it installed on the car?
No, and they will not program a used one. One from a auto parts has to be ordered with you vin. programmed into it.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 pt cruiser po344 ty1981 Tech & Performance Forum 1 05 Mar 2010 09:18 pm
Code PO344 at 2500 top rpm pspears Tech & Performance Forum 0 25 Oct 2009 05:01 pm


All times are GMT -5. The time now is 10:51 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors