PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Cruise control stopped working

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Jul 2013, 04:08 pm
Fresh Cruiser
 
Join Date: Jul 2013
Posts: 1
Default Cruise control stopped working


Hi can any one please help I recently purchase a mk1 2000 pt cruiser with faulty cruise control any suggestions
I press the lever to turn it on but there is nothing
Thanks
Reply With Quote
  #2 (permalink)  
Old 14 Jul 2013, 05:01 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Cruise control stopped working

You say it "stopped working" but in your statement you said you purchased the "MK1 2000 PT" (whatever the heck that is) with faulty CC. So, it was working for the previous owner but quit working and you bought it that way?

What did the previous owner try and do to fix it? Did he check for a bad vacuum? Did he check for a blown fuse? Does the "cruise" light come on in the dash but it doesn't engage?

What have you done to try and fix it? Are all the parts needed to have CC there and in working order?

Your question is rather vague without further explanation.

P.S. Please explain what a MK1 2000 PT is and why is it different from a normal PT?
Reply With Quote
  #3 (permalink)  
Old 03 Aug 2013, 12:02 pm
ejstith's Avatar
Regular Cruiser
 
Join Date: Aug 2009
Location: Tallahassee, FL
Posts: 102
Default Re: Cruise control stopped working

Hey, Crewzin, where is the cruise control fuse. I couldn't' find it in the manual. Mine quit working too. When l push in the button the cruise just flashes & goes out. This just started, it always worked fine. Thanks.
__________________
2005 PT, Limited turbo Lite. Automatic all whistles and bells.
Reply With Quote
  #4 (permalink)  
Old 03 Aug 2013, 12:13 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Cruise control stopped working

There are so many things that control the CC it's hard to tell you where to start. The PCM (Computer), Clockspring (in the steering wheel) Vehicle Speed Control Switch, Speed Control Servo, brake lamp switch, Clutch Pedal Position Switch (in the manual) and Transmission Range Sensor (in the automatic) and last but not least the TCM (Transmission Control Module).

Last edited by CREWZIN; 23 Jan 2016 at 03:48 pm.
Reply With Quote
  #5 (permalink)  
Old 03 Aug 2013, 01:34 pm
Garya1682's Avatar
Young Cruiser
 
Join Date: Apr 2013
Location: LONDON BABY
Posts: 79
Send a message via Skype™ to Garya1682
Default Re: Cruise control stopped working

Quote:
Originally Posted by CREWZIN View Post
The cruiser control fuse in the 00-05 cruiser is the #10 fuse in the interior fuse box.

There are so many things that control the CC it's hard to tell you where to start. The PCM (Computer), Clockspring (in the steering wheel) Vehicle Speed Control Switch, Speed Control Servo, brake lamp switch, Clutch Pedal Position Switch (in the manual) and Transmission Range Sensor (in the automatic) and last but not least the TCM (Transmission Control Module).
when I faced this issue it was the speed control servo and I changed the fuse for the sake of it and It solved the issue for. my cc light was coming on but it didn't do the job
__________________

2002 cruiser
2.0L PETROL AUTO
80k miles
Reply With Quote
  #6 (permalink)  
Old 05 Aug 2013, 04:02 pm
ejstith's Avatar
Regular Cruiser
 
Join Date: Aug 2009
Location: Tallahassee, FL
Posts: 102
Default Re: Cruise control stopped working

Well I finished my trip without a cruise control & when I got home I checked the fuse & it was OK. I started checking around the servo & found the plug was disconnected. I just had the timing belt replaced & they failed to plug it back in. Plugged it in & all is well.....
__________________
2005 PT, Limited turbo Lite. Automatic all whistles and bells.
Reply With Quote
  #7 (permalink)  
Old 05 Aug 2013, 04:06 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Thumbs up Re: Cruise control stopped working

Sometimes the obvious solution,is also the simplest...
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #8 (permalink)  
Old 01 Apr 2014, 08:59 pm
Fresh Cruiser
 
Join Date: Jun 2008
Location: Acworth, GA
Posts: 5
Default Re: Cruise control stopped working

Hi! I just had my timing belt replaced and my cruise control isn't working.

Where is the servo and the plug you're talking about as I'd like to check that>

Thanks for your help!

Quote:
Originally Posted by ejstith View Post
Well I finished my trip without a cruise control & when I got home I checked the fuse & it was OK. I started checking around the servo & found the plug was disconnected. I just had the timing belt replaced & they failed to plug it back in. Plugged it in & all is well.....
Reply With Quote
  #9 (permalink)  
Old 01 Apr 2014, 09:26 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Cruise control stopped working

isnt there also a vacume line that is really little and easy to break(thats what happened to mine when they changed the TB
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solution for Cruise Control not working on 2006 PT Cruiser Touring Edition refbillyj General PT Cruiser Discussions 14 03 Apr 2015 04:17 pm
Installed factory cruise control but not working gitrdun Interior Accessories Forum 11 07 Jul 2013 10:14 pm
One more try... Cruise control not working... Jered General PT Cruiser Discussions 9 27 Jan 2009 03:04 pm
cruise control not working oldone Tech & Performance Forum 1 14 Oct 2007 09:50 am
Cruise Control not working glfnjim Tech & Performance Forum 14 27 Nov 2005 01:45 am


All times are GMT -5. The time now is 03:03 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors