PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Code P0340 ??????

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Jul 2013, 06:29 am
Young Cruiser
 
Join Date: Sep 2012
Posts: 78
Default Code P0340 ??????

Hey guys, been having some issues with my 02 pt. I posted on here a few days ago about the car not starting and giving some codes. The car starts now, but it takes about 20 seconds of cranking in order to do so. Once started the car runs great. Lots of power and smooth riding. The engine light does come on, and gives the only code of P0340, which from my research is saying a cam sensor or wire connector. I've replaced both the wire and sensor. I've actually replaced the sensor with 3 others that I had laying around. Two being OEM, the other a new aftermarket. I replaced the connector wire because the clamp at the end wasn't locking. I'm kinda lost now on where to turn to next. I was wondering if maybe the magnet on the camshaft is bad, or maybe the wires further back have a short. Like I said, runs great, but cranks for way to long before starting. Any ideas on this?
Reply With Quote
  #2 (permalink)  
Old 17 Jul 2013, 06:50 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Code P0340 ??????

Sounds like you did everything right. Replacing the magnet inside the camshaft sensor help others, might as well try that.
Reply With Quote
  #3 (permalink)  
Old 17 Jul 2013, 08:29 am
Young Cruiser
 
Join Date: Sep 2012
Posts: 78
Default Re: Code P0340 ??????

Hey thanks for the reply. Where is the best place to pick one up? Dealer or maybe Oreilys? Also, what exactly do I call it when I order it?
Reply With Quote
  #4 (permalink)  
Old 17 Jul 2013, 12:18 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Code P0340 ??????

I think it's a dealer only part. It's called a Target Magnet .....according to Haynes.

Reply With Quote
  #5 (permalink)  
Old 18 Jul 2013, 12:44 pm
Young Cruiser
 
Join Date: Sep 2012
Posts: 78
Default Re: Code P0340 ??????

Ok,, back to "Square One"... I replaced the target magnet, brand new one from the dealer. The cam sensor and connector has been replaced also. Still cranks for about 20 seconds before starting, then the check engine light comes on. The code is still P0340. Still runs great, just hard to start. Anymore ideas,,, I'm out....
Reply With Quote
  #6 (permalink)  
Old 18 Jul 2013, 01:28 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: Code P0340 ??????

try turning the key to the run position and leave it there for about 10 seconds. then see if it'll start. i'm thinking the fuel pump isn't getting the gas to the injectors quick enough. when in the run position, you should hear the fuel pump kick in.

just a thought.
jondickson likes this.
__________________
2005 Toyota Camry LE Salsa Red (Wife's)
2002 Automatic N/A (Mine) Inferno Red
2016 Kia Soul Plus Black
Reply With Quote
  #7 (permalink)  
Old 18 Jul 2013, 01:33 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Code P0340 ??????

You might also want to check the fuel pressure with the schroeder valve located just under the upper manifold. Pressure should read between 53 and 63 psi.


Last edited by CREWZIN; 18 Jul 2013 at 01:39 pm.
Reply With Quote
  #8 (permalink)  
Old 18 Jul 2013, 03:34 pm
Young Cruiser
 
Join Date: Sep 2012
Posts: 78
Default Re: Code P0340 ??????

Ok, just checked it,,,, shes holding steady at about 55 psi. Any other ideas about my problem? I'm stumped.
Reply With Quote
  #9 (permalink)  
Old 18 Jul 2013, 03:39 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Code P0340 ??????

Well, you arn't the only one....

hard to start
Reply With Quote
  #10 (permalink)  
Old 18 Jul 2013, 03:42 pm
Young Cruiser
 
Join Date: Sep 2012
Posts: 78
Default Re: Code P0340 ??????

I'm getting ready to tear into some wiring, as bad as I hate to. They look good for the most part on the outside, but I don't know what else to do. Do you think if there was a wire touching it would give this code and act like it is? I would think that if they were touching then I wouldn't even start. But I don't know where else to go with this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
02 pt with p0340 code webstertroy General PT Cruiser Discussions 11 19 Jan 2013 09:26 pm
Code P0340 flcruiser General PT Cruiser Discussions 1 24 Aug 2012 07:08 pm
P0340 code Travis2k7 Tech & Performance Forum 18 10 Jul 2012 09:40 pm
P0340 Code. BlackJack Tech & Performance Forum 10 01 Mar 2010 09:26 pm
code p0340 sflamedic General PT Cruiser Discussions 5 21 Oct 2008 06:12 am


All times are GMT -5. The time now is 04:46 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors