PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
I think I'm limp?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Sep 2013, 07:56 am
Fresh Cruiser
 
Join Date: Aug 2013
Posts: 5
Default I think I'm limp?

New to the scene here (already did the intro post ) I have been doing several searches on a collection of issues (or at least what I would call issues) with the PT Crusier I bought for my daughter. One big one... After we bought it where it would simply loose all power and just shut down. We took it to a few different spots even the local dealer and got mixed answers.

After getting the run around, I finally found someone who suggested the issues were related to the ECU going bad. We ended up replacing the ECU with a used one. It was re-programmed and the stalling has stopped and overall seems to be responding ok

However, now among the shop saying new motor mounts, and lower control arm the car seems to show symptoms of this "limp" mode I am reading about. I am new to American cars but I have never heard of this. But the symptom is this, when in park, I rev the engine and around 3000 rpm, it begins to drop then go back up. Not that I am trying to blow the engine but in all cars I have had, you rev the engine, it goes until you take your foot off or you blow the engine.

I get a similar feel when I take the car above the 70 mile an hour point. It gives a hesitation which almost feel like it will stall but then when you get the rpms down or it shifts gears it runs normal again. I did the code check and its throwing no codes. Someone also suggested it could be a PCV valve issue or hose.

Is this normal? What items should I be looking at first?

The issue is pretty inconsistent. I am getting the oil changed today along with transmission flush just because I am not sure of when the last ones were done but I am worried that I may be looking at several more trips or late nights in the garage fixing this thing.

I am also not sure of well this was taken care of based on what I see in the CarFax. Outside of a few small trips for what are probably oil changes, I see no regularly scheduled maintenance records. So either the prevous owner did there own, I need to know play some catch up on a few items.

My daugter is about 3 hours away at school so I need to know this car is solid before I let her take it down there. The car itself isn't in bad shape overall. The engine bay is pretty clean, some rust spots on the wheel wells but overall good looking ride. Interior is clean for an older car but I have to know it wont break on the side of the road.
Reply With Quote
  #2 (permalink)  
Old 03 Sep 2013, 08:18 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: I think I'm limp?

The engine computer prevents revving while in neutral.
On the road the hesitation may be caused by spark plugs/wires.
Plugs - the stock Champions are okay - gap at 0.040 - and replace the wires at the same time - the stock wires do not last - the best I've found are Crane firewires.
Even if the plugs/wires don't cure your hesitation, it can't hurt - look in the tech forum, there's a how-to on changing the plugs.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 03 Sep 2013, 11:34 am
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Wink Re: I think I'm limp?

Quote:
Originally Posted by xternal View Post
I am new to American cars
In my own personal opinion,PT Cruisers aren't technically an 'American Car'.....Because they are built in Tolouca,Mexico by citizens of Mexico....And Chrysler is a consolidated subsidiary of Italian multinational automaker Fiat,at the time PT Cruisers were being made,Chrysler was owned by German automaker Daimler-Benz....Which they made vehicles under the corporate name 'DaimlerChrysler'.........With that info in mind;What do you think?LOL
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #4 (permalink)  
Old 03 Sep 2013, 11:48 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: I think I'm limp?

Most cars have rev limiter to prevent that reving till it blows. The hesitation, I would check the above suggested maintenance and see what you have.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #5 (permalink)  
Old 03 Sep 2013, 01:20 pm
Fresh Cruiser
 
Join Date: Aug 2013
Posts: 5
Default Re: I think I'm limp?

Quote:
In my own personal opinion,PT Cruisers aren't technically an 'American Car'.....Because they are built in Tolouca,Mexico by citizens of Mexico....And Chrysler is a consolidated subsidiary of Italian multinational automaker Fiat,at the time PT Cruisers were being made,Chrysler was owned by German automaker Daimler-Benz....Which they made vehicles under the corporate name 'DaimlerChrysler'.........With that info in mind;What do you think?LOL
nice, but still doesnt count.

The plugs and wires were already replaced a few months back but I suppose I could take a quick look at that. I did not do these myself so I am not sure of the type.
Reply With Quote
  #6 (permalink)  
Old 04 Sep 2013, 03:46 am
Fanatic Cruiser
 
Join Date: Jun 2009
Location: Rochester, Michigan
Posts: 669
Default Re: I think I'm limp?

What year PT? How many miles?

btw...you are not in "limp mode"...(vehicle remains in second gear only).
Reply With Quote
  #7 (permalink)  
Old 04 Sep 2013, 07:02 am
Banned
 
Join Date: May 2011
Location: Dallas Texas
Posts: 3,722
Exclamation Re: I think I'm limp?

Having a daughter in college and having
A car Not being able to go above 70 mph.

Most parents would be quite pleased to be in your shoes!
Reply With Quote
  #8 (permalink)  
Old 07 Sep 2013, 07:18 am
Fresh Cruiser
 
Join Date: Aug 2013
Posts: 5
Default Re: I think I'm limp?

2004 with 130k..if it were just that it wouldn't over 70 then your right I'm probably ok with that. Just afraid it will simply die out. Have replaced wires and plugs so hopefully this will solve it for now. Next up is motor mounts which from the posts I have found looks easy enough. After that I think she needs to get this car out f my driveway before I do more things to it
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp Mode? Bentron General PT Cruiser Discussions 23 21 Jun 2016 10:54 am
stuck in limp mode galahad General PT Cruiser Discussions 3 13 Feb 2013 07:44 am
Air bag deployment and limp mode Hvymtl Tech & Performance Forum 1 25 Aug 2011 03:36 pm
help..limp mode ivynthemnts758 Tech & Performance Forum 2 09 Sep 2010 08:44 am
01 cruiser in limp mode mui5m General PT Cruiser Discussions 1 04 Dec 2009 02:19 pm


All times are GMT -5. The time now is 11:38 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors