PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2002 PT wouldn't start, lost all power

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Jan 2014, 12:41 am
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 3
Unhappy 2002 PT wouldn't start, lost all power

Hi All,
My wife's 2002 PT Limited Edition was running fine just yesterday, but today when she tried starting it after sitting all night and day, all that happened was a loud click (not too loud though, kinda normal first thing you hear when starting) and suddenly, all power was gone. Prior to that, power locks, cabin light, etc worked normally, but as soon as the key was turned, it went completely dead. I am at a loss as to what this can be, it doesn't feel like a normal dead battery, besides, the battery in this car is only a month old.
Another detail, not sure how important, is this car just had its radiator fan and head gasket replaced as a result of overheating (due to the fan going bad). Again, it was running just fine for a few days after those repairs, and then this... great car, but I am beginning to feel it might be cursed Any suggestions greatly appreciated, thank you!
Reply With Quote
  #2 (permalink)  
Old 05 Jan 2014, 12:49 am
Fresh Cruiser
 
Join Date: Dec 2013
Location: Pensacola Florida
Posts: 47
Default Re: 2002 PT wouldn't start, lost all power

check both battery cables on both ends. sounds like a bad connection.
Reply With Quote
  #3 (permalink)  
Old 05 Jan 2014, 07:50 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2002 PT wouldn't start, lost all power

Welcome to the forum.
Agree with snapper. Check all the ends of every cable (negative and positive) for corrosion. Also, if you have a decent auto store, they will check the battery and charging system for free. Even some new batteries can be defective with a bad cell.
Reply With Quote
  #4 (permalink)  
Old 05 Jan 2014, 04:14 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: 2002 PT wouldn't start, lost all power

I wouldn't rule out the ignition cylinder.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 05 Jan 2014, 05:32 pm
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 3
Default Re: 2002 PT wouldn't start, lost all power

Thanks guys, you were spot on - apparently whoever worked on it last didn't tighten the negative terminal. The car is back running and my trust in it is restored! Really appreciate all the help!
Reply With Quote
  #6 (permalink)  
Old 05 Jan 2014, 05:44 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Thumbs up Re: 2002 PT wouldn't start, lost all power

Quote:
Originally Posted by Mike_N View Post
Thanks guys, you were spot on - apparently whoever worked on it last didn't tighten the negative terminal. The car is back running and my trust in it is restored! Really appreciate all the help!
And a shop would have charged almost $100,and that's if you didn't need a tow!....Glad you got it corrected.
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #7 (permalink)  
Old 05 Jan 2014, 06:01 pm
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 3
Default Re: 2002 PT wouldn't start, lost all power

Quote:
Originally Posted by randyincctx View Post
And a shop would have charged almost $100,and that's if you didn't need a tow!....Glad you got it corrected.
Amen to that! (Although I've been using mobile mechanics from CraigsList ever since the shop wanted 2k for that gasket Come to think of it, that's probably why the terminal wasn't tightened lol )
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Wouldn't start tcham Tech & Performance Forum 0 01 Jun 2013 04:29 pm
My Pt Died :( Engine shut off and lost all electrical power CruzrMama Tech & Performance Forum 9 08 Aug 2011 10:14 pm
my car lost all power PTCRZ666 Tech & Performance Forum 4 10 Jun 2010 07:16 pm
The PT that wouldn't die !! Boglesnurf General PT Cruiser Discussions 0 08 Sep 2008 07:05 pm
electrical power lost !!!!! roadkill636 Tech & Performance Forum 8 30 Jul 2008 09:16 pm


All times are GMT -5. The time now is 10:41 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors