PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2005 Bad Alternator???

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Jan 2014, 02:31 pm
Fresh Cruiser
 
Join Date: Jul 2013
Location: La Porte, Texas
Posts: 9
Default 2005 Bad Alternator???

I battery warning light was coming on and off before my car would not start. I replaced the battery and drove it home as the battery light came on again. I fully charged the battery, started the car then removed the negative battery cable and the engine stalled and quit. Re-attached negative cable and re-started engine. Bad alternator or is there another component I should consider? Thanks for your replies.
Reply With Quote
  #2 (permalink)  
Old 16 Jan 2014, 02:46 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,045
Default Re: 2005 Bad Alternator???

Quote:
Originally Posted by SuzaMan View Post
I battery warning light was coming on and off before my car would not start. I replaced the battery and drove it home as the battery light came on again. I fully charged the battery, started the car then removed the negative battery cable and the engine stalled and quit. Re-attached negative cable and re-started engine. Bad alternator or is there another component I should consider? Thanks for your replies.
Sounds like the alternator. But I wouldn't run the old-school battery test like that. On some cars, that can kill the ECM.

The definitive way to know is to have someone check the charging system with a volt meter. With the car off, it should show about 12.5 volts across the battery terminals. And when started, it should be about 13.5 to 14 volts. If it doesn't show this when started, then the alternator is not charging. I believe they can run a test for you for free at NAPA with their battery/changing-system tester. Autozone may be able to do this too.
garkeller likes this.
__________________
Reply With Quote
  #3 (permalink)  
Old 16 Jan 2014, 03:11 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,880
Default Re: 2005 Bad Alternator???

That test doesn't work on our PT's . So you have to go get tested if you don't know how.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 16 Jan 2014, 03:29 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: 2005 Bad Alternator???

Quote:
Originally Posted by Busted_PT View Post
That test doesn't work on our PT's .
yea i have the only known PT in the universe that will continue to run with the battery disconnected

Reply With Quote
  #5 (permalink)  
Old 16 Jan 2014, 07:49 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,045
Default Re: 2005 Bad Alternator???

Quote:
Originally Posted by rob342 View Post
yea i have the only known PT in the universe that will continue to run with the battery disconnected

I believe others on this forum has reported that at least the 1st Gen PT's will run with no battery in them. Possibly the 2nd Gen's too. The problem is the possibility of damaging the electronics even though the probability may be low. And doing this is not always definitive because a bad alternator may charge enough to keep the car running but not be strong enough to keep the battery charged.
__________________

Last edited by Handy_Cruiser; 16 Jan 2014 at 07:52 pm.
Reply With Quote
  #6 (permalink)  
Old 16 Jan 2014, 08:27 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,880
Default Re: 2005 Bad Alternator???

Quote:
Originally Posted by Handy_Cruiser View Post
I believe others on this forum has reported that at least the 1st Gen PT's will run with no battery in them. Possibly the 2nd Gen's too. The problem is the possibility of damaging the electronics even though the probability may be low. And doing this is not always definitive because a bad alternator may charge enough to keep the car running but not be strong enough to keep the battery charged.
Actually, I tried this after one of these discussions and rob342 seems to be correct about his being the only one. But he recently found the wiring anomaly that accounted for this.
Handy_Cruiser likes this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #7 (permalink)  
Old 16 Jan 2014, 08:41 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,045
Default Re: 2005 Bad Alternator???

Quote:
Originally Posted by Busted_PT View Post
Actually, I tried this after one of these discussions and rob342 seems to be correct about his being the only one. But he recently found the wiring anomaly that accounted for this.
I do think I read somewhere on this forum of someone else doing this and suspiciously saying it would not hurt the car. But your assertion sounds plausible to me. Plus I don't want to test it on my own PT. It's not worth putting my PT in danger. So I concede the point.

And if true, this is another reason for the OP to get his changing system tested. The old school battery disconnection test may not only be potentially bad for the electronics, but also may give a false positive result, meaning it may appear like the alternator does not work every time since the PT engine may almost always quit running.
__________________

Last edited by Handy_Cruiser; 16 Jan 2014 at 08:43 pm.
Reply With Quote
  #8 (permalink)  
Old 16 Jan 2014, 08:42 pm
Regular Cruiser
 
Join Date: Oct 2007
Location: Danville, PA
Posts: 121
Default Re: 2005 Bad Alternator???

I got a digital battery condition/charge indicator with five LED's at a parts store for under $10.00. It's been very useful for figuring out charge and battery issues. Obviously, check the battery terminal condition and the wires where they join the terminals. Also the opposite end of the two battery wires for good connection.
There have been a couple of people here in the recent past who had charging problems because a wire had fallen down and the passenger side axle had rubbed through cutting the wire. A cheap easy fix, but not something you would think to look for.
There have also been recommendations to buy the cheapest alternator you can find and put it in a place where you may pay several hours of labor to have it installed. I put one of those $130 dollar alternators on my Subaru about a year ago (they always seems to fail on a Sunday, and it's the only one you can get)! In the year since, I've gone through three of those alternators, finally put on a Subaru reman (#4) and it's holding up OK. It's a ten minute job to swap alternator on a Subaru, I would not recommend that particular replacement alternator for a PT.
Reply With Quote
  #9 (permalink)  
Old 16 Jan 2014, 09:11 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,880
Default Re: 2005 Bad Alternator???

Quote:
Originally Posted by Handy_Cruiser View Post
I do think I read somewhere on this forum of someone else doing this and suspiciously saying it would not hurt the car. But your assertion sounds plausible to me. Plus I don't want to test it on my own PT. It's not worth putting my PT in danger. So I concede the point.

And if true, this is another reason for the OP to get his changing system tested. The old school battery disconnection test may not only be potentially bad for the electronics, but also may give a false positive result, meaning it may appear like the alternator does not work every time since the PT engine may almost always quit running.
I think the real danger would be connecting the terminal with the engine running, on cars that will. Like you I thought that would work on the PT. Until I was informed other wise. I believe it was Lynn that told me that. Had him on the phone when in tried it for sure.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #10 (permalink)  
Old 17 Jan 2014, 12:28 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,390
Default Re: 2005 Bad Alternator???

A 2005 PT Cruisers charging system is PCM controlled. I highly recommend that if you question anything regarding the alternator that you read a service manual for the testing procedures.

Basically simple "old school" testing do not work, nor is conclusive voltage output engine run or off. Unless you are checking battery condition.

Aside from the PCM there is also a sensor under the battery that also relays data to the PCM controlling generator output.

You can damage both the generator and the PCM if charging system procedures are not done correctly.
__________________
Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I THINK I HAVE A BAD ALTERNATOR musky General PT Cruiser Discussions 13 06 Dec 2012 08:20 am
2005 2005 Convertible top/drivers windows not working rabidaardvark PT Cruiser Convertible Forum 6 08 Sep 2010 10:48 pm
H/O Alternator phil2park2 Sound and Security Forum 7 04 Sep 2010 07:06 am
Alternator Mark Tech & Performance Forum 0 13 Feb 2002 05:46 pm


All times are GMT -5. The time now is 01:52 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors