PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Front Turn Signal Lights Turn On and Off When Applying Brake?

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Jan 2014, 07:26 am
Danny7627's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Queens, NYC
Posts: 351
Default Front Turn Signal Lights Turn On and Off When Applying Brake?

A few days ago, I was pulling in the parking lot of a 7-11 facing the window and I noticed that my front signal indicators both lit up when I applied the brake (07 PT Cruiser)

I went home and pulled, reset and visually inspected the bulbs and connectors including the license plate bulb and could not find anything wrong. All worked ok.

The problem as of yesterday was intermittent. It had stopped happening for a day or two and then yesterday while I was stopped at a light I saw it was occurring again from the reflection from the car ahead of me. Maybe the turn signal switch?

I'm off to work this morning. Hopefully, this evening I will be able to figure it out when I read the responses.

Thanks
Danny
__________________

2008 Convertible Turbo -lite
2007 Touring N/A Boneyard
Reply With Quote
  #2 (permalink)  
Old 19 Jan 2014, 07:47 am
garkeller's Avatar
Cool Cruiser
 
Join Date: Nov 2013
Location: Tampa Bay
Posts: 311
Default Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

OMG...I HATE electrical problems
Hope it's an easy fix---I've got a weird one too in that only my front turn signals flash with my hazards, nothing on the rear---I've been ignoring it so far as everything else is okay
Reply With Quote
  #3 (permalink)  
Old 19 Jan 2014, 07:15 pm
Danny7627's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Queens, NYC
Posts: 351
Default Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

Anyone?
__________________

2008 Convertible Turbo -lite
2007 Touring N/A Boneyard
Reply With Quote
  #4 (permalink)  
Old 19 Jan 2014, 07:28 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Lightbulb Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

Quote:
Originally Posted by Danny7627 View Post
Maybe the turn signal switch?
Could be the MFS,but you should check the wiring & connector the plugs into the MFS,see if any of the wire insulation looks burnt or 'melty' there.
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #5 (permalink)  
Old 19 Jan 2014, 08:23 pm
Danny7627's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Queens, NYC
Posts: 351
Default Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

Quote:
Originally Posted by randyincctx View Post
Could be the MFS,but you should check the wiring & connector the plugs into the MFS,see if any of the wire insulation looks burnt or 'melty' there.
Thanks Randy, I have run some leds here and there but was ever so careful with the wiring. Tomorrow, I will check all the connections and wires again. Everything is functioning properly otherwise.

Maybe its an option to annoy the driver ahead of you in traffic?...lol
__________________

2008 Convertible Turbo -lite
2007 Touring N/A Boneyard
Reply With Quote
  #6 (permalink)  
Old 19 Jan 2014, 08:57 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Wink Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

Quote:
Originally Posted by Danny7627 View Post
Thanks Randy, I have run some leds here and there but was ever so careful with the wiring. Tomorrow, I will check all the connections and wires again. Everything is functioning properly otherwise.

Maybe its an option to annoy the driver ahead of you in traffic?...lol
In the meantime,if santanadharma comes along he'll probably have alot of good info & pics on these kinds of issues.....
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #7 (permalink)  
Old 19 Jan 2014, 11:26 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,021
Default Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

Quote:
Originally Posted by randyincctx View Post
In the meantime,if santanadharma comes along...
He will have to tell you Danny, I have no knowledge of the canbus second-gen electrical system. I would like to have the electrical schematics, but without which I am in ignorance; intermittently, and that is the worst kind.

Do the rear turn signal indicators also light up when the brakes are applied?
Perhaps a short in the wiring where brake light and rear turn light systems are adjacent. If so, the flashers should also flash the brake light bulb. I doubt that the MFS is involved.
Reply With Quote
  #8 (permalink)  
Old 20 Jan 2014, 06:13 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,224
Default Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

Danny; LED's will sometimes confuse the TIPM if they don't draw enough current. You may have to go back to the original bulbs and reset the electrical system by disconnecting the neg battery terminal and stepping on the brake pedal a few times.
Reply With Quote
  #9 (permalink)  
Old 20 Jan 2014, 06:38 am
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,065
Default Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

First, switch you hazard lights on and off several times. Sometimes that's the culprit. Next, if you still have incandescent tail/brake light bulbs, check those. Sometimes the elements inside a double element bulb with touch. This can cause a connection between the brake light circuit and the marker light circuit. Thus, the front markers can come on with the breaks. I imagine the same could happen with LED double element bulbs if the wires on the base are touching.
__________________

Last edited by Handy_Cruiser; 20 Jan 2014 at 06:44 am.
Reply With Quote
  #10 (permalink)  
Old 20 Jan 2014, 07:02 am
Danny7627's Avatar
Cool Cruiser
 
Join Date: Jan 2011
Location: Queens, NYC
Posts: 351
Default Re: Front Turn Signal Lights Turn On and Off When Applying Brake?

Quote:
Originally Posted by pt06 View Post
Danny; LED's will sometimes confuse the TIPM if they don't draw enough current. You may have to go back to the original bulbs and reset the electrical system by disconnecting the neg battery terminal and stepping on the brake pedal a few times.
I appreciate all of the responses.

A few weeks ago I had one brake bulb burn out so I replaced both with Pilot L.E.D. brake 3157 bulbs. Nice and bright.

I was thinking that these might be the culprit.

I will take them out today and replace with original (new3157's) and see what happens. Hopefully, this works.

Also Handy, I will try what you suggested first to see if it's the remedy before I replace the LED bulbs.

Thanks Again!
__________________

2008 Convertible Turbo -lite
2007 Touring N/A Boneyard

Last edited by Danny7627; 20 Jan 2014 at 07:06 am. Reason: More info
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wipers Turn On With Turn Signal or Bump... NewPTCruiserInPA General PT Cruiser Discussions 8 17 Dec 2013 09:10 am
Right front turn signal not working rctjroy Tech & Performance Forum 3 15 Sep 2012 04:26 pm
2006 - Turn signal/driving lights Tarnishedknight Tech & Performance Forum 10 02 Sep 2010 08:23 am
blue turn signal bulbs that turn orange when in us Capt Kidd General PT Cruiser Discussions 1 04 Jun 2004 10:10 pm
Help removing front turn signal reflector. GT_Firebreather Exterior Accessories Forum 7 28 Jul 2003 02:14 pm


All times are GMT -5. The time now is 08:45 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors