PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
PT Cruiser high rpms and strange acceleration issues

 
Like Tree1Likes
  • 1 Post By pluminator

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Jan 2014, 04:08 pm
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 3
Default PT Cruiser high rpms and strange acceleration issues

Cruiser just wants to go, even with break applied.

I’ve never posted on these forums before so forgive me if I managed to mess something up along those lines. But here we go.

I was on my way home with my wife today after running some errands, it was a mix of street and high way driving. As we got off the highway and went to turn down one of our side streets I realized even as I let off the gas and began to push on the break the car still wanted to ‘drive forward’. The RPMs were sitting at around 2,000. Thankfully it was very light traffic so I never had to try and get it to a complete stop until we got to the stop sign before turning down our street.

Here is where it go scary, as I slowed down the RPMs went up, somewhere between 3,000 and 4,000 and just wanted to keep pulling the car even with my foot firmly on the break. So at the stop sign I cut the ignition, gave it a moment and started back up. It immediately jumped up in RPMs and tried to pull us forth. So I shut it off again and restarted it. This time I just threw it into drive and let it pull me, giving it enough gas to get us down the road. But as we turned onto our street and got going it leveled out. Idle went back down and it no longer seemed like it wanted to force me forward.

And now that I am home and have let it sit all seems well. I checked under the hood, the vacuum tubes I can reach seem solidly in place around the TB near the intake. (I am not a car guy, but I did some research prior to writing this). The hoses seem secure, I cant see or feel any leaks (not that it couldn't be else where), the TB seemed clean, not gunked up despite being a high mileage vehicle.

So really I am at a loss, I don’t really know where to look and my first thought was transmission because of the RPMs and such when shifting into gear, but really I am grasping at straws. ANY help on this would be much appreciated. Thank you.
Reply With Quote
  #2 (permalink)  
Old 28 Jan 2014, 04:15 pm
garkeller's Avatar
Cool Cruiser
 
Join Date: Nov 2013
Location: Tampa Bay
Posts: 311
Default Re: PT Cruiser high rpms and strange acceleration issues

My primary thought would be if the throttle cable got in a bind between the pedal and the TB and then if maybe an aftermarket floor mat caused any issue (both have happened to me in older cars)
Anyway, welcome to the forum and glad you and the mrs didn't get hurt with that gremlin attack!Gremlin.jpg
Reply With Quote
  #3 (permalink)  
Old 28 Jan 2014, 04:20 pm
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 3
Default Re: PT Cruiser high rpms and strange acceleration issues

It is a 2001, so it definitely has some years behind it. If it is the binding of the cable as you mentioned is there a way to decrease the chance of it happening? I do not know if it makes a difference, but we live in Michigan, and the snow and cold has been hell this year, so I don't know if that could bring about any troubles.

But thank you again for your reply! We are hoping it was something temporary.
Reply With Quote
  #4 (permalink)  
Old 28 Jan 2014, 08:38 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: PT Cruiser high rpms and strange acceleration issues

I would check the inside of the throttlebody for build up.

If its caked with black gunk it will actual cause the throttle to stick open and not close all the way, thus causing the car to continue accellerating. If its dirty, remove it from the car and clean it out with choke cleaner, but make 100% sure its fully dried before re-installing :-)
Reply With Quote
  #5 (permalink)  
Old 28 Jan 2014, 08:59 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: PT Cruiser high rpms and strange acceleration issues

Was the temp gauge reading normal during this? Assuming so, maybe lub the tb pivot maybe hanging open. Inspect the cables to see if anything is out of place. Zip tie the vac hose ends you can get to. Do you have a check engine light?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #6 (permalink)  
Old 28 Jan 2014, 09:23 pm
garkeller's Avatar
Cool Cruiser
 
Join Date: Nov 2013
Location: Tampa Bay
Posts: 311
Default Re: PT Cruiser high rpms and strange acceleration issues

I'm unfamiliar with what hard cold temps can do to a vehicle as I've always lived in Florida...is it possible for the steel cable to freeze/ice up in the line? It def sounds like something along the TB cable/connections/internal so I would say a good cleaning along all that area to see...good luck and stay safe! Make sure you use actual TB cleaner as it's safe on the exposed sensors in the TB area!
05078.jpg
Reply With Quote
  #7 (permalink)  
Old 28 Jan 2014, 09:25 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: PT Cruiser high rpms and strange acceleration issues

Quote:
Originally Posted by garkeller View Post
I'm unfamiliar with what hard cold temps can do to a vehicle as I've always lived in Florida...is it possible for the steel cable to freeze/ice up in the line? It def sounds like something along the TB cable/connections/internal so I would say a good cleaning along all that area to see...good luck and stay safe! Make sure you use actual TB cleaner as it's safe on the exposed sensors in the TB area!
Attachment 9994
Except the air intake temp sensor!!!!. BAG THAT! I toasted mine with TB cleaner last summer :-p haha
garkeller likes this.
Reply With Quote
  #8 (permalink)  
Old 28 Jan 2014, 09:31 pm
garkeller's Avatar
Cool Cruiser
 
Join Date: Nov 2013
Location: Tampa Bay
Posts: 311
Default Re: PT Cruiser high rpms and strange acceleration issues

I know what you mean Plum...I hate that little delicate thingie that just sorta sticks out waiting for something to bang against it while doing motor work!
Reply With Quote
  #9 (permalink)  
Old 28 Jan 2014, 09:45 pm
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 3
Default Re: PT Cruiser high rpms and strange acceleration issues

Thank you all for your quick and informative replies! I am going to take the time to get up in there and see just how dirty it is. Curious glance it seemed fine, but I was pissed off and probably not the most reasonable at the time. So I will take a look at that and trace the cables and make sure its all good. I'll be sure to watch out for the sensor and bag it if cleaning is done so I don't screw it up.

I will probably get to it all by this weekend and post an update then on how things went. Thanks again for the advice, it really gave us a good direction to go with.
Reply With Quote
  #10 (permalink)  
Old 28 Jan 2014, 09:50 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: PT Cruiser high rpms and strange acceleration issues

Quote:
Originally Posted by CarNoob85 View Post
Thank you all for your quick and informative replies! I am going to take the time to get up in there and see just how dirty it is. Curious glance it seemed fine, but I was pissed off and probably not the most reasonable at the time. So I will take a look at that and trace the cables and make sure its all good. I'll be sure to watch out for the sensor and bag it if cleaning is done so I don't screw it up.

I will probably get to it all by this weekend and post an update then on how things went. Thanks again for the advice, it really gave us a good direction to go with.
If its a continuing problem, You can just pull the intake hose off and take a cloth to the inside of the TB for a quick clean out, should give some effect :-) that way you can have a semi-normal acceleration until the weekend, takes about 2 minutes :-)
Reply With Quote
Reply

Tags
acceleration issue, high idle, high rpms


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Siren Noise upon acceleration Cali777 General Turbo Discussions 6 11 Jun 2012 06:04 pm
High Idle and Cooling issues shadowsnkx Tech & Performance Forum 0 06 Sep 2011 08:55 pm
Engine surging at 4000 RPMs along with shaking at 2000 RPMs... brian5060 Tech & Performance Forum 3 24 Jul 2010 07:42 pm
Stutters during acceleration at low RPMs 2004PTGT General PT Cruiser Discussions 14 13 Jun 2009 10:17 am
Computer Causing PT Cruiser to Stall at Low RPMs/Turns??? pulpjava General PT Cruiser Discussions 7 26 Mar 2009 06:38 am


All times are GMT -5. The time now is 01:19 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors