PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
New PT owner here...with a BIG problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30 Jan 2014, 06:09 pm
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 5
Default New PT owner here...with a BIG problem

Hows it going fellas..i just bought a cruiser, i have always loved these cars. the issue...it seems as if all the transmission oil has leaked out between the block and the trans...i have read that it needs a seal (i have no ides what seal or where this seal is)...but what i want to know is if i need a new transmission, or if changing this seal (i realize that the trans may have to come out)...will fix the problem.
anyone
Reply With Quote
  #2 (permalink)  
Old 30 Jan 2014, 06:59 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: New PT owner here...with a BIG problem

I'm not aware this is a common problem- I understand the solenoid pack leaks out, but that's up front.
Assuming it is an automatic.
Reply With Quote
  #3 (permalink)  
Old 30 Jan 2014, 08:12 pm
mityqwik's Avatar
Senior Cruiser
 
Join Date: Sep 2010
Location: Hampton roads Va.
Posts: 1,966
Default Re: New PT owner here...with a BIG problem

welcome to the forum
__________________
It takes 8,460 bolts to assemble an automobile,
and one nut to scatter it all over the road
Reply With Quote
  #4 (permalink)  
Old 31 Jan 2014, 08:59 am
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 5
Default Re: New PT owner here...with a BIG problem

Where would the solenoid pack leak out from....and yes, automatic.
Reply With Quote
  #5 (permalink)  
Old 31 Jan 2014, 01:05 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: New PT owner here...with a BIG problem

The pack is on trans front. There's lots of threads on this.
I'm not an expert on this, so my advice is limited.
Reply With Quote
  #6 (permalink)  
Old 31 Jan 2014, 09:51 pm
767skyking's Avatar
Fanatic Cruiser
 
Join Date: Nov 2009
Location: Inland Empire Ca
Posts: 754
Default Re: New PT owner here...with a BIG problem

Chrysler had some problems with torque converters leaking at the welds... Might be the problem.
__________________
The "Three Amigos" (And Growing)
Performace, Body and Service, OEM
"Team Amigos FREE Parts!! PM me for details!!

Reply With Quote
  #7 (permalink)  
Old 01 Feb 2014, 11:37 am
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 5
Default Re: New PT owner here...with a BIG problem

Thanks guys....so would replacing the tranny with a good working used one be a good idea? What do you guys think? I found a used one that has had the solenoid packs replaced from the dealer about 30k miles ago.
Reply With Quote
  #8 (permalink)  
Old 02 Feb 2014, 12:01 pm
Fresh Cruiser
 
Join Date: Jan 2014
Posts: 5
Default Re: New PT owner here...with a BIG problem

anything guys?
Reply With Quote
  #9 (permalink)  
Old 02 Feb 2014, 12:54 pm
Young Cruiser
 
Join Date: Mar 2013
Posts: 98
Default Re: New PT owner here...with a BIG problem

Welcome

Pretty much a blanket statement when you are dealing with a "good working used one". First, how do you know it works well? Are you buying it from a private individual you trust, or from a salvage yard? Next, a visual inspection is in order - fluid color/smell, looking for leaks, broken bolts, stripped holes, broken mounts, etc. And personally I never install a used trans without changing the converter, axle, dipstick tube, shift shaft, and any other seal that I can. Check all the torque struts and suspension stuff, like LCA bushings, half shafts and axle bearings - all common replacement items. And another important but often forgotten step - FLUSH THE COOLER.

Hope this helps.
Reply With Quote
  #10 (permalink)  
Old 02 Feb 2014, 02:11 pm
767skyking's Avatar
Fanatic Cruiser
 
Join Date: Nov 2009
Location: Inland Empire Ca
Posts: 754
Default Re: New PT owner here...with a BIG problem

If the original transmission is operating fine, pull the trans and figure out if it is leaking at the shaft seal or converter and replace what is needed. There are shops in our area that will do "soft" rebuilds (clutch plates, gaskets and seals) for about $650, which includes a reman converter.
__________________
The "Three Amigos" (And Growing)
Performace, Body and Service, OEM
"Team Amigos FREE Parts!! PM me for details!!

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are you a PT owner or a Chrysler owner? purple04 General PT Cruiser Discussions 55 04 Sep 2014 09:57 pm
New PT Owner with a problem dantheman General PT Cruiser Discussions 14 14 Sep 2011 04:08 am
Another new owner Gremlin Welcome New PT Cruiser Members 14 01 Aug 2011 03:28 pm
is it a balljoint problem or a wheel bearing problem? phtech Tech & Performance Forum 2 05 Mar 2011 04:33 pm


All times are GMT -5. The time now is 01:15 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors