PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
P0480 - Cooling Fan Relay but weird...

 
Like Tree1Likes
  • 1 Post By CREWZIN

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Feb 2014, 12:46 pm
Fresh Cruiser
 
Join Date: Feb 2014
Posts: 4
Default P0480 - Cooling Fan Relay but weird...

Trying to help a friend work on his car. He has an '06 non-turbo. His car was overheating and I found out his low speed fan had quit working. Also noticed the fuse had blown for the fan motor. Replaced the fan motor and the fuse. Fan didn't work. Replaced the relay and then it starts working but has the code P0480 Cooling Fan Relay 1 Control Circuit. Whats weird is when you turn the car off and restart it the fan won't work. With the car running, pulled the relay and put it back in and it starts working. What is even weirder is that tried it again, pulled the relay, and then the fan turns on with the relay out. How in the heck would the fan run with the relay out?

I am going to have him replace the relay again but I do not know what is going on here.
Reply With Quote
  #2 (permalink)  
Old 02 Feb 2014, 01:44 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: P0480 - Cooling Fan Relay but weird...

If you replaced the fan unit you replaced the relays as they are all part of the fan unit. So which relay are you pulling? The ones mounted on the fan shroud or somewhere else.
Reply With Quote
  #3 (permalink)  
Old 02 Feb 2014, 01:51 pm
Fresh Cruiser
 
Join Date: Feb 2014
Posts: 4
Default Re: P0480 - Cooling Fan Relay but weird...

There are not any mounted on the shroud. It is just the one that is in the distribution box next to the master cylinder. I was looking around online though and it looks like the '06 and newer should have them on the shroud but his doesn't which is weird.
Reply With Quote
  #4 (permalink)  
Old 02 Feb 2014, 03:34 pm
VNT's Avatar
VNT VNT is offline
Senior Cruiser
 
Join Date: Jun 2009
Location: NE
Posts: 1,466
Default Re: P0480 - Cooling Fan Relay but weird...

So you replaced his fan module(fan, enclosure, relays) and now he still has an issue?

I just replaced mine with a new mopar fan module(250 clams), replaced the 50A in cavity 11 and everything is fine.


Note when my original fan module failed, you could smell burnt electrical and next day the CEL tripped. I ordered the new fan that evening, dealer cut me a deal on the fan and had it next morning.
__________________
VNT

89 Shadow ES 2.5 T2 +20's A555 sold
86 TurboZ CS 2.2 T2 +20's A555
90 Daytona ES 2.5 T1 A523
90 Datyona Shelby VNT needs work
00 Durango SLT+ 5.9 4x4
02 Grand Cherokee 4.7 4x4
03 PT GT Black 5 sp Stg 1
05 PT GT Silver 5 Spd Conv
06 PT GT Cool Vanilla 5 spd Conv
06 PT Base Marine Blue 40TE Conv
15 Grand Cherokee Overland 5.7 QD2
Reply With Quote
  #5 (permalink)  
Old 02 Feb 2014, 03:52 pm
Fresh Cruiser
 
Join Date: Feb 2014
Posts: 4
Default Re: P0480 - Cooling Fan Relay but weird...

Removed the fan and shroud from car. I took the fan blade off and replaced the motor. Replaced the fuse and the relay in the distribution box. There are no relays on the shroud like I have seen in some pics online. The only relay I see for it is the one in the distribution box. It is something to do with the relay now. Fan runs great but doesn't come on unless you mess with the relay. I just don't understand how the fan runs with the low speed relay out in my hand.
Reply With Quote
  #6 (permalink)  
Old 02 Feb 2014, 04:33 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: P0480 - Cooling Fan Relay but weird...

Robert, I don't pretend to know your answer, but I do have questions: YES the 2006 to 2008 (and maybe more) radiator fan is supposed to have TWO relays near the top of the fan (as you have seen in pictures). Those relays attach to electrical connections near the top of the fan. Do you NOT have those two connections that attach to the relays that are supposed to be on the fan? If not, and you do buy a 2006+ radiator fan with the relays attached, you don't have the electrical connection to go to those relays, correct?

If you don't have those connections, somebody jury rigged something so the fan would work without the relays (attached) and that's why it's running without the relay in the distribution box. Maybe somebody bought the wrong fan (01-05) and did some work on the car so the fan would run?

Don't know if I made myself clear or not but you are right saying the fan should NOT run with the relay out of the dist box...unless someone might have done something to get it to run.
bert57 likes this.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 02 Feb 2014 at 04:36 pm.
Reply With Quote
  #7 (permalink)  
Old 03 Feb 2014, 12:07 am
Fresh Cruiser
 
Join Date: Feb 2014
Posts: 4
Default Re: P0480 - Cooling Fan Relay but weird...

I will make sure his car is not an '06 but he says that is what the registration says. It seems like though it would be an '01-'05 with the fan setup. The fan on the car did not have the relays attached to it and the one I replaced it with did not also. I will have to do more investigating.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cooling fan relay 2 circuit location... jcmnz24 General PT Cruiser Discussions 4 28 Sep 2013 02:06 pm
Cooling fan relay ? facts Tech & Performance Forum 11 22 Aug 2013 10:58 pm
Cooling Fan Relay bowrock General PT Cruiser Discussions 2 19 Dec 2012 08:32 am
Radiator/cooling fan relay part number for PT 06? TwoCats Tech & Performance Forum 23 24 Jan 2012 10:35 am
Weird Cooling Issue TurboDucky Tech & Performance Forum 3 31 Dec 2011 01:40 pm


All times are GMT -5. The time now is 08:11 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors