PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
01 smells hot when shut off

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Feb 2014, 05:35 pm
Fresh Cruiser
 
Join Date: Feb 2014
Posts: 1
Lightbulb 01 smells hot when shut off

I have an 01 Cruiser. I just replaced the tensioner pulley and now the car smells hot and like burnt rubber when I shut it off. The serpentine belt is still in good shape. Maybe a cooling fan issue??? Anybody have experience with this issue?
Reply With Quote
  #2 (permalink)  
Old 12 Feb 2014, 06:05 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 01 smells hot when shut off

If it didn't smell that way before the tensioner change, then that's where to start looking for what's causing the burnt rubber smell.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
something smells like rotten eggs,. mkinsey7 General PT Cruiser Discussions 7 10 Sep 2014 09:33 pm
2003 - Smells Like Coolant, Just Started Overheating AllisonInVirginia Tech & Performance Forum 5 08 Dec 2011 05:24 pm
A/C smells.. arain Tech & Performance Forum 0 20 Sep 2011 07:41 pm
Smells of oil jona_20017 General PT Cruiser Discussions 3 19 Mar 2011 05:47 pm
A/C Smells Terrible Scott123 Tech & Performance Forum 6 28 Oct 2007 08:38 pm


All times are GMT -5. The time now is 09:50 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors