PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Flickering Lights

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Feb 2014, 04:25 pm
thetunesguy's Avatar
Fresh Cruiser
 
Join Date: Oct 2010
Location: Lathrop CA
Posts: 23
Default Flickering Lights

Just finished putting the DreamCruiser back together after replairing the turbo. I've taken the car out and about a few times and have noticed that there is now a serious flickering of all lights (dashboard, odometer, headlights, etc.).

Does anyone know if there's something near the turbo that I might have knocked loose that might cause this?? I had the battery disconnected while repairs were happening but I didn't mess with the electrical system so I'm in the dark here...
__________________

Proud owner of 2003 Dream Cruiser #40
Reply With Quote
  #2 (permalink)  
Old 24 Feb 2014, 04:39 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Post Re: Flickering Lights

Just curious.....See if it makes a difference when you move the steering column up & down,there is a known issue with the grounding point located at the pivot point inside the steering column.


ST_CLM01.jpg

ST_CLM02.jpg

ST_CLM03.jpg
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #3 (permalink)  
Old 24 Feb 2014, 05:48 pm
thetunesguy's Avatar
Fresh Cruiser
 
Join Date: Oct 2010
Location: Lathrop CA
Posts: 23
Default Re: Flickering Lights

Are those pics an example of how to beef up the ground wiring?? Or is that actual stock ground wiring from the steeriing column??
__________________

Proud owner of 2003 Dream Cruiser #40
Reply With Quote
  #4 (permalink)  
Old 24 Feb 2014, 06:15 pm
rcktpwrd's Avatar
Senior Cruiser
 
Join Date: Jan 2011
Location: Raleigh, NC
Posts: 1,813
Default Re: Flickering Lights

Quote:
Originally Posted by thetunesguy View Post
Are those pics an example of how to beef up the ground wiring?? Or is that actual stock ground wiring from the steeriing column??
that is to repair a faulty factory ground setup from the factory, in relation to the horn and radio display not working.

For your issue I would double check the ground connection at the battery. make sure the wire is still in good condition and not corroded also check the connection to the fender...
__________________
Joel

2001 PT Cruiser 5-speed; 1976 Oldsmobile Cutlass S; 1990 Chevy 454SS; 1995 Caprice Classic woody
www.rcktpwrd.com
Reply With Quote
  #5 (permalink)  
Old 24 Feb 2014, 06:29 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Flickering Lights

Quote:
Originally Posted by thetunesguy View Post
Are those pics an example of how to beef up the ground wiring?? Or is that actual stock ground wiring from the steeriing column??
After you take note ad follow Randy's advice and hopefully find your problem, you might want to beef up your grounding system by looking up and searching for "hypergrounding" on Google or on this forum.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 25 Feb 2014, 12:14 pm
thetunesguy's Avatar
Fresh Cruiser
 
Join Date: Oct 2010
Location: Lathrop CA
Posts: 23
Default Re: Flickering Lights

I'm definitely going to have to figure this one out. As I was driving today, the stereo shut off for a split second after hitting a bump. It came right back on - wasn't even off for a half-second - but the display was off, and everything. The engine does not seem to be affected - it keeps on running, so I'm not thinking that it's alternator-related.
__________________

Proud owner of 2003 Dream Cruiser #40
Reply With Quote
  #7 (permalink)  
Old 04 Jun 2014, 05:46 pm
Fresh Cruiser
 
Join Date: Jan 2014
Location: Port St. Lucie, FL
Posts: 6
Default Re: Flickering Lights

I posted this elsewhere on this site, but I wanted to be sure you see it. It just might help you or another PT owner that has this problem:

My wife's 2003 GT Turbo has been haunted by all kinds of electrical problems since we got it back in October 2013 with 93,000 miles on the odometer.

Symptoms: Flickering dash, interior lights & headlights; At times it would do what I thought was a full reset where the engine would shudder, all dash lights come on & gauges would peg and then normalize. Sometimes the car would shut off- very scary while she's driving it at the time. Not to mention the very annoying power locks randomly cycling all the time...

Other posts here suggested auxiliary ground wiring, so that got done. No change- still haunted. I had a hundred dollar bill burning a hole in my pocket so I bought a new battery. Next, I replaced the Multifunction switch. No change in the flickering issue, but at least the fog lights work now so it wasn't a wasted expense...

The car had a history of the Check Engine light coming on, throwing a P0480 code (Low speed fan relay). I bought the very expensive used Bosch fan motor for $235.00 back in February, but because the PT never overheated, I put off installing it. Instead I replaced the PCM last month- another $300.00 adventure.

Then the PT began to randomly shut down completely as if the ignition switch was turned off. So I replaced the switch. The bad behavior continued, along with the random P0480 fan code. Maybe the fan error was "backfeeding" bad data to the PCM? So last night I tackled the fan motor replacement.

After it was installed, I let it idle waiting for it to get warm enough to cycle the fan. While I'm standing there pointing a flashlight at the fan, I happened to rest my hand on the positive battery terminal. It was so hot that it burned my palm!

Turned out that where the 2 heavy gauge wires enter the terminal, corrosion got in and created a high resistance causing the problem! Got a new terminal for $4.00, stripped back the insulation to expose non-crystallized wire, secured them tightly and started it up.

Fixed! For the 1st time since we've owned it she runs like a new car. Drove it for over an hour with no issues, and it runs better than I've ever experienced since day 1.

So I recommend that you touch the battery terminals and if either if them are warmer than the battery itself, you need to find out why & fix it.
Reply With Quote
  #8 (permalink)  
Old 04 Jun 2014, 07:05 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Flickering Lights

Quote:
Originally Posted by gcapp99 View Post
I posted this elsewhere on this site, but I wanted to be sure you see it. It just might help you or another PT owner that has this problem:
Thanks for taking the time to report what your problem and cure was.

I have seen battery clamps so loose you could move them around by hand - no wrench - and terminals corroded, but not the cables to the clamps being the problem.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
lights flickering cookieman18 General PT Cruiser Discussions 19 27 Nov 2016 10:01 pm
Fog lights flickering-ignition off-no fuse Paulalh General PT Cruiser Discussions 3 13 Jun 2013 01:18 am
Flickering lights dom92 General PT Cruiser Discussions 2 01 Mar 2011 06:58 pm
Flickering lights again white General PT Cruiser Discussions 1 02 Mar 2009 04:00 pm
Flashing/Flickering lights alien88 General PT Cruiser Discussions 4 25 Nov 2008 10:19 pm


All times are GMT -5. The time now is 02:47 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors