PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
More Mystery Problems w/ my '06 Turbo

 
Like Tree3Likes
  • 1 Post By Ray_Dockrey
  • 1 Post By quicksilverdon
  • 1 Post By Hearse

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Mar 2014, 10:18 am
Fresh Cruiser
 
Join Date: Jul 2012
Location: Somerville, MA
Posts: 13
Default More Mystery Problems w/ my '06 Turbo

Hi all,

My '06 turbo is having some mystery problems, and the symptoms are quite frankly confusing me and the repair shop where I have it, so I thought I'd ask the experts.

-Been having white (maybe white/blue) smoke out of the exhaust when starting up for about a week. Does not smell sweet, like I have heard coolant does. It smells like burning hydrocarbons.
-No overheating.
-Took car for an oil change Wednesday, and the coolant was very low. They refilled it. It is still fine, not low, so if there's a leak, it's not a fast one.
-I (and the mechanic) can smell a sort of burning smell inside the car.
-Last night, white smoke was coming out from the hood after I had driven it for about a mile. Has not happened again.
-Before the oil change, the oil light blinked on twice. I immediately took it in.
-Shop can't find any noticeable external leaks.
-Possibly, there is some hesitation, lack of smoothness (if that makes any sense) when I accelerate, particularly a "hard" acceleration from a standstill.
-A few times while accelerating, I've heard a repeated clicking noise. Doesn't happen all the time, not sure if it's related.

I was suspecting head gasket, but was told it would be overheating if that was the problem? Is that true?

I'm about an hour from my home and trying to figure out if it's safe to continue driving.

Thanks in advance for any thoughts you might have. You guys are the best.
Reply With Quote
  #2 (permalink)  
Old 14 Mar 2014, 10:49 am
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: More Mystery Problems w/ my '06 Turbo

Has the PCV been changed? I know that in a lot of cases with the turbo it is suggested to start with the PCV.

Hesitation and rough idle could be it needs plugs and wires if they haven't been changed.
Reply With Quote
  #3 (permalink)  
Old 14 Mar 2014, 11:51 am
Fresh Cruiser
 
Join Date: Jul 2012
Location: Somerville, MA
Posts: 13
Default Re: More Mystery Problems w/ my '06 Turbo

Idle is fine, not rough. I finally had the same conclusion about the PCV after reading lots and lots of other threads. Car has 160,000 miles, and I don't think it's ever been changed. Is this something a non-mechanical person can change easily? I see the part is fairly inexpensive and from what I've been reading, it's just a matter of finding the piece and switching it out - don't have to take anything else apart. Is that accurate? What should I know to watch out for?
Reply With Quote
  #4 (permalink)  
Old 14 Mar 2014, 12:02 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: More Mystery Problems w/ my '06 Turbo

Agree on PCV - changing one is all of 5 minutes - shake the new one, it'll rattle and old one probably won't.
The spark plugs on PTs are in "wells" that have oil seals that can and often do go bad and the leaked oil will stink and possibly smoke.
randyincctx likes this.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 14 Mar 2014, 01:46 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Post Re: More Mystery Problems w/ my '06 Turbo

It's a fairly simple task,especially when you have a group of people helping with the instructions........
The hardest part will probably be removing the old,especially if sealant(RTV) or thread tape was used previously,plus being in there for so many years/miles!
First thing is to locate the PCV valve (see photos),then take/pull off the rubber/plastic hose,and then unscrew the old valve using a 24mm wrench.
Installation is basically the reverse;Screw the new valve in,torque to 70 inch lbs(or fairly tight,NOT too tight!),then re-attach the rubber/plastic hose...and your done.





__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #6 (permalink)  
Old 14 Mar 2014, 03:14 pm
Young Cruiser
 
Join Date: Jun 2013
Location: Petaluma, California
Posts: 64
Default Re: More Mystery Problems w/ my '06 Turbo

The pvc valve is on the other side of the valve cover on top for turbo's.
randyincctx likes this.
__________________
2003 GT- Stage 1, Mopar BOV, 2.75" catback, Hurst SS, Eibach pro-kit, 6000k fogs, Alpine CDA 7893, 10" Alpine Type-X powered with JL Audio e1400d, Alpine Type-R components powered with JL Audio e4300.
Reply With Quote
  #7 (permalink)  
Old 14 Mar 2014, 03:33 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Red face Re: More Mystery Problems w/ my '06 Turbo

Quote:
Originally Posted by Hearse View Post
The pvc valve is on the other side of the valve cover on top for turbo's.
You are correct sir...I missed that part;My bad;Other than the location of the PCV valve,it's still the same basic process for R&R.
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #8 (permalink)  
Old 14 Mar 2014, 07:39 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: More Mystery Problems w/ my '06 Turbo

Quote:
Originally Posted by Hearse View Post
The pvc valve is on the other side of the valve cover on top for turbo's.
And on my '05, doesn't screw in, is a push and 1/4 turn twist.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 14 Mar 2014, 07:52 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,891
Default Re: More Mystery Problems w/ my '06 Turbo

If your turbo has a quite a few miles you may want to pull the intake hose off and check the play in the shaft . In and out and side to side.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #10 (permalink)  
Old 16 Mar 2014, 10:02 am
Fresh Cruiser
 
Join Date: Jul 2012
Location: Somerville, MA
Posts: 13
Default Re: More Mystery Problems w/ my '06 Turbo

Anyone have problems getting the part? The parts stores' computers show a straight valve, not the angled one that came out of the car. When I brought the actual part in, they said it has to be ordered from the factory. The dealership here thinks they have one, but I'm less than optimistic at this point.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 pt. turbo alt.problems Broomstix Tech & Performance Forum 4 18 Aug 2013 12:47 pm
Turbo problems...help! loki547 General Turbo Discussions 21 06 Aug 2011 11:06 am
Turbo problems? PTCruisinTurbo General Turbo Discussions 29 30 Jan 2011 04:08 pm
'04 PT Turbo/GT stalling problems! pcm2a General PT Cruiser Discussions 1 01 Oct 2007 07:53 am
Major Turbo problems Iris Turbo Performance 7 04 May 2004 07:06 pm


All times are GMT -5. The time now is 12:44 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors