PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2006 PT maxes rpm at 3500 and dies at idle speed

 
Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Mar 2014, 09:54 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 12
Question 2006 PT maxes rpm at 3500 and dies at idle speed

2006 PT, not turbo, touring edition

running like crud. maxes out rpm at 3500 and acts like limiter has kicked in. won't idle, just dies unless holding foot on the gas. also hard to start, have to hold foot on gas at just the right amount to get it to start. got the codes pulled, they are listed below. things i have already done include new fuel pump, new catalytic converter, new muffler, new crank shaft sensor, (new cam shaft sensor goes on saturday, its sitting on the shelf right now waiting for me to have the free time and daylight), new idle air control valve, new throttle position sensor. unrelated but just to add, also a new waterpump and timing belt. (problem was there before new water pump and timing belt were installed, and got no worse) after each new thing was installed, the car would run normal for about 5 seconds, i assume while the computer was sensing it or whatever. i can't figure that part out. after the 5 seconds of the car being like "oh hey, whats this new gadget... kinda cool... oh nevermind ima run like a POS again, sorry bud," it just goes back to dying unless foot on gas.

so here's the codes that got pulled about two months ago (well, one is an actual "code" the others are spelled out):

p2074
mass air flow sensor
random misfire cylinder 3
idle control circuit low
iat sensor
o2 sensor high voltage
map baro sensor
throttle pedal position sensor


Any help is certainly appreciated. Thanks
J
Reply With Quote
  #2 (permalink)  
Old 21 Mar 2014, 11:02 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Lightbulb Re: 2006 PT maxes rpm at 3500 and dies at idle speed

Quote:
Originally Posted by bundixlake View Post
p2074
mass air flow sensor
random misfire cylinder 3
idle control circuit low
iat sensor
o2 sensor high voltage
map baro sensor
throttle pedal position sensor
With all of that going on,and all you have done (or checked) already,being a 2006 PT Cruiser,the first year they went to Can-Bus electronics,there could possibly be a problem with your TIPM (not unheard of).
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #3 (permalink)  
Old 22 Mar 2014, 10:46 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 12
Default Re: 2006 PT maxes rpm at 3500 and dies at idle speed

i hope not. that thing runs about 800 bucks, doesn't it?
Reply With Quote
  #4 (permalink)  
Old 23 Mar 2014, 08:31 am
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: 2006 PT maxes rpm at 3500 and dies at idle speed

Have you replaced the map sensor? It can cause issues like you describe.
Reply With Quote
  #5 (permalink)  
Old 23 Mar 2014, 10:44 am
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: 2006 PT maxes rpm at 3500 and dies at idle speed

Try switching the plugs on the IAC and TPS. Some people plug them in wrong. Same shape connector, easy mistake to make any time they get disconnected for other maintenance, such as removing the upper intake to change the spark plugs or fixing a leaky valve cover gasket

Last edited by rob342; 23 Mar 2014 at 10:56 am.
Reply With Quote
  #6 (permalink)  
Old 25 Mar 2014, 03:54 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 12
Default Re: 2006 PT maxes rpm at 3500 and dies at idle speed

@rob342: i just went out to try that, and the IAC plug won't even reach (by about three inches or so) to the TPS and so that isn't the problem... but good idea anyway.
Reply With Quote
  #7 (permalink)  
Old 25 Mar 2014, 05:45 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 12
Default Re: 2006 PT maxes rpm at 3500 and dies at idle speed

on my way down for a new map sensor now
Reply With Quote
  #8 (permalink)  
Old 25 Mar 2014, 08:38 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 12
Default Re: 2006 PT maxes rpm at 3500 and dies at idle speed

well put on new map sensor but cant tell if it works because now it wont start at all. fuel not getting to engine again... acting like it did when my hose slipped off my new fuel pump. except now it has a full tank of gas, so dropping the tank again will be a bitch. i clamped the crap out of that hose, too. i hate this car.
Reply With Quote
  #9 (permalink)  
Old 25 Mar 2014, 11:49 pm
2step's Avatar
Senior Cruiser
 
Join Date: Oct 2004
Location: New Braunfels, Texas.
Posts: 1,672
Default Re: 2006 PT maxes rpm at 3500 and dies at idle speed

If you are trying to rev the RPM above 3500 with the car sitting in neutral then, yes, there is a limiter to prevent "over reving" the engine when not in gear. Normal. The idle problems can be a number of things including plugged or stuck injector(s). You might try pulling the spark plugs right after shut down to visually check to see if they are all equally wet/dry. What you're describing doesn't sound like a vacuum leak exactly but don't rule it out. Those are a couple of ideas you can try that don't cost anything to check. But they are minor projects. So far you have been throwing new parts at it hoping something will work. You are going to pretty close to what it would have cost you to have a mechanic fix the problem. In any case, I hope you get it all sorted out soon.
bundixlake likes this.
Reply With Quote
  #10 (permalink)  
Old 26 Mar 2014, 04:51 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 12
Default Re: 2006 PT maxes rpm at 3500 and dies at idle speed

Quote:
Originally Posted by 2step View Post
If you are trying to rev the RPM above 3500 with the car sitting in neutral then, yes, there is a limiter to prevent "over reving" the engine when not in gear. Normal. The idle problems can be a number of things including plugged or stuck injector(s). You might try pulling the spark plugs right after shut down to visually check to see if they are all equally wet/dry. What you're describing doesn't sound like a vacuum leak exactly but don't rule it out. Those are a couple of ideas you can try that don't cost anything to check. But they are minor projects. So far you have been throwing new parts at it hoping something will work. You are going to pretty close to what it would have cost you to have a mechanic fix the problem. In any case, I hope you get it all sorted out soon.
well thanks for letting me know that about the RPM. be hard to pull the plugs right after shutting it down, since you gotta take off all that crap from the top just to get to them. they looked pretty good when i changed them though. the mechanic i asked about it a while ago told me he'd be doing the same thing as me, just changing all the sensors until something worked, since that's what the code reader was saying was wrong. he said it was "hit and miss" because with a problem like this, you can't really know what's going on for sure. i've got to drop the tank this weekend to see if that hose slipped off of the fuel pump. i dont know how in the hell it could have, i clamped the crap out of it, but who knows with this car. thanks.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
-Very- Rough Idle and engine dies + hot air purplecruiser Tech & Performance Forum 6 27 Feb 2015 11:09 am
Very Rough Idle, engine dies sometimes jonlouisville77 Tech & Performance Forum 13 03 May 2012 12:37 pm
Rough idle - dies. bigtop1228 Tech & Performance Forum 13 29 Dec 2011 10:19 am
rough idle and dies bompa45 Tech & Performance Forum 19 29 Mar 2009 09:19 am


All times are GMT -5. The time now is 03:18 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors