PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2007 2.4 Touring - TCM issues?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Mar 2014, 01:22 pm
rg1 rg1 is offline
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 16
Default 2007 2.4 Touring - TCM issues? have error codes

Wife was out driving the car and said she couldn't get out of first gear. Engine light was on. When she got home, I checked fluids. All seemed ok. I got in started it up. Saw engine light. I drove it around the block a few times, had no issues with shifting into higher gears.

I got the following diagnostic codes:
P0700 - (General) Trans control system malfunction
P0218 - over temp
P0714 - Tans. flud Temp sensor
P0882 - TCM power input signal

Considering the car seems ok now, should I get it checked out? Could the TCM be going bad? Could it somehow have lost power due to loose connection and then recover? How long will it take for the code to clear?

Any help, suggestions, greatly appreciated.

Thanks.

-Rob

Last edited by rg1; 24 Mar 2014 at 02:48 pm.
Reply With Quote
  #2 (permalink)  
Old 25 Mar 2014, 09:47 am
rg1 rg1 is offline
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 16
Default Re: 2007 2.4 Touring - TCM issues?

anyone...bueller? bueller?

My mechanic friend told me PTs are infamous for TCM issues...

My check-engine light went off....still not sure what I should do...
Reply With Quote
  #3 (permalink)  
Old 25 Mar 2014, 09:59 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,891
Default Re: 2007 2.4 Touring - TCM issues?

How many miles? Has it ever been serviced?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 30 Mar 2014, 08:51 am
rg1 rg1 is offline
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 16
Default 2007 2.4 Touring - TCM / PCM issue - going into LIMP mode

Hi..the car has 58000 miles. It hasn't been services since I have taken possession. It has been in my family for a while, and nothing major was needed/done.

I spoke with a mechanic about the issue, and the general consensus is the PCM is going bad and nothing I can do.

The problem came back today. Started up, engine light came on, car was in "LIMP" mode. I shut off the car, and restarted, and it was fine. Engine light is still on, but not in "LIMP" mode.

I also found out this car has integrated TCM/PCM, so I cant just replace my TCM (so I am told), and I have to replace the entire PCM. Is this true?

Im not sure what my options are. If I need new PCM, I quess I would just have to do it, but Im hoping there may be other solution.
Reply With Quote
  #5 (permalink)  
Old 14 Apr 2014, 10:01 am
rg1 rg1 is offline
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 16
Default Re: 2007 2.4 Touring - TCM issues?

So the problem comes and goes...what should I do?
Reply With Quote
  #6 (permalink)  
Old 05 Jun 2014, 02:37 pm
Fresh Cruiser
 
Join Date: Jan 2013
Location: Arizona
Posts: 14
Default Re: 2007 2.4 Touring - TCM issues?

I am having the same issue. I put it in the shop and the mechanic got these codes. P1684, P0882 and P0218. He cleared the codes and could not duplicate the problem. I drove home fine and this morning the engine light is on and it is limp mode. Mechanic thinks its a sensor inside the tranny. Any advise would be greatly appreciated. BTW, this happened right after I had my radiator flushed...don't know if this means anything. Thanks in advance for any assistance.

Nawnie
Reply With Quote
  #7 (permalink)  
Old 05 Jun 2014, 04:05 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,805
Default Re: 2007 2.4 Touring - TCM issues?

Quote:
Originally Posted by rg1 View Post
So the problem comes and goes...what should I do?
Quote:
Originally Posted by Nawnie View Post
I am having the same issue.

Nawnie
Both of you should start calling Transmission service shops NOT general repair shops and talk to them. You want a shop familiar with Chrysler transmission and can read and Diagnose the TCM. This is specialized work and most general repair shops are not set up to handle this work as seems to be indicated by your responses.
Any advise given to diagnose the issues call for a more familiar experience level working on these type of transmission and computer control vehicles.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #8 (permalink)  
Old 19 Jan 2016, 01:12 pm
rg1 rg1 is offline
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 16
Default Re: 2007 2.4 Touring - TCM issues?

thought I would reply...but long story short...I think the TCM issues were due to faulty battery / connector....once I had that taken care of, no issues...I was getting the cam shaft sensor error, and had that replaced....car was running great, better then ever has....unfortunately, now I have a fried turbo.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Touring, will 215/60/15 work? TroyO Wheels, Tires, Suspension 3 27 Jan 2014 01:52 am
2007 A/C and Overheating issues Michelle_T General PT Cruiser Discussions 30 26 Apr 2013 02:07 pm
2007 PT Cruiser Touring Ed. rjlong1989 Tech & Performance Forum 6 06 May 2011 11:50 am
Considering 06 Touring, but it has a few issues William_F General PT Cruiser Discussions 13 15 Feb 2010 01:07 pm
2007 TOURING CRUISER bompa45 Wheels, Tires, Suspension 0 14 Apr 2009 02:46 pm


All times are GMT -5. The time now is 08:08 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors