PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Camshaft sensor and P0340

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Mar 2014, 04:10 pm
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 2
Default Camshaft sensor and P0340

Hello,

I am a newbie to the forum, hoping someone can help me. When I was driving on highway 60-65 mph, suddenly the engine light came on and engine start cycle up and down. What I mean, if I apply the gas it will go about 3000 rpm and then suddenly drop down 2000 and then go up and again etc. I managed to get out the highway. It kept doing up regardless of the gear I was in. When checked the diagnostic code, it returned the code P0340. Thanks the info on the forum, I learned this either means some battery issue, or an error with camshaft sensor. So, I got a new one, and again thanks to this forum (you guys are great), I replaced it. I also checked the voltage on the battery, which reads 12.66V. I didn't check the amps, because I couldn't figure out how to do it. But I don't think its that because I notice no cranking issue when I start the car.

Anyways, I do not have the issue when I am driving anymore. I went up to the highway, made sure the RPMs are way above than when I had the issue. Try to accelerate aggressively so forth. Drove about 10 miles, and there was no sign of that stuttering. But, when the car is parked or N, if I push the gas and increase the RPM same thing starts to happen between 3500-4000 RPM. I never this before so I can't tell it started to happen with my incident, or its just normal behavior (though doesn't feel like it).

So my normal driving is fine, but I still would like to know if there is any other issues so that I avoid another highway scare.

There are some fairly stupid around where I live, who would try to take over or won't yield to a car that's clearly in distress and have its flashers on trying to make to the side of the road.
Reply With Quote
  #2 (permalink)  
Old 29 Mar 2014, 07:41 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Lightbulb Re: Camshaft sensor and P0340

Quote:
Originally Posted by cruiser_wa View Post
But, when the car is parked or N, if I push the gas and increase the RPM same thing starts to happen between 3500-4000 RPM. I never this before so I can't tell it started to happen with my incident, or its just normal behavior (though doesn't feel like it).
Are you still getting the P0340 code,or maybe a new one?
I'm not sure if that's the rev-limiter kicking in @ 3500-4000,but I haven't really revved up like that when in 'N' either.
If your still getting the P0340 code,you might want to check the harness from the connection back,and see if the wiring insulation is hardened,brittle,or broken.....
Or if you purchased an aftermarket CPS,there is always the possibility it's no-good right out of the box(fairly common complaint w/aftermarket replacements).
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #3 (permalink)  
Old 29 Mar 2014, 11:07 pm
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 2
Default Re: Camshaft sensor and P0340

Hi,

I drove about 10 miles, and engine light didn't come back on. It shows "done" and no other code. Hopefully it will stay that way

Meanwhile I am curious about the rev-limiter kicking in P or N.
Reply With Quote
  #4 (permalink)  
Old 31 Mar 2014, 07:18 pm
SanchB's Avatar
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 1
Default Re: Camshaft sensor and P0340

Sounds to me like a definite rev-limiter. I know mine does this, but it's a turbo and I have read that is normal. I'm assuming it would be the same even for non turbos if it's a manufacturers doing, but better check that statement... U know what they say when you assume.
__________________
Brandon S. From Central California. Original owner of a 2004 Cool Vanilla Touring Edition 2.4L Turbo. Automatic transmission w/ 62,000 miles. Chrome package, spoiler, K&N air filter, and Premier CD deck w/MB Quart interior speakers 😎😎😎
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CrankShaft Sensor/CamShaft Sensor Questions PTMomma Tech & Performance Forum 8 12 Aug 2014 01:43 pm
CamShaft Sensor stan General PT Cruiser Discussions 17 12 Feb 2014 05:01 pm
Camshaft sensor? RedEmma Tech & Performance Forum 3 26 Jun 2012 01:45 pm
Crankcase sensor /Camshaft sensor PigFarmer Tech & Performance Forum 21 20 Mar 2012 07:01 pm
P0340 Camshaft Position Sensor replacement '07 TurboLite crooozin Tech & Performance Forum 0 02 Mar 2011 03:39 pm


All times are GMT -5. The time now is 11:50 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors