PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
01 pt cruiser speedometer not working

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Apr 2014, 01:02 pm
Fresh Cruiser
 
Join Date: Feb 2014
Posts: 5
Default 01 pt cruiser speedometer not working

Speedometer not working after changing cluster lights and transmission shift solenoid gasket . Cant get speedometer to work driving me crazy did self check on cluster and all gauges move, checked pins behind cluster all seem good ,replaced transmission output solenoid no codes or ck engine light, bought used cluster on ebay same thing no speedo. All gauges work but speedo. Did reboot on computer nothing seems to help any advice greatly appreciated im lost thanks gary
Reply With Quote
  #2 (permalink)  
Old 05 Apr 2014, 03:43 pm
Senior Cruiser
 
Join Date: Nov 2010
Location: oak creek, wi
Posts: 1,149
Default Re: 01 pt cruiser speedometer not working

just a thought, check to make sure the electrical connection from the speedo is connected to the transmission. I say that because you stated you worked on the transmission solenoid.
__________________
2005 Toyota Camry LE Salsa Red (Wife's)
2002 Automatic N/A (Mine) Inferno Red
2016 Kia Soul Plus Black
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
manual trans. code p0501 - speedometer not working shelbyzman Tech & Performance Forum 3 02 Jan 2014 04:26 pm
speedometer stopped working - p0500 code shelbyzman Tech & Performance Forum 4 30 Dec 2013 03:03 am
Odometer problem, speedometer working fine freshman6969 Tech & Performance Forum 11 08 Jul 2012 03:56 pm
Speedometer jumping, fobs not working Gabriella General PT Cruiser Discussions 6 08 Dec 2010 07:10 pm
2006 PT - Speedometer AND Odometer not working SweepTheLeg Tech & Performance Forum 8 04 Sep 2009 04:33 pm


All times are GMT -5. The time now is 01:18 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors