PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
A/C problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Apr 2014, 01:36 am
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 16
Default A/C problems

Hi there, so I was driving down the highway last summer and using the ac and it was blowing ice cold, then out of nowhere it started blowing hot, all in an instant. So I checked the refrigerant with the gauge and it was in the red. When I put the air on in the car it blows, but like its outside air. The heater works perfectly fine. Anyone have an idea whats going on?
Thank you for any and all assistance.
Reply With Quote
  #2 (permalink)  
Old 22 Apr 2014, 05:12 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: A/C problems

Is the compressor going on and off like it should? If your in the red on your reading, you might have lost enough R134a for the system to stop working.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 22 Apr 2014, 12:16 pm
Fresh Cruiser
 
Join Date: Apr 2010
Posts: 14
Default Re: A/C problems

What is the pressure on your low and high? Im having a Simalar problem, my low side is 60 psi while my high is 25psi! And my unit has the 18 ounces that it calls for! Maybe you're just low on freon
Reply With Quote
  #4 (permalink)  
Old 22 Apr 2014, 04:12 pm
thecabinguy's Avatar
Cool Cruiser
 
Join Date: Aug 2013
Location: Prescott, AZ
Posts: 277
Default Re: A/C problems

Quote:
Originally Posted by imlost33 View Post
Hi there, so I was driving down the highway last summer and using the ac and it was blowing ice cold, then out of nowhere it started blowing hot, all in an instant. So I checked the refrigerant with the gauge and it was in the red. When I put the air on in the car it blows, but like its outside air. The heater works perfectly fine. Anyone have an idea whats going on?
Thank you for any and all assistance.
The exact same thing happened to me, and I was on a highway, too. Just stopped working. Turns out there was some sort of valve that was leaking some and leaked out the freon. Fixed valve and topped of freon and the A/C has been working ever since.
__________________
Prescott, Arizona, home of forested mountains, 5 lakes (well, four lakes and one big pond), and Arizona's Christmas City (my home 6,000 feet elevation) - 2005 Touring & 2002 Limited - both patriot blue & factory stock
Reply With Quote
  #5 (permalink)  
Old 22 Apr 2014, 07:01 pm
Fresh Cruiser
 
Join Date: Mar 2014
Posts: 16
Default Re: A/C problems

The guy that replaced the clutch plate said the compressor is coming on. I checked the gauge before I tried to fill it with freon and it was in the red so I attached a can and tried to fill it to see if the gauge would change. It stayed in the red but it doesn't seem like the can is any lighter and I tied for about 10 minutes to fill it. It's reading very high in the red both on low and on high. I even bought the can with the stop leak but like I said it doesn't seem like anything is going into the system from the can.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced PCM Old Problems Fixed - New Problems Arise!! adstatus Tech & Performance Forum 4 12 Oct 2013 07:49 am
03 A/C Problems BigSam Tech & Performance Forum 3 12 Jun 2012 07:03 pm
Car Problems BabyBlueCruiser General PT Cruiser Discussions 11 11 Aug 2010 09:43 pm
DC3 problems alceryes General Turbo Discussions 5 09 Sep 2006 03:20 am
Problems, and i need some help mike257 General Turbo Discussions 25 13 Aug 2006 05:03 pm


All times are GMT -5. The time now is 03:35 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors