PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Electrical issues ie. fog lights engine codes 04 PT turbo

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 May 2014, 03:09 pm
Fresh Cruiser
 
Join Date: May 2014
Location: california
Posts: 1
Default Electrical issues ie. fog lights engine codes 04 PT turbo

1. original owner.
2. 61k on it
Issues:
1. A couple of years ago I was out of country, my wife had this experience with this car:
2. smoke coming out of hazzard switch which includes the fog lights switch etc.
3. Stopped car, horn honking, lights flashing, could not lock car.
4. My son in law tried trouble shooting, could not resolve. Removed fuse #8 or # 16. Car worked again. No engine light on.
5. Present situation, A couple of days ago my wife tried starting car, did not start for quiet a while, finally started, while driving car sputtered and wanted to shut down.( engine hesitated like out of gas).
6. That went away but engine light came on.
7. I checked codes showed po340 and po 325.
8. Consulted a friend, mentioned to check battery cables, clean up and reconnect. Also after that to reset codes and see what if anything would show up again.
9. After reconnecting battery, no engine light on, car ran fine.
10. When I realized fuse had been removed, I put back in and light switch began to smoke, fog lights on, even thought the switch was not turned on. Quickly removed fuse.
11. I had replaced over two years ago the fog light switch (purchased from now Auto Zone, Life time warranty) everything was working fine until item #2 started.
12. Finally a decided to see if I could fix problem with fog lights.
13. Got new switch from AutoZone, installed, and fog lights worked but hazard and blinkers did not.
14. Thought maybe bad switch, got another one, installed same problem. Returned and re-installed existing switch, no fog lights but turn signal light work. But have to remove fuse.
15. I have driven car several times, no engine lights on, seems to be working OK.

What could be wrong with the fog lights and switch?

Anyone have any issues like this? I am somewhat hesitant to take to dealer, because last time I had an isssue with this car, with engine light on , after 300.00 plus dollars, a vacuum pump replacement, a few days later engine light came on again. After one hour, the mechanic from dealer came out invited me to the shop, and proceeded to tell me that the problem was the seal on the gas cap. If he would have looked at that the first time I would have saved the $300. 00 dollars. Dealer did not return original part, could not find, Dealer refused to refund for the part exchanged which was not the original problem or give me some credit.

A few months later engine light came on again, I checked the gas cap, rubber seals was slightly cracked, I applied silicone to the rubber, it has now been several years, same gas cap, no engine light on and car works fine.

Bottom line I have an electrical problem that needs to be solved. Any suggestions?
Thanks
Reply With Quote
  #2 (permalink)  
Old 08 May 2014, 03:13 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Electrical issues ie. fog lights engine codes 04 PT turbo

When you put the new switch in, did you take the little black box from the old switch and put it on the new switch? That little black box controls the Hazard and maybe the blinkers too. It doesn't come with the new switch so you need to transfer it over from the old to the new one.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 08 May 2014, 05:46 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Electrical issues ie. fog lights engine codes 04 PT turbo

Quote:
Originally Posted by CREWZIN View Post
When you put the new switch in, did you take the little black box from the old switch and put it on the new switch? That little black box controls the Hazard and maybe the blinkers too. It doesn't come with the new switch so you need to transfer it over from the old to the new one.
Correct.
Compare old and new switches and you'll see. Move the blinker module over and you should be fine.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine, ABS and Trac Lights on - Garage reorted no error codes AndyJay Tech & Performance Forum 15 03 Apr 2014 12:43 pm
Codes, codes, codes... Desperately need engine light help... cdc3jj General PT Cruiser Discussions 9 01 Sep 2012 07:52 am
2005 dream cruiser turbo electrical issues i think maiajoi General Turbo Discussions 2 13 Mar 2012 04:38 pm
Electrical issueS... (fog lights always turned on... radio display turned off.. etc) benoit_bertrand Sound and Security Forum 5 09 May 2011 03:09 pm
Help Please ! Electrical issues. thegooch2 Tech & Performance Forum 5 16 Aug 2010 06:53 am


All times are GMT -5. The time now is 07:30 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors