PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Having issues with my starter relay.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 May 2014, 09:27 pm
Fresh Cruiser
 
Join Date: Apr 2014
Posts: 6
Default Having issues with my starter relay.

Okay so I'm hopefull that I can explain this all within the first attempt. Couple weeks back, I had my 2006 Pt Cruiser parked out in front of my school. It's been having problems lately where i need to move the battery cables around to get the car starting. Recently, when I try to turn it on, it stops making the clicking sound. My dad ran a copper wire from the starter to the battery to directly get a jump going when i turned the key and it instantly turned on. We've had our car sitting on the drive way to about a month now.He's been trying to see what the problem is. We recently spotted some liquid outside of the transmission solenoid and my dads wanting to know if the car refusing to start and this leak are in somehow related to one another.
Reply With Quote
  #2 (permalink)  
Old 21 May 2014, 03:24 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Having issues with my starter relay.

Leak would have nothing to do with starter.
It would seem obvious what your problem is - wiring. You mentioned moving battery cables and that it works with a direct wire.
Get under and trace cable from starter with a piece of string, then take the string to AdvanceAuto, etc, and buy a cable of that length -get a cable at least as fat (fatter is better) as the one that's there.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
06 PT: Starter relay? Kell Tech & Performance Forum 15 19 Oct 2017 10:40 pm
Removed starter relay, Now Pt cruiser Cranks but wont start!! iponnet22 General PT Cruiser Discussions 2 13 Oct 2012 11:26 pm
Starter issues... AntonioT42 Tech & Performance Forum 4 28 May 2012 01:07 pm
Hid kit relay beakerss Exterior Accessories Forum 6 03 Oct 2011 09:50 pm
2001 cruiser fan and relay issues azdave General PT Cruiser Discussions 3 14 Jul 2009 05:02 pm


All times are GMT -5. The time now is 08:41 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors