PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Cooling Fan Failed

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 May 2014, 09:17 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Cooling Fan Failed

Well, my Cruiser just turned 70,000 miles and the cooling fan decided to crap out today. It was the high speed side. Luckily it hasn't got really hot here yet so all I had to do was not run the AC when stopped.

Picked up a Dorman unit at Autozone and the install went pretty easy. Being I have replaced the fan in my daughter's 06 twice it gets easier each time lol. This fan is a lot quieter then the others and much quieter then the factory unit.
Reply With Quote
  #2 (permalink)  
Old 24 May 2014, 09:34 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Cooling Fan Failed

Wow, makes me feel lucky that at nearly 120,000 miles I still have original fan...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 20 Jun 2014, 01:02 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Cooling Fan Failed

Help me! I can't seem to get my fan unit out! To lift it up, I have to pull off the top hose from my radiator, but still cannot get it out!!

PLEASE HELP! How do you get it out???

if you know, please email me robin.r.huggins at gmail.com (yes, you know what that means, remove spaces and at and replace with @).

I'm desperate!
Reply With Quote
  #4 (permalink)  
Old 20 Jun 2014, 01:10 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Cooling Fan Failed

Robin,

Sent you an email; U-Tube video on the Turbo radiator fan replacement.

Chromenut likes this.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 20 Jun 2014, 03:06 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Cooling Fan Failed

OMG thank the Lord that Crewzin sent me that video. I had no clue how easy taking off the front end was. Only thing I had to disconnect out of everything, was the top radiator hose, so gotta get a gallon of anti-freeze now, but everything is now working perfectly, again!

Carey, thank you so very much, again, for always being so darned helpful!
Reply With Quote
  #6 (permalink)  
Old 20 Jun 2014, 03:21 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Cooling Fan Failed

No problem Robin. Glad you got it fixed.

I'll be coming up your way (Midlothian) at the end of July to spend some quality time with the Grandkids. Will give ya a call.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #7 (permalink)  
Old 20 Jun 2014, 07:11 pm
Banned
 
Join Date: May 2011
Location: Dallas Texas
Posts: 3,722
Default Re: Cooling Fan Failed

Can I not ask chromey about cruiser of the month?????
Reply With Quote
  #8 (permalink)  
Old 20 Jun 2014, 07:19 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Cooling Fan Failed

Send him a PM.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #9 (permalink)  
Old 20 Jun 2014, 07:22 pm
Banned
 
Join Date: May 2011
Location: Dallas Texas
Posts: 3,722
Default Re: Cooling Fan Failed

Thought it would be better to ask him here, I will pm him thx
Reply With Quote
  #10 (permalink)  
Old 20 Jun 2014, 07:24 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Cooling Fan Failed

Don't you think he was a little busy in the middle of a radiator fan swap which he needed help with ???
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed and new cooling fan and cooling temp sensor & still the fan doesn't kick in rdvarona Southeast PT Forum 18 31 May 2013 09:14 pm
failed mot !!! ricksatluz Europe PT Forum 9 02 Mar 2013 07:11 am
Dorman fan failed Ray_Dockrey Tech & Performance Forum 2 24 Jan 2013 04:15 am
it says upload failed?????????? SnoGirl Feedback and Support 5 12 Oct 2009 12:34 am


All times are GMT -5. The time now is 09:19 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors