PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
engine light comes on and loss of power when I accelerate hard

 
Like Tree1Likes
  • 1 Post By Busted_PT

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 May 2014, 12:34 pm
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 34
Default engine light comes on and loss of power when I accelerate hard

Whenever I accelerate, the the Check Engine light comes on and stays constant (does not flash).
This was happening before and the Check Engine Light would be flashing, code said "2 misfire." Changed plugs and wires, did not get rid of the light (but it was time to change them anyway)
Replaced engine (which was pretty worn out and shot, burnt valves, leaky compression, etc) with a good rebuilt engine from a mechanic I'd put against anybody and trust as a friend (retired service manager at local dealership). He rebuilt it himself and it had 65K on it. Engine sounds great and smooth. Also replaced timing belt and other components while he was in there.
Now when I start it, there is (usually) no check engine light, but the minute I accelerate, I hear "DING", Check Engine Light comes on, and immediately significant loss of power. Light stays on. Start it later that day, same thing....fine till I accelerate (like to punch it to pass someone etc). A slow acceleration does not affect it. Only a hard one.
Taking it to my mechanic friend tomorrow to get the code read etc... Just wanted to run it past all of you first......ignition coil? sensor? fuel injector(s)? Maybe even a fuel pump/filter issue? (it's the original one)
BTW, replaced the engine just a few days ago. Put the brand new plugs and wires on it also.
2005 PT Cruiser convertible, 2.4 nonturbo base model, auto tranny.
135K, but just dropped rebuilt engine w/65K on it.

Last edited by kpl1228; 27 May 2014 at 12:59 pm.
Reply With Quote
  #2 (permalink)  
Old 27 May 2014, 03:02 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,891
Lightbulb Re: engine light comes on and loss of power when I accelerate hard

You never said what codes you been getting
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #3 (permalink)  
Old 27 May 2014, 03:09 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,793
Default Re: engine light comes on and loss of power when I accelerate hard

Quote:
Originally Posted by Busted_PT View Post
You never said what codes you been getting
Danny you missed the part he said "Taking it to my mechanic friend tomorrow to get the code read etc."


I suppose he wanted all to guess the problem without those all important DTC's?
I think it may be a problem with low tire pressure?
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #4 (permalink)  
Old 27 May 2014, 04:38 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,891
Default Re: engine light comes on and loss of power when I accelerate hard

Quote:
Originally Posted by NitroPT View Post
Danny you missed the part he said "Taking it to my mechanic friend tomorrow to get the code read etc."


I suppose he wanted all to guess the problem without those all important DTC's?
I think it may be a problem with low tire pressure?
I don't understand rebuilding a 65k motor to start with. But you know my theory about service managers.
IOwnMugsy likes this.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine power loss help demon666 Tech & Performance Forum 18 12 Aug 2013 09:08 pm
Engine light is on, car hesitates/sputters when trying to accelerate past 30 mph.. quietcharm23 Tech & Performance Forum 2 03 Nov 2011 09:42 am
Check engine light: Amber Light: power loss dbleclk Turbo Performance 2 06 Jul 2011 06:12 am
Random power loss, glow plug light??? toooldforthis General PT Cruiser Discussions 30 27 Mar 2011 11:11 am
Loss of Engine Power. b0b88 Tech & Performance Forum 1 03 Aug 2008 05:20 pm


All times are GMT -5. The time now is 04:17 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors