PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
k&N filter system problem.maybe

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Apr 2004, 04:12 pm
Senior Cruiser
 
Join Date: Jan 2004
Location: Columbus, Nebraska, USA.
Posts: 1,574
Default k&N filter system problem.maybe

I just installed a K&N system on my 04 turbo lite. It went on fine
had no problems.Started it up. It was louder ,but no problem.I
took it for a test drive and every time I let up on the gas there is
sound like air releasing like if you let air out of a tire.[:I]I checked both the vacuum hoses, checked clamp at the turbo.everything seems to be tight and fine and I can't get it to do this setting in the driveway and stepping on the gas, only under load. Is this
something that is supposed to happen? I've never had one of these before.If not, any ideas what could be wrong? It doesn't last long
just a short hiss.Thanks
Reply With Quote
  #2 (permalink)  
Old 18 Apr 2004, 06:26 pm
Fanatic Cruiser
 
Join Date: Jan 2003
Location: San Juan, Puerto Rico, USA.
Posts: 566
Default

Did you install a K&N system or just a Drop-in filter in the OEM airbox?

Ian
__________________
Reply With Quote
  #3 (permalink)  
Old 18 Apr 2004, 06:35 pm
Senior Cruiser
 
Join Date: Jan 2004
Location: Columbus, Nebraska, USA.
Posts: 1,574
Default

The whole system. have checked it several times, everything seemsto be tight and right.Just don't want to screw something else up.
__________________
04 cool vanila Limited Turbo




Wife has a 03 limited
(Steel Blue)
Reply With Quote
  #4 (permalink)  
Old 18 Apr 2004, 07:20 pm
Regular Cruiser
 
Join Date: Mar 2003
Location: Rockford, Michigan, USA.
Posts: 146
Default

I had a similar problem on my '02 PT 5-Speed after I installed a K&N FIPK. I took it to the dealer and it turned out that I had an intake manifold leak. The dealer replaced the intake manifold (the large black plastic piece in the front center part of the engine compartment which connects to the engine that has the ribs on top) gasket and that solved the "sounds like an air leak" problem. I think maybe somebody was leaning on the intake manifold with too much body weight. Maybe your problem is similar.
__________________
[IMG]|2003 PT GT 5-Speed | Mopar Stage 1 | Mopar 2.5\" Dual Exhaust | Mopar Short-Throw Shifter | Mopar HO Plastic Intake | Mopar Boost Gauge | AGP WGA/BOP | APC Carbon Fiber Taillights | Axis 19x8 Wheels/Yokohama 225/35ZR19 Parada Spec2 Tires | BTG Strut Tower Brace | BTG Billet Shorty Antenna | Eibach Anti-Sway Bars | HKS SSQV BOV | JLM Motor/Tranny Mounts | KW Variant 1 Coilovers | Maxxfab 3\" Downpipe | NGK Iridiums | Prototypepower UCP/CAI v5 | PTeazer Smoothie Roll Pan | Screamin\' Demon Coil/Livewires | StopTech Slotted Rotors/Hawk HPS Pads/Stainless Steel Lines | Unorthodox Racing Underdrive Pulley|
Reply With Quote
  #5 (permalink)  
Old 18 Apr 2004, 07:46 pm
Senior Cruiser
 
Join Date: Dec 2003
Location: Orange, CA, USA.
Posts: 1,019
Default

You have the turbo so you're going to hear things the naturally aspirated cars don't, especially now that you've swapped out the stock airbox and intake hose with the K&N setup. I'm inclined to think that everything you're hearing is completely normal; when I put Adam's full intake kit on my car you could hear all sorts of amazing sounds, including a fluttering noise when driving slowing through my neighborhood and letting off the gas. You probably couldn't mimic the sounds while revving at idle because you can't get the turbo to fully spool - I believe the idle limiter (or whatever you want to call it) won't let you run over something like 3000rpm before kicking in when in park or even neutral.
Reply With Quote
  #6 (permalink)  
Old 18 Apr 2004, 08:02 pm
Cool Cruiser
 
Join Date: Mar 2003
Location: Pittsburgh, PA.
Posts: 320
Default

Jimbo,

You are hearing the recirculating blow-off valve (really the surge valve) emptying into the intake pipe. You did not notice this due to the silencer built into the stock tube you replaced. The noise will not surface until the turbo has spooled up. A brief tap of the throttle will not create enough boost that warrants surge valve venting.

To be sure, make sure the hose from the surge valve is connected on both ends. There is a chance you may have pulled it off when you removed the stock intake tube or installed the FIPK tube. I know, I did it when I put the MOPAR BOV conversion kit on. I had to remove the intake tube to access the surge valve bolts.

Report with your findings!

Scott
__________________
\"If you choose not to decide, you still have made a choice.\"
Reply With Quote
  #7 (permalink)  
Old 18 Apr 2004, 08:43 pm
Senior Cruiser
 
Join Date: Jan 2004
Location: Columbus, Nebraska, USA.
Posts: 1,574
Default

Where is the surge valve located?
So this is normal?
__________________
04 cool vanila Limited Turbo




Wife has a 03 limited
(Steel Blue)
Reply With Quote
  #8 (permalink)  
Old 18 Apr 2004, 09:06 pm
Senior Cruiser
 
Join Date: Jan 2004
Location: Columbus, Nebraska, USA.
Posts: 1,574
Default

Scott,Checked all hoses. They are all on.
Went for a short drive.It does it when I step on gas
and than let off.If I'm driving say like up to 40 MPG
and when I get there I quit excellerating it doesn't do it.
I wouldn't hear it if the radio was on.It's just a short
burst like a pressure relief.I heared all the noises that
Mike was talking about. I knew they were normal, but this was weired
having never had a turbo before.If it is normal I'll turn the radio up.
__________________
04 cool vanila Limited Turbo




Wife has a 03 limited
(Steel Blue)
Reply With Quote
  #9 (permalink)  
Old 18 Apr 2004, 10:40 pm
Cool Cruiser
 
Join Date: Mar 2003
Location: Pittsburgh, PA.
Posts: 320
Default

Jimbo,

Sounds like you have it covered. The surge valve, btw, is located on the turbo housing facing the front of the car. The surge valve is the aluminum housing with the small, off-white hard line attached to it (look at the instructions to install the Mopar BOV for a better picture: http://home.comcast.net/~dtibs/mprbov/ )

Scott

P.S.- If you don't like the sound you have now, do not get the Mopar BOV conversion kit, it will drive you nuts.
__________________
\"If you choose not to decide, you still have made a choice.\"
Reply With Quote
  #10 (permalink)  
Old 18 Apr 2004, 10:50 pm
Fanatic Cruiser
 
Join Date: May 2003
Location: Rhode Island.
Posts: 950
Default

With a intake that is higher flow rated, your gonna hear a whole host of sounds that the stock system shielded you from.
Remove the stock intake hose, and the large silencer is gone. You almost hear the air getting sucked in and start and whenever the turbo spools or lets up, your going to know.
Since I put on my Airraid, those sounds are much more prominent. Evven noted it more once I removed the silencer going to the wheels well, I could hear the turbo even more clearly.
__________________

2003 GT Inferno Red,5-spd,Eibach Springs,Koni Sport Adjustables, Eibach front and rear Sway Bars, Mopar Stage 1,Mopar BOV,Custom 2.5\" Dual Tip Exhaust (Magnaflow),Hurst Short Throw Shifter, Pioneer DEH6500 Headunit, RF Punch 300 and 301 Amps,RF 12\" Sub and MB Quart Reference and Premium Speakers,Ronal RT 17x7.5\'s with Michelin Pilot Sport 225/45ZR17s, Koni Adjustible shocks, Keystone single scoop, GT Airraid Intake, Mopar Ground Effects
Homepage:
http://www.cardomain.com/id/ptgtredman

http://blueman.ptenthusiasts.net/index.html
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cabin air filter AlmondTurbo General PT Cruiser Discussions 44 27 Jul 2012 06:31 pm
Error Codes skylight Tech & Performance Forum 7 28 Apr 2011 03:34 pm
Error Codes thegoldpt Turbo Performance 6 07 Apr 2007 02:26 pm
Error Code List skylight General Turbo Discussions 6 07 Apr 2007 02:11 pm
Inilex Satellite Tracking System for PT Cruiser Tee It High General PT Cruiser Discussions 4 18 Jan 2005 11:47 pm


All times are GMT -5. The time now is 02:09 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors